* [PATCH] x86/traps: use conditional_{cli,sti} in preempt_conditinal_{cli_sti}
@ 2016-01-16 12:58 Alexander Kuleshov
2016-01-16 19:06 ` Borislav Petkov
0 siblings, 1 reply; 3+ messages in thread
From: Alexander Kuleshov @ 2016-01-16 12:58 UTC (permalink / raw)
To: Thomas Gleixner
Cc: Ingo Molnar, H . Peter Anvin, x86, Borislav Petkov,
Andy Lutomirski, Dave Hansen, Wang Nan, linux-kernel,
Alexander Kuleshov
The 3d2a71a596bd9 commit (x86, traps: converge do_debug handlers by
Alexander van Heukelum <heukelum@fastmail.fm>) introduces two functions:
preempt_conditional_sti/cli() which are enables/disables interrupts
depends on state of the interrupt enable flag and increments/decrements
the preempt counter.
In the same time arch/x86/kernel/traps.c defines two similar inline
functions: conditional_{sti,cli} which are do the same, but without
touch of the preempt counter. Let's use these functions in the
preempt_conditional_{sti,cli} instead of duplication of 'if' statemets.
Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
---
arch/x86/kernel/traps.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/arch/x86/kernel/traps.c b/arch/x86/kernel/traps.c
index ade185a..30ec8fa 100644
--- a/arch/x86/kernel/traps.c
+++ b/arch/x86/kernel/traps.c
@@ -92,8 +92,7 @@ static inline void conditional_sti(struct pt_regs *regs)
static inline void preempt_conditional_sti(struct pt_regs *regs)
{
preempt_count_inc();
- if (regs->flags & X86_EFLAGS_IF)
- local_irq_enable();
+ conditional_sti(regs);
}
static inline void conditional_cli(struct pt_regs *regs)
@@ -104,8 +103,7 @@ static inline void conditional_cli(struct pt_regs *regs)
static inline void preempt_conditional_cli(struct pt_regs *regs)
{
- if (regs->flags & X86_EFLAGS_IF)
- local_irq_disable();
+ conditional_cli(regs);
preempt_count_dec();
}
--
2.7.0.25.gfc10eb5
^ permalink raw reply related [flat|nested] 3+ messages in thread
* Re: [PATCH] x86/traps: use conditional_{cli,sti} in preempt_conditinal_{cli_sti}
2016-01-16 12:58 [PATCH] x86/traps: use conditional_{cli,sti} in preempt_conditinal_{cli_sti} Alexander Kuleshov
@ 2016-01-16 19:06 ` Borislav Petkov
2016-01-16 22:46 ` Andy Lutomirski
0 siblings, 1 reply; 3+ messages in thread
From: Borislav Petkov @ 2016-01-16 19:06 UTC (permalink / raw)
To: Alexander Kuleshov
Cc: Thomas Gleixner, Ingo Molnar, H . Peter Anvin, x86,
Andy Lutomirski, Dave Hansen, Wang Nan, linux-kernel
On Sat, Jan 16, 2016 at 06:58:07PM +0600, Alexander Kuleshov wrote:
> The 3d2a71a596bd9 commit (x86, traps: converge do_debug handlers by
> Alexander van Heukelum <heukelum@fastmail.fm>) introduces two functions:
> preempt_conditional_sti/cli() which are enables/disables interrupts
> depends on state of the interrupt enable flag and increments/decrements
> the preempt counter.
>
> In the same time arch/x86/kernel/traps.c defines two similar inline
> functions: conditional_{sti,cli} which are do the same, but without
> touch of the preempt counter. Let's use these functions in the
> preempt_conditional_{sti,cli} instead of duplication of 'if' statemets.
>
> Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
> ---
> arch/x86/kernel/traps.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/arch/x86/kernel/traps.c b/arch/x86/kernel/traps.c
> index ade185a..30ec8fa 100644
> --- a/arch/x86/kernel/traps.c
> +++ b/arch/x86/kernel/traps.c
> @@ -92,8 +92,7 @@ static inline void conditional_sti(struct pt_regs *regs)
> static inline void preempt_conditional_sti(struct pt_regs *regs)
> {
> preempt_count_inc();
> - if (regs->flags & X86_EFLAGS_IF)
> - local_irq_enable();
> + conditional_sti(regs);
What I would do is kill both preempt_conditional_sti() and
preempt_conditional_cli() instead. Why?
Because call sites become more readable:
preempt_disable();
if (regs->flags & X86_EFLAGS_IF)
local_irq_enable();
and
if (regs->flags & X86_EFLAGS_IF)
local_irq_disable();
preempt_enable_no_resched();
Those preempt_* variants are just silly.
Yes, I'd delete conditional_cli() because nothing uses it. And since I'm
deleting crap, I'd delete conditional_sti() too because it's naming is
ugly. You have to know that "STI" means Set Interrupt Flag. Now, if it
were called
cond_local_irq_enable()
that would be better.
So yeah, IMO, the most understandable variant would be:
preempt_disable();
cond_local_irq_enable();
and the opposing pair:
cond_local_irq_disable();
preempt_enable_no_resched();
And *that* is actually understandable at a quick glance.
But that's just me.
--
Regards/Gruss,
Boris.
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB 21284 (AG Nürnberg)
--
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] x86/traps: use conditional_{cli,sti} in preempt_conditinal_{cli_sti}
2016-01-16 19:06 ` Borislav Petkov
@ 2016-01-16 22:46 ` Andy Lutomirski
0 siblings, 0 replies; 3+ messages in thread
From: Andy Lutomirski @ 2016-01-16 22:46 UTC (permalink / raw)
To: Borislav Petkov
Cc: Alexander Kuleshov, Thomas Gleixner, Ingo Molnar, H . Peter Anvin,
X86 ML, Andy Lutomirski, Dave Hansen, Wang Nan,
linux-kernel@vger.kernel.org
On Sat, Jan 16, 2016 at 11:06 AM, Borislav Petkov <bp@suse.de> wrote:
> On Sat, Jan 16, 2016 at 06:58:07PM +0600, Alexander Kuleshov wrote:
>> The 3d2a71a596bd9 commit (x86, traps: converge do_debug handlers by
>> Alexander van Heukelum <heukelum@fastmail.fm>) introduces two functions:
>> preempt_conditional_sti/cli() which are enables/disables interrupts
>> depends on state of the interrupt enable flag and increments/decrements
>> the preempt counter.
>>
>> In the same time arch/x86/kernel/traps.c defines two similar inline
>> functions: conditional_{sti,cli} which are do the same, but without
>> touch of the preempt counter. Let's use these functions in the
>> preempt_conditional_{sti,cli} instead of duplication of 'if' statemets.
>>
>> Signed-off-by: Alexander Kuleshov <kuleshovmail@gmail.com>
>> ---
>> arch/x86/kernel/traps.c | 6 ++----
>> 1 file changed, 2 insertions(+), 4 deletions(-)
>>
>> diff --git a/arch/x86/kernel/traps.c b/arch/x86/kernel/traps.c
>> index ade185a..30ec8fa 100644
>> --- a/arch/x86/kernel/traps.c
>> +++ b/arch/x86/kernel/traps.c
>> @@ -92,8 +92,7 @@ static inline void conditional_sti(struct pt_regs *regs)
>> static inline void preempt_conditional_sti(struct pt_regs *regs)
>> {
>> preempt_count_inc();
>> - if (regs->flags & X86_EFLAGS_IF)
>> - local_irq_enable();
>> + conditional_sti(regs);
>
> What I would do is kill both preempt_conditional_sti() and
> preempt_conditional_cli() instead. Why?
>
> Because call sites become more readable:
>
> preempt_disable();
>
> if (regs->flags & X86_EFLAGS_IF)
> local_irq_enable();
>
> and
>
> if (regs->flags & X86_EFLAGS_IF)
> local_irq_disable();
>
> preempt_enable_no_resched();
>
> Those preempt_* variants are just silly.
>
> Yes, I'd delete conditional_cli() because nothing uses it. And since I'm
> deleting crap, I'd delete conditional_sti() too because it's naming is
> ugly. You have to know that "STI" means Set Interrupt Flag. Now, if it
> were called
>
> cond_local_irq_enable()
>
> that would be better.
>
> So yeah, IMO, the most understandable variant would be:
>
> preempt_disable();
> cond_local_irq_enable();
>
> and the opposing pair:
>
> cond_local_irq_disable();
> preempt_enable_no_resched();
>
> And *that* is actually understandable at a quick glance.
>
> But that's just me.
>
I agree. Every time I look at those helpers I wonder what the condition is.
Also, "preempt_conditional_sti" meaning "enable interrupts if they
were enabled but *don't* enable preemption" just seems backwards.
--Andy
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2016-01-16 22:46 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2016-01-16 12:58 [PATCH] x86/traps: use conditional_{cli,sti} in preempt_conditinal_{cli_sti} Alexander Kuleshov
2016-01-16 19:06 ` Borislav Petkov
2016-01-16 22:46 ` Andy Lutomirski
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox