From: Dave Martin <Dave.Martin@arm.com>
To: Suzuki K Poulose <suzuki.poulose@arm.com>
Cc: linux-arm-kernel@lists.infradead.org, mark.rutland@arm.com,
ckadabi@codeaurora.org, ard.biesheuvel@linaro.org,
marc.zyngier@arm.com, catalin.marinas@arm.com,
will.deacon@arm.com, linux-kernel@vger.kernel.org,
jnair@caviumnetworks.com
Subject: Re: [PATCH 10/16] arm64: Make KPTI strict CPU local feature
Date: Fri, 26 Jan 2018 12:25:19 +0000 [thread overview]
Message-ID: <20180126122519.GR5862@e103592.cambridge.arm.com> (raw)
In-Reply-To: <20180123122809.16269-11-suzuki.poulose@arm.com>
On Tue, Jan 23, 2018 at 12:28:03PM +0000, Suzuki K Poulose wrote:
> KPTI capability is a security feature which should be enabled
> when at least one CPU on the system needs it. Any late CPU
> which needs the kernel support, should be prevented from
> booting (and thus making the system unsecure) if the feature
> was not already enabled.
Is there an actual change to behaviour here?
It's not very obvious from the commit message, or the patch when read in
isolation.
>
> Cc: Will Deacon <will.deacon@arm.com>
> Signed-off-by: Suzuki K Poulose <suzuki.poulose@arm.com>
> ---
> arch/arm64/kernel/cpufeature.c | 11 ++++++-----
> 1 file changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/arch/arm64/kernel/cpufeature.c b/arch/arm64/kernel/cpufeature.c
> index 111f6c4b4cd7..2627a836e99d 100644
> --- a/arch/arm64/kernel/cpufeature.c
> +++ b/arch/arm64/kernel/cpufeature.c
> @@ -862,9 +862,8 @@ static bool has_no_fpsimd(const struct arm64_cpu_capabilities *entry, int __unus
> static int __kpti_forced; /* 0: not forced, >0: forced on, <0: forced off */
>
> static bool unmap_kernel_at_el0(const struct arm64_cpu_capabilities *entry,
[Nit: All the other .matches functions have a predicate-style name, so
"should_unmap_kernel_at_el0" or "must_unmap_kernel_at_el0" might be
better names... However, the name wasn't introduced by this series and
it's not a huge deal.]
> - int __unused)
> + int scope)
> {
> - u64 pfr0 = read_sanitised_ftr_reg(SYS_ID_AA64PFR0_EL1);
>
> /* Forced on command line? */
> if (__kpti_forced) {
> @@ -878,8 +877,7 @@ static bool unmap_kernel_at_el0(const struct arm64_cpu_capabilities *entry,
> return true;
>
> /* Defer to CPU feature registers */
> - return !cpuid_feature_extract_unsigned_field(pfr0,
> - ID_AA64PFR0_CSV3_SHIFT);
> + return !has_cpuid_feature(entry, scope);
> }
>
> static int __init parse_kpti(char *str)
> @@ -1003,7 +1001,10 @@ static const struct arm64_cpu_capabilities arm64_features[] = {
> {
> .desc = "Kernel page table isolation (KPTI)",
> .capability = ARM64_UNMAP_KERNEL_AT_EL0,
> - .type = ARM64_CPUCAP_BOOT_SYSTEM_FEATURE,
> + .type = ARM64_CPUCAP_STRICT_CPU_LOCAL_FEATURE,
> + .sys_reg = SYS_ID_AA64PFR0_EL1,
> + .field_pos = ID_AA64PFR0_CSV3_SHIFT,
> + .min_field_value = 1,
> .matches = unmap_kernel_at_el0,
> },
> #endif
[...]
Cheers
---Dave
next prev parent reply other threads:[~2018-01-26 12:25 UTC|newest]
Thread overview: 67+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-23 12:27 [PATCH 00/16] arm64: Rework cpu capabilities handling Suzuki K Poulose
2018-01-23 12:27 ` [PATCH 01/16] arm64: capabilities: Update prototype for enable call back Suzuki K Poulose
2018-01-23 14:52 ` Dave Martin
2018-01-23 15:38 ` Suzuki K Poulose
2018-01-25 15:36 ` Dave Martin
2018-01-25 16:57 ` Suzuki K Poulose
2018-01-29 16:35 ` Dave Martin
2018-01-23 12:27 ` [PATCH 02/16] arm64: Move errata work around check on boot CPU Suzuki K Poulose
2018-01-23 14:59 ` Dave Martin
2018-01-23 15:07 ` Suzuki K Poulose
2018-01-23 15:11 ` Dave Martin
2018-01-23 12:27 ` [PATCH 03/16] arm64: Move errata capability processing code Suzuki K Poulose
2018-01-23 12:27 ` [PATCH 04/16] arm64: capabilities: Prepare for fine grained capabilities Suzuki K Poulose
2018-01-23 17:33 ` Dave Martin
2018-01-24 18:45 ` Suzuki K Poulose
2018-01-25 13:43 ` Dave Martin
2018-01-25 17:08 ` Suzuki K Poulose
2018-01-25 17:38 ` Dave Martin
2018-01-25 17:33 ` Dave Martin
2018-01-25 17:56 ` Suzuki K Poulose
2018-01-26 10:00 ` Dave Martin
2018-01-26 12:13 ` Suzuki K Poulose
2018-01-23 12:27 ` [PATCH 05/16] arm64: Add flags to check the safety of a capability for late CPU Suzuki K Poulose
2018-01-26 10:10 ` Dave Martin
2018-01-30 11:17 ` Suzuki K Poulose
2018-01-30 14:56 ` Dave Martin
2018-01-30 15:06 ` Suzuki K Poulose
2018-01-23 12:27 ` [PATCH 06/16] arm64: capabilities: Unify the verification Suzuki K Poulose
2018-01-26 11:08 ` Dave Martin
2018-01-26 12:10 ` Suzuki K Poulose
2018-01-29 16:57 ` Dave Martin
2018-01-23 12:28 ` [PATCH 07/16] arm64: capabilities: Filter the entries based on a given type Suzuki K Poulose
2018-01-26 11:22 ` Dave Martin
2018-01-26 12:21 ` Suzuki K Poulose
2018-01-29 17:06 ` Dave Martin
2018-01-23 12:28 ` [PATCH 08/16] arm64: capabilities: Group handling of features and errata Suzuki K Poulose
2018-01-26 11:47 ` Dave Martin
2018-01-26 12:31 ` Suzuki K Poulose
2018-01-29 17:14 ` Dave Martin
2018-01-29 17:22 ` Suzuki K Poulose
2018-01-30 15:06 ` Dave Martin
2018-01-23 12:28 ` [PATCH 09/16] arm64: capabilities: Introduce strict features based on local CPU Suzuki K Poulose
2018-01-26 12:12 ` Dave Martin
2018-01-30 11:25 ` Suzuki K Poulose
2018-01-23 12:28 ` [PATCH 10/16] arm64: Make KPTI strict CPU local feature Suzuki K Poulose
2018-01-26 12:25 ` Dave Martin [this message]
2018-01-26 15:46 ` Suzuki K Poulose
2018-01-29 17:24 ` Dave Martin
2018-01-23 12:28 ` [PATCH 11/16] arm64: errata: Clean up midr range helpers Suzuki K Poulose
2018-01-26 13:50 ` Dave Martin
2018-01-23 12:28 ` [PATCH 12/16] arm64: Add helpers for checking CPU MIDR against a range Suzuki K Poulose
2018-01-26 14:08 ` Dave Martin
2018-01-23 12:28 ` [PATCH 13/16] arm64: Add support for checking errata based on a list of MIDRS Suzuki K Poulose
2018-01-26 14:16 ` Dave Martin
2018-01-26 15:57 ` Suzuki K Poulose
2018-01-30 15:16 ` Dave Martin
2018-01-30 15:38 ` Suzuki K Poulose
2018-01-30 15:58 ` Dave Martin
2018-01-23 12:28 ` [PATCH 14/16] arm64: Add MIDR encoding for Arm Cortex-A55 and Cortex-A35 Suzuki K Poulose
2018-01-23 12:28 ` [PATCH 15/16] arm64: Delay enabling hardware DBM feature Suzuki K Poulose
2018-01-26 14:41 ` Dave Martin
2018-01-26 16:05 ` Suzuki K Poulose
2018-01-30 15:22 ` Dave Martin
2018-01-23 12:28 ` [PATCH 16/16] arm64: Add work around for Arm Cortex-A55 Erratum 1024718 Suzuki K Poulose
2018-01-26 15:33 ` Dave Martin
2018-01-26 16:29 ` Suzuki K Poulose
2018-01-30 15:27 ` Dave Martin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180126122519.GR5862@e103592.cambridge.arm.com \
--to=dave.martin@arm.com \
--cc=ard.biesheuvel@linaro.org \
--cc=catalin.marinas@arm.com \
--cc=ckadabi@codeaurora.org \
--cc=jnair@caviumnetworks.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=marc.zyngier@arm.com \
--cc=mark.rutland@arm.com \
--cc=suzuki.poulose@arm.com \
--cc=will.deacon@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox