The Linux Kernel Mailing List
 help / color / mirror / Atom feed
* [PATCH v2 0/3] mm/migrate: preparatory cleanups for batch copy and offload
@ 2026-07-01  5:17 Shivank Garg
  2026-07-01  5:17 ` [PATCH v2 1/3] mm/migrate: rename page to folio leftovers Shivank Garg
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Shivank Garg @ 2026-07-01  5:17 UTC (permalink / raw)
  To: Andrew Morton, David Hildenbrand, Zi Yan, Matthew Brost,
	Joshua Hahn, Rakie Kim, Byungchul Park, Gregory Price, Ying Huang,
	Alistair Popple, Lorenzo Stoakes, Liam R. Howlett,
	Vlastimil Babka, Mike Rapoport, Suren Baghdasaryan, Michal Hocko
  Cc: linux-mm, linux-kernel, Shivank Garg, Dev Jain, Jonathan Cameron

This is a small set of mm/migrate cleanups split out of the batch-copy
and offload RFC [1], so they can be reviewed and merged independently
ahead of that larger series.

No functional change intended.

[1] https://lore.kernel.org/all/20260428155043.39251-2-shivankg@amd.com

Signed-off-by: Shivank Garg <shivankg@amd.com>
---
Changes in v2:
- Rename folio/page_was_mapped to was_mapped and unmap_and_move_huge_page
  to unmap_and_move_hugetlb_folio (David).
- Fix stale "page" wording in comment.
- Rebase to mm-new.
- Link to v1: https://lore.kernel.org/r/20260626-migrate-cleanups-prep-v1-0-a95933af7619@amd.com

---
Shivank Garg (3):
      mm/migrate: rename page to folio leftovers
      mm/migrate: fix stale list name in migrate_folios_move() comment
      mm/migrate: use migrate_info field instead of private

 include/linux/mm_types.h |  1 +
 mm/migrate.c             | 52 +++++++++++++++++++++++-------------------------
 2 files changed, 26 insertions(+), 27 deletions(-)
---
base-commit: 15654b0268cd65b4e673510c0377774e61b86397
change-id: 20260626-migrate-cleanups-prep-77a0ad340cc6

Best regards,
-- 
Shivank Garg <shivankg@amd.com>


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2026-07-02  0:00 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-01  5:17 [PATCH v2 0/3] mm/migrate: preparatory cleanups for batch copy and offload Shivank Garg
2026-07-01  5:17 ` [PATCH v2 1/3] mm/migrate: rename page to folio leftovers Shivank Garg
2026-07-01 15:39   ` Zi Yan
2026-07-01 23:54   ` SJ Park
2026-07-01  5:17 ` [PATCH v2 2/3] mm/migrate: fix stale list name in migrate_folios_move() comment Shivank Garg
2026-07-01  5:17 ` [PATCH v2 3/3] mm/migrate: use migrate_info field instead of private Shivank Garg
2026-07-02  0:00   ` SJ Park

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox