The Linux Kernel Mailing List
 help / color / mirror / Atom feed
* [PATCH 0/3] kasan: common: cleanups and deduplication
@ 2026-07-04  9:20 Igor Putko
  2026-07-04  9:20 ` [PATCH 1/3] kasan: deduplicate quarantine reduction logic Igor Putko
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Igor Putko @ 2026-07-04  9:20 UTC (permalink / raw)
  To: ryabinin.a.a, glider, andreyknvl, dvyukov, vincenzo.frascino,
	akpm
  Cc: kasan-dev, linux-mm, linux-kernel, Igor Putko

This patch series refactors KASAN common code to improve readability 
and maintainability.

Specifically, it:
- Introduces a helper for quarantine reduction to eliminate boilerplate.
- Utilizes the standard ALIGN_DOWN macro instead of manual bitwise logic.
- Replaces a magic number with the KASAN_TAG_KERNEL definition.

Igor Putko (3):
  kasan: deduplicate quarantine reduction logic
  kasan: common: use ALIGN_DOWN macro for stack alignment
  kasan: common: replace magic number with KASAN_TAG_KERNEL

 mm/kasan/common.c | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)

-- 
2.47.3


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2026-07-04  9:20 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-04  9:20 [PATCH 0/3] kasan: common: cleanups and deduplication Igor Putko
2026-07-04  9:20 ` [PATCH 1/3] kasan: deduplicate quarantine reduction logic Igor Putko
2026-07-04  9:20 ` [PATCH 2/3] kasan: common: use ALIGN_DOWN macro for stack alignment Igor Putko
2026-07-04  9:20 ` [PATCH 3/3] kasan: common: replace magic number with KASAN_TAG_KERNEL Igor Putko

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox