* [PATCH v2] staging: rtl8723bs: rename bLinkInfoDump to snake_case [not found] <his-message-id> @ 2026-07-05 8:34 ` pastraman 2026-07-05 9:20 ` Greg KH 0 siblings, 1 reply; 2+ messages in thread From: pastraman @ 2026-07-05 8:34 UTC (permalink / raw) To: gregkh; +Cc: linux-staging, linux-kernel, pastraman Rename bLinkInfoDump to link_info_dump to follow the kernel coding style, which discourages CamelCase and Hungarian notation. Issue reported by checkpatch.pl. Signed-off-by: pastraman <pastraman1@gmail.com> --- drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 2 +- drivers/staging/rtl8723bs/include/drv_types.h | 2 +- drivers/staging/rtl8723bs/os_dep/os_intfs.c | 4 ++-- 3 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c b/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c index a86d6f97cf02..607771a0af21 100644 --- a/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c +++ b/drivers/staging/rtl8723bs/core/rtw_mlme_ext.c @@ -4780,7 +4780,7 @@ void _linked_info_dump(struct adapter *padapter) int UndecoratedSmoothedPWDB; struct dvobj_priv *pdvobj = adapter_to_dvobj(padapter); - if (padapter->bLinkInfoDump) { + if (padapter->link_info_dump) { if ((pmlmeinfo->state&0x03) == WIFI_FW_STATION_STATE) rtw_hal_get_def_var(padapter, HAL_DEF_UNDERCORATEDSMOOTHEDPWDB, diff --git a/drivers/staging/rtl8723bs/include/drv_types.h b/drivers/staging/rtl8723bs/include/drv_types.h index 552d0c5fa47f..7b61be9dfea0 100644 --- a/drivers/staging/rtl8723bs/include/drv_types.h +++ b/drivers/staging/rtl8723bs/include/drv_types.h @@ -344,7 +344,7 @@ struct adapter { u8 bFWReady; u8 bBTFWReady; - u8 bLinkInfoDump; + u8 link_info_dump; u8 bRxRSSIDisplay; /* Added by Albert 2012/10/26 */ /* The driver will show up the desired channel number when this flag is 1. */ diff --git a/drivers/staging/rtl8723bs/os_dep/os_intfs.c b/drivers/staging/rtl8723bs/os_dep/os_intfs.c index f31196f54b3e..10c84a887140 100644 --- a/drivers/staging/rtl8723bs/os_dep/os_intfs.c +++ b/drivers/staging/rtl8723bs/os_dep/os_intfs.c @@ -555,7 +555,7 @@ static void rtw_init_default_value(struct adapter *padapter) /* misc. */ RTW_ENABLE_FUNC(padapter, DF_RX_BIT); RTW_ENABLE_FUNC(padapter, DF_TX_BIT); - padapter->bLinkInfoDump = 0; + padapter->link_info_dump = 0; padapter->bNotifyChannelChange = 0; /* for debug purpose */ @@ -613,7 +613,7 @@ void rtw_reset_drv_sw(struct adapter *padapter) RTW_ENABLE_FUNC(padapter, DF_RX_BIT); RTW_ENABLE_FUNC(padapter, DF_TX_BIT); - padapter->bLinkInfoDump = 0; + padapter->link_info_dump = 0; padapter->xmitpriv.tx_pkts = 0; padapter->recvpriv.rx_pkts = 0; -- 2.54.0 ^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH v2] staging: rtl8723bs: rename bLinkInfoDump to snake_case 2026-07-05 8:34 ` [PATCH v2] staging: rtl8723bs: rename bLinkInfoDump to snake_case pastraman @ 2026-07-05 9:20 ` Greg KH 0 siblings, 0 replies; 2+ messages in thread From: Greg KH @ 2026-07-05 9:20 UTC (permalink / raw) To: pastraman; +Cc: linux-staging, linux-kernel On Sun, Jul 05, 2026 at 11:34:24AM +0300, pastraman wrote: > Rename bLinkInfoDump to link_info_dump to follow the kernel coding > style, which discourages CamelCase and Hungarian notation. Issue > reported by checkpatch.pl. > > Signed-off-by: pastraman <pastraman1@gmail.com> > --- > drivers/staging/rtl8723bs/core/rtw_mlme_ext.c | 2 +- > drivers/staging/rtl8723bs/include/drv_types.h | 2 +- > drivers/staging/rtl8723bs/os_dep/os_intfs.c | 4 ++-- > 3 files changed, 4 insertions(+), 4 deletions(-) Hi, This is the friendly patch-bot of Greg Kroah-Hartman. You have sent him a patch that has triggered this response. He used to manually respond to these common problems, but in order to save his sanity (he kept writing the same thing over and over, yet to different people), I was created. Hopefully you will not take offence and will fix the problem in your patch and resubmit it so that it can be accepted into the Linux kernel tree. You are receiving this message because of the following common error(s) as indicated below: - It looks like you did not use your "real" name for the patch on either the Signed-off-by: line, or the From: line (both of which have to match). Please read the kernel file, Documentation/process/submitting-patches.rst for how to do this correctly. - This looks like a new version of a previously submitted patch, but you did not list below the --- line any changes from the previous version. Please read the section entitled "The canonical patch format" in the kernel file, Documentation/process/submitting-patches.rst for what needs to be done here to properly describe this. If you wish to discuss this problem further, or you have questions about how to resolve this issue, please feel free to respond to this email and Greg will reply once he has dug out from the pending patches received from other developers. thanks, greg k-h's patch email bot ^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-07-05 9:21 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
[not found] <his-message-id>
2026-07-05 8:34 ` [PATCH v2] staging: rtl8723bs: rename bLinkInfoDump to snake_case pastraman
2026-07-05 9:20 ` Greg KH
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox