From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: "André Moreira" <andrem.33333@gmail.com>
Cc: Sudip Mukherjee <sudipm.mukherjee@gmail.com>,
Teddy Wang <teddy.wang@siliconmotion.com>,
linux-fbdev@vger.kernel.org, linux-staging@lists.linux.dev,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5] staging: sm750fb: rename variables to comply with kernel style
Date: Wed, 8 Jul 2026 07:03:27 +0200 [thread overview]
Message-ID: <2026070804-everyday-almighty-9aac@gregkh> (raw)
In-Reply-To: <20260707201541.12459-1-andrem.33333@gmail.com>
On Tue, Jul 07, 2026 at 05:15:41PM -0300, André Moreira wrote:
> Rename 'setAllEngOff' to 'set_all_eng_off' within the 'init_status'
> struct to avoid CamelCase and comply with the Linux kernel coding style.
> Also update its usage within sm750.c to prevent compilation errors.
>
> Signed-off-by: André Moreira <andrem.33333@gmail.com>
> ---
> v5:
> - Fix broken diff from v4 that was accidentally recreating the entire struct.
> - Update the variable usage inside drivers/staging/sm750fb/sm750.c to
> prevent compilation errors.
>
> v4:
> - Drop register renames 'pvReg' to 'regs' as they were merged via another upstream patch.
> - Keep only the 'init_status' CamelCase cleanup.
>
> v3:
> - Added changelog history to satisfy the bot.
>
> v2:
> - Renamed 'pv_reg' to 'regs' to completely remove Hungarian notation, based on Greg KH's feedback.
>
> drivers/staging/sm750fb/sm750.c | 2 +-
> drivers/staging/sm750fb/sm750.h | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c
> index 89c811e0806c4..00c293430a7d5 100644
> --- a/drivers/staging/sm750fb/sm750.c
> +++ b/drivers/staging/sm750fb/sm750.c
> @@ -848,7 +848,7 @@ static void sm750fb_setup(struct sm750_dev *sm750_dev, char *src)
> sm750_dev->init_parm.mem_clk = 0;
> sm750_dev->init_parm.master_clk = 0;
> sm750_dev->init_parm.power_mode = 0;
> - sm750_dev->init_parm.setAllEngOff = 0;
> + sm750_dev->init_parm.set_all_eng_off = 0;
> sm750_dev->init_parm.reset_memory = 1;
>
> /* defaultly turn g_hwcursor on for both view */
> diff --git a/drivers/staging/sm750fb/sm750.h b/drivers/staging/sm750fb/sm750.h
> index d2c522e67f26a..589ae51444f81 100644
> --- a/drivers/staging/sm750fb/sm750.h
> +++ b/drivers/staging/sm750fb/sm750.h
> @@ -44,7 +44,7 @@ struct init_status {
> ushort chip_clk;
> ushort mem_clk;
> ushort master_clk;
> - ushort setAllEngOff;
> + ushort set_all_eng_off;
> ushort reset_memory;
> };
>
If this variable is only set, and never read, why is it here at all?
Why not just remove it entirely?
thanks,
greg k-h
next prev parent reply other threads:[~2026-07-08 5:03 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-23 22:06 [PATCH] staging: sm750fb: rename variables to avoid CamelCase André Moreira
2026-07-07 9:11 ` Greg KH
2026-07-07 10:27 ` [PATCH v2] staging: sm750fb: rename variables to comply with kernel style André Moreira
2026-07-07 10:56 ` Greg Kroah-Hartman
2026-07-07 11:43 ` [PATCH v3] " André Moreira
2026-07-07 11:49 ` Greg Kroah-Hartman
2026-07-07 13:15 ` [PATCH v4] " André Moreira
2026-07-07 13:28 ` Andre Moreira
2026-07-07 14:17 ` Greg Kroah-Hartman
2026-07-07 20:15 ` [PATCH v5] " André Moreira
2026-07-08 5:03 ` Greg Kroah-Hartman [this message]
2026-07-08 6:03 ` [PATCH v6] staging: sm750fb: Remove unused variable 'setAllEngOff' André Moreira
2026-07-08 11:59 ` Greg Kroah-Hartman
2026-07-08 13:09 ` Andre Moreira
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2026070804-everyday-almighty-9aac@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=andrem.33333@gmail.com \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=sudipm.mukherjee@gmail.com \
--cc=teddy.wang@siliconmotion.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox