The Linux Kernel Mailing List
 help / color / mirror / Atom feed
* [Question] list_add() naming: why not list_add_head()?
@ 2026-07-10  3:19 Ziran Zhang
  0 siblings, 0 replies; only message in thread
From: Ziran Zhang @ 2026-07-10  3:19 UTC (permalink / raw)
  To: linux-kernel, kernel-janitors
  Cc: Paul E . McKenney, Andrew Morton, Randy Dunlap, Andy Shevchenko,
	Simona Vetter, David Howells, Jonathan Corbet, Nicolas Frattaroli,
	Bagas Sanjaya, Shuah Khan, Ziran Zhang

I noticed list_add() inserts at the head->next, 
but the name doesn't reflect that. 
Why wasn't it called list_add_head()? Is there 
any historical or design reason?

Thanks for your time.

Regards,
Ziran Zhang


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2026-07-10  3:22 UTC | newest]

Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-10  3:19 [Question] list_add() naming: why not list_add_head()? Ziran Zhang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox