The Linux Kernel Mailing List
 help / color / mirror / Atom feed
* [PATCH v2] cxl/region: Add cxl_decoder_is_passthrough() helper
@ 2026-08-05  6:59 Richard Cheng
  0 siblings, 0 replies; only message in thread
From: Richard Cheng @ 2026-08-05  6:59 UTC (permalink / raw)
  To: dave, jic23, dave.jiang, alison.schofield, vishal.l.verma, djbw
  Cc: iweiny, ming.li, gourry, rrichter, linux-cxl, linux-kernel,
	newtonl, kristinc, kaihengf, kobak, Richard Cheng

commit_decoder() open-codes the passthrough test.
A NULL ->commit() plus a switch decoder with at most one target. The
call site is hard to read, and it suggests a NULL ->commit() alone
identifies a passthrough decoder. It does not.
DVSEC-emulated endpoint decoders also leave ->commit() NULL, and root
decoders never set it. A future caller testing ->commit() alone would
silently include them.

Move the test into cxl_decoder_is_passthrough() and document what each
condition rules out. The helper runs the same tests in the same order,
no functional change.

Signed-off-by: Richard Cheng <icheng@nvidia.com>
---
Changelog:

v1 -> v2:
    - Dropped the passthrough F_ENABLE restore patch. The bug was
      already fixed.
    - What remains is only the clarify helper function patch, so the
      patch is retitled accordingly

v1:
https://lore.kernel.org/linux-cxl/20260727103743.63343-1-icheng@nvidia.com/

Best regards,
Richard Cheng.
---
 drivers/cxl/core/region.c | 28 ++++++++++++++++++++++------
 1 file changed, 22 insertions(+), 6 deletions(-)

diff --git a/drivers/cxl/core/region.c b/drivers/cxl/core/region.c
index 27e63e6dab7c..cd73684fbe97 100644
--- a/drivers/cxl/core/region.c
+++ b/drivers/cxl/core/region.c
@@ -293,17 +293,33 @@ static void cxl_region_decode_reset(struct cxl_region *cxlr, int count)
 	clear_bit(CXL_REGION_F_NEEDS_RESET, &cxlr->flags);
 }
 
-static int commit_decoder(struct cxl_decoder *cxld)
+/*
+ * A single-dport host-bridge need not publish an HDM decoder capability
+ * when passthrough decode can be assumed. The resulting decoder is a
+ * software-only construct with no registers to program, so it carries no
+ * ->commit() operation, see devm_cxl_add_passthrough_decoder().
+ *
+ * A NULL ->commit() alone does not identify one, it is also NULL for
+ * DVSEC-emulated endpoint decoders. Test the decoder type and target
+ * count as well.
+ */
+static bool cxl_decoder_is_passthrough(struct cxl_decoder *cxld)
 {
-	struct cxl_switch_decoder *cxlsd = NULL;
+	if (cxld->commit)
+		return false;
+
+	if (!is_switch_decoder(&cxld->dev))
+		return false;
+
+	return to_cxl_switch_decoder(&cxld->dev)->nr_targets <= 1;
+}
 
+static int commit_decoder(struct cxl_decoder *cxld)
+{
 	if (cxld->commit)
 		return cxld->commit(cxld);
 
-	if (is_switch_decoder(&cxld->dev))
-		cxlsd = to_cxl_switch_decoder(&cxld->dev);
-
-	if (dev_WARN_ONCE(&cxld->dev, !cxlsd || cxlsd->nr_targets > 1,
+	if (dev_WARN_ONCE(&cxld->dev, !cxl_decoder_is_passthrough(cxld),
 			  "->commit() is required\n"))
 		return -ENXIO;
 	return 0;

base-commit: 212e015fc34712c849653cdb3179cd643c915015
-- 
2.43.0


^ permalink raw reply related	[flat|nested] only message in thread

only message in thread, other threads:[~2026-08-05  6:59 UTC | newest]

Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-05  6:59 [PATCH v2] cxl/region: Add cxl_decoder_is_passthrough() helper Richard Cheng

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox