From: Alex Williamson <alex@shazbot.org>
To: Matt Evans <matt@ozlabs.org>
Cc: "Leon Romanovsky" <leon@kernel.org>,
"Jason Gunthorpe" <jgg@nvidia.com>,
"Alex Mastro" <amastro@fb.com>,
"Christian König" <christian.koenig@amd.com>,
"Bjorn Helgaas" <bhelgaas@google.com>,
"Logan Gunthorpe" <logang@deltatee.com>,
"Kevin Tian" <kevin.tian@intel.com>,
"Pranjal Shrivastava" <praan@google.com>,
"Longfang Liu" <liulongfang@huawei.com>,
"Mahmoud Adam" <mngyadam@amazon.de>,
"David Matlack" <dmatlack@google.com>,
"Björn Töpel" <bjorn@kernel.org>,
"Sumit Semwal" <sumit.semwal@linaro.org>,
"Ankit Agrawal" <ankita@nvidia.com>,
"Alistair Popple" <apopple@nvidia.com>,
"Vivek Kasireddy" <vivek.kasireddy@intel.com>,
linux-kernel@vger.kernel.org, linux-media@vger.kernel.org,
dri-devel@lists.freedesktop.org, linaro-mm-sig@lists.linaro.org,
kvm@vger.kernel.org, linux-pci@vger.kernel.org, alex@shazbot.org
Subject: Re: [PATCH v5 7/9] vfio/pci: Clean up BAR zap and revocation
Date: Wed, 12 Aug 2026 14:06:57 -0600 [thread overview]
Message-ID: <20260812140657.247b9fa3@shazbot.org> (raw)
In-Reply-To: <291625a2-f281-4c05-b51f-553018a34b08@ozlabs.org>
On Tue, 11 Aug 2026 16:58:43 +0100
Matt Evans <matt@ozlabs.org> wrote:
> Hi Alex,
>
> On 04/08/2026 21:10, Alex Williamson wrote:
> > On Thu, 30 Jul 2026 15:47:13 +0100
> > Matt Evans <matt@ozlabs.org> wrote:
> >
> >> Hi Alex,
> >>
> >> On 29/07/2026 18:52, Alex Williamson wrote:
> >>> On Wed, 15 Jul 2026 18:47:30 +0100
> >>> Matt Evans <matt@ozlabs.org> wrote:
> >>>> diff --git a/include/linux/vfio_pci_core.h b/include/linux/vfio_pci_core.h
> >>>> index 9a1674c152aa..e2b4252e7c3f 100644
> >>>> --- a/include/linux/vfio_pci_core.h
> >>>> +++ b/include/linux/vfio_pci_core.h
> >>>> @@ -134,6 +134,7 @@ struct vfio_pci_core_device {
> >>>> bool pm_intx_masked;
> >>>> bool pm_runtime_engaged;
> >>>> bool sriov_active;
> >>>> + bool zap_bars_on_revoke;
> >>>> struct pci_saved_state *pci_saved_state;
> >>>> struct pci_saved_state *pm_save;
> >>>> int ioeventfds_nr;
> >>>
> >>> This should be in the bitfield usage group since it's only modified at
> >>> init time.
> >>
> >> This was intentional, but happy to change it if you're certain ofc. Is
> >> it inconceivable that a sub-driver could set it after init? I'd say
> >> they _shouldn't_, but only review will stop them and this placement
> >> intended to be cautious. It seemed a low cost way to avoid issues
> >> around synchronisation on the bitfield.
> >
> > I'd agree with the statement that they shouldn't, it would be difficult
> > to synchronize setting the flag once there are any active mappings of
> > the BARs. Also, if we put it in the bitfield category under the
> > comment that the value is only modified at setup/release, it documents
> > the intentions, hopefully to the extent the author or reviewers notice.
> > An argument can always be made to change it if there's a worthwhile use
> > case. Thanks,
>
> (Having noticed in moving this to the bitfield; my previous reply didn't
> supply the real reason it wasn't in the bitfield.)
>
> Isn't the init-time 'event horizon' for writing the bitfield the
> vfio_register_group_dev() in vfio_pci_core_register_device(), after
> which synchronisation is needed?
>
> The hisi_acc_vfio_pci driver's .probe calls
> vfio_pci_core_register_device() and _after that_ sets
> zap_bars_on_revoke, and that's now in the "needs synchronisation to
> write the bitfield" phase.
>
> (Re-reading my comment in vfio_pci_core_register_device() I'd noted
> this, "Drivers can opt out after registration". Has to be done after by
> definition as the default's set in vfio_pci_core_register_device().)
>
> The concern is just blatting neighbours in the bitfield, not the window
> of time before the flag's set. The flag's an opt-out of a safe but (for
> this driver) unnecessary zap, so having it unset for a short time is OK.
>
> I still think this really should be a standalone bool, not a bit in the
> bitfield. It has to be set after registration and having to take a lock
> to do that has downsides.
You're right on the ordering, the device is live after
vfio_pci_core_register_device(). However, I think that's evidence that
vfio-pci-core is setting the default polarity, inferred from the mmap
op, in the wrong place. It should happen in init, not register_device.
The same mmap op pointer is available in vfio_pci_core_init_dev(), which
is used by all vfio-pci variant drivers in their init callback. The
proposed vfio_pci_core_register_device() change just needs to be lifted
into vfio_pci_core_init_dev(). hisi_acc is then modified to fix the
flag after vfio_pci_core_init_dev(), something like below.
I think that's better than anticipating it being dynamic when we don't
have a use case that requires it. Thanks,
Alex
--- a/drivers/vfio/pci/hisilicon/hisi_acc_vfio_pci.c
+++ b/drivers/vfio/pci/hisilicon/hisi_acc_vfio_pci.c
@@ -1564,6 +1564,7 @@ static int hisi_acc_vfio_pci_migrn_init_dev(struct vfio_device *core_vdev)
struct hisi_acc_vf_core_device *hisi_acc_vdev = hisi_acc_get_vf_dev(core_vdev);
struct pci_dev *pdev = to_pci_dev(core_vdev->dev);
struct hisi_qm *pf_qm = hisi_acc_get_pf_qm(pdev);
+ int ret;
hisi_acc_vdev->vf_id = pci_iov_vf_id(pdev) + 1;
hisi_acc_vdev->pf_qm = pf_qm;
@@ -1575,7 +1576,9 @@ static int hisi_acc_vfio_pci_migrn_init_dev(struct vfio_device *core_vdev)
core_vdev->migration_flags = VFIO_MIGRATION_STOP_COPY | VFIO_MIGRATION_PRE_COPY;
core_vdev->mig_ops = &hisi_acc_vfio_pci_migrn_state_ops;
- return vfio_pci_core_init_dev(core_vdev);
+ ret = vfio_pci_core_init_dev(core_vdev);
+ hisi_acc_vdev->core_device.zap_bars_on_revoke = false;
+ return ret;
}
static const struct vfio_device_ops hisi_acc_vfio_pci_migrn_ops = {
next prev parent reply other threads:[~2026-08-12 20:07 UTC|newest]
Thread overview: 56+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-15 17:47 [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs Matt Evans
2026-07-15 17:47 ` [PATCH v5 1/9] PCI/P2PDMA: Split pool-related cleanup out of pci_p2pdma_release() Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-28 22:33 ` Alex Williamson
2026-07-29 10:08 ` Leon Romanovsky
2026-08-05 0:31 ` Jason Gunthorpe
2026-07-30 16:45 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 2/9] PCI/P2PDMA: Add CONFIG_PCI_P2PDMA_CORE Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-30 19:37 ` Pranjal Shrivastava
2026-08-04 15:42 ` Matt Evans
2026-08-04 16:19 ` Logan Gunthorpe
2026-08-05 0:39 ` Jason Gunthorpe
2026-08-05 16:28 ` Matt Evans
2026-08-05 16:40 ` Jason Gunthorpe
2026-08-05 20:50 ` Logan Gunthorpe
2026-08-11 13:45 ` Matt Evans
2026-08-11 14:01 ` Jason Gunthorpe
2026-07-15 17:47 ` [PATCH v5 3/9] vfio/pci: Add a helper to look up PFNs for DMABUFs Matt Evans
2026-07-17 8:02 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 17:34 ` Matt Evans
2026-07-30 22:55 ` Pranjal Shrivastava
2026-07-31 17:43 ` Matt Evans
2026-08-03 18:22 ` Matt Evans
2026-08-04 19:01 ` Pranjal Shrivastava
2026-08-05 0:41 ` Jason Gunthorpe
2026-07-15 17:47 ` [PATCH v5 4/9] vfio/pci: Add a helper to create a DMABUF for a BAR-map VMA Matt Evans
2026-08-12 22:39 ` Matt Evans
2026-07-15 17:47 ` [PATCH v5 5/9] vfio/pci: Convert BAR mmap() to use a DMABUF Matt Evans
2026-07-15 17:47 ` [PATCH v5 6/9] vfio/pci: Provide a user-facing name for BAR mappings Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 14:37 ` Matt Evans
2026-07-15 17:47 ` [PATCH v5 7/9] vfio/pci: Clean up BAR zap and revocation Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-29 17:52 ` Alex Williamson
2026-07-30 14:47 ` Matt Evans
2026-08-04 20:10 ` Alex Williamson
2026-08-05 13:58 ` Matt Evans
2026-08-11 15:58 ` Matt Evans
2026-08-12 20:06 ` Alex Williamson [this message]
2026-07-30 23:20 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 8/9] vfio/pci: Support mmap() of a VFIO DMABUF Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-30 23:33 ` Pranjal Shrivastava
2026-07-15 17:47 ` [PATCH v5 9/9] vfio/pci: Permanently revoke a DMABUF on request Matt Evans
2026-07-17 8:03 ` Tian, Kevin
2026-07-30 23:43 ` Pranjal Shrivastava
2026-07-15 18:12 ` [PATCH v5 0/9] vfio/pci: Add mmap() for DMABUFs David Matlack
2026-07-16 14:51 ` Matt Evans
2026-07-16 21:23 ` David Matlack
2026-07-17 8:42 ` David Laight
2026-07-17 16:30 ` David Matlack
2026-07-17 17:12 ` Matt Evans
2026-07-20 21:50 ` David Matlack
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260812140657.247b9fa3@shazbot.org \
--to=alex@shazbot.org \
--cc=amastro@fb.com \
--cc=ankita@nvidia.com \
--cc=apopple@nvidia.com \
--cc=bhelgaas@google.com \
--cc=bjorn@kernel.org \
--cc=christian.koenig@amd.com \
--cc=dmatlack@google.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=jgg@nvidia.com \
--cc=kevin.tian@intel.com \
--cc=kvm@vger.kernel.org \
--cc=leon@kernel.org \
--cc=linaro-mm-sig@lists.linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=liulongfang@huawei.com \
--cc=logang@deltatee.com \
--cc=matt@ozlabs.org \
--cc=mngyadam@amazon.de \
--cc=praan@google.com \
--cc=sumit.semwal@linaro.org \
--cc=vivek.kasireddy@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox