* [GIT PULL] devfreq next for 6.19
@ 2025-11-27 15:10 Chanwoo Choi
2025-11-27 15:30 ` Rafael J. Wysocki
0 siblings, 1 reply; 2+ messages in thread
From: Chanwoo Choi @ 2025-11-27 15:10 UTC (permalink / raw)
To: Rafael J. Wysocki
Cc: Linux Kernel Mailing List, open list:DEVICE FREQUENCY (DEVFREQ),
Chanwoo Choi, MyungJoo Ham, Kyungmin Park, Chanwoo Choi
Dear Rafael,
This is devfreq-next pull request. I add detailed description of
this pull request on the following tag. Please pull devfreq with
following updates.
Best Regards,
Chanwoo Choi
The following changes since commit 6146a0f1dfae5d37442a9ddcba012add260bceb0:
Linux 6.18-rc4 (2025-11-02 11:28:02 -0800)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/linux.git tags/devfreq-next-for-6.19
for you to fetch changes up to d9600d57668c49308f705a660c5ad17fa3a53f73:
PM / devfreq: Fix typo in DFSO_DOWNDIFFERENTIAL macro name (2025-11-26 13:58:59 +0900)
----------------------------------------------------------------
Update devfreq next for v6.19
Detailed description for this pull request:
- Move governor.h under include/linux/ and rename to devfreq-governor.h
in order to allow devfreq governor definitions in out of drivers/devfreq/.
- Fix potential use-after-free issue of OPP handling on hisi_uncore_freq.c
- Use min() to improve the readability on tegra30-devfreq.c
- Fix typo in DFSO_DOWNDIFFERENTIAL macro name on governor_simpleondemand.c
----------------------------------------------------------------
Dmitry Baryshkov (1):
PM / devfreq: Move governor.h to a public header location
Pengjie Zhang (1):
PM / devfreq: hisi: Fix potential UAF in OPP handling
Riwen Lu (1):
PM / devfreq: Fix typo in DFSO_DOWNDIFFERENTIAL macro name
Thorsten Blum (1):
PM / devfreq: tegra30: use min to simplify actmon_cpu_to_emc_rate
drivers/devfreq/devfreq.c | 2 +-
drivers/devfreq/governor_passive.c | 27 +++++++++++++++++-
drivers/devfreq/governor_performance.c | 2 +-
drivers/devfreq/governor_powersave.c | 2 +-
drivers/devfreq/governor_simpleondemand.c | 6 ++--
drivers/devfreq/governor_userspace.c | 2 +-
drivers/devfreq/hisi_uncore_freq.c | 6 ++--
drivers/devfreq/tegra30-devfreq.c | 15 ++++------
.../governor.h => include/linux/devfreq-governor.h | 33 +++-------------------
9 files changed, 45 insertions(+), 50 deletions(-)
rename drivers/devfreq/governor.h => include/linux/devfreq-governor.h (80%)
^ permalink raw reply [flat|nested] 2+ messages in thread* Re: [GIT PULL] devfreq next for 6.19
2025-11-27 15:10 [GIT PULL] devfreq next for 6.19 Chanwoo Choi
@ 2025-11-27 15:30 ` Rafael J. Wysocki
0 siblings, 0 replies; 2+ messages in thread
From: Rafael J. Wysocki @ 2025-11-27 15:30 UTC (permalink / raw)
To: Chanwoo Choi
Cc: Rafael J. Wysocki, Linux Kernel Mailing List,
open list:DEVICE FREQUENCY (DEVFREQ), MyungJoo Ham, Kyungmin Park,
Chanwoo Choi
Hi Chanwoo,
On Thu, Nov 27, 2025 at 4:10 PM Chanwoo Choi <chanwoo@kernel.org> wrote:
>
> Dear Rafael,
>
> This is devfreq-next pull request. I add detailed description of
> this pull request on the following tag. Please pull devfreq with
> following updates.
>
> Best Regards,
> Chanwoo Choi
>
>
> The following changes since commit 6146a0f1dfae5d37442a9ddcba012add260bceb0:
>
> Linux 6.18-rc4 (2025-11-02 11:28:02 -0800)
>
> are available in the Git repository at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/linux.git tags/devfreq-next-for-6.19
>
> for you to fetch changes up to d9600d57668c49308f705a660c5ad17fa3a53f73:
>
> PM / devfreq: Fix typo in DFSO_DOWNDIFFERENTIAL macro name (2025-11-26 13:58:59 +0900)
>
> ----------------------------------------------------------------
> Update devfreq next for v6.19
>
> Detailed description for this pull request:
> - Move governor.h under include/linux/ and rename to devfreq-governor.h
> in order to allow devfreq governor definitions in out of drivers/devfreq/.
>
> - Fix potential use-after-free issue of OPP handling on hisi_uncore_freq.c
>
> - Use min() to improve the readability on tegra30-devfreq.c
>
> - Fix typo in DFSO_DOWNDIFFERENTIAL macro name on governor_simpleondemand.c
> ----------------------------------------------------------------
>
> Dmitry Baryshkov (1):
> PM / devfreq: Move governor.h to a public header location
>
> Pengjie Zhang (1):
> PM / devfreq: hisi: Fix potential UAF in OPP handling
>
> Riwen Lu (1):
> PM / devfreq: Fix typo in DFSO_DOWNDIFFERENTIAL macro name
>
> Thorsten Blum (1):
> PM / devfreq: tegra30: use min to simplify actmon_cpu_to_emc_rate
>
> drivers/devfreq/devfreq.c | 2 +-
> drivers/devfreq/governor_passive.c | 27 +++++++++++++++++-
> drivers/devfreq/governor_performance.c | 2 +-
> drivers/devfreq/governor_powersave.c | 2 +-
> drivers/devfreq/governor_simpleondemand.c | 6 ++--
> drivers/devfreq/governor_userspace.c | 2 +-
> drivers/devfreq/hisi_uncore_freq.c | 6 ++--
> drivers/devfreq/tegra30-devfreq.c | 15 ++++------
> .../governor.h => include/linux/devfreq-governor.h | 33 +++-------------------
> 9 files changed, 45 insertions(+), 50 deletions(-)
> rename drivers/devfreq/governor.h => include/linux/devfreq-governor.h (80%)
Pulled and added to linux-pm.git/linux-next, thanks!
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2025-11-27 15:31 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-11-27 15:10 [GIT PULL] devfreq next for 6.19 Chanwoo Choi
2025-11-27 15:30 ` Rafael J. Wysocki
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox