From: Miquel Raynal <miquel.raynal@bootlin.com>
To: "Michael Walle" <mwalle@kernel.org>
Cc: "Pratyush Yadav" <pratyush@kernel.org>,
"Takahiro Kuwano" <takahiro.kuwano@infineon.com>,
"Richard Weinberger" <richard@nod.at>,
"Vignesh Raghavendra" <vigneshr@ti.com>,
"Thomas Petazzoni" <thomas.petazzoni@bootlin.com>,
"Steam Lin" <STLin2@winbond.com>,
<linux-mtd@lists.infradead.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 04/30] mtd: spi-nor: winbond: Make the RDCR fixup Winbond wide
Date: Fri, 31 Jul 2026 11:38:19 +0200 [thread overview]
Message-ID: <874ihfjy7o.fsf@bootlin.com> (raw)
In-Reply-To: <DJRJS82LPRIZ.2NG59E6DSDTHM@kernel.org> (Michael Walle's message of "Mon, 06 Jul 2026 16:11:31 +0200")
On 06/07/2026 at 16:11:31 +02, "Michael Walle" <mwalle@kernel.org> wrote:
> On Fri May 29, 2026 at 5:22 PM CEST, Miquel Raynal wrote:
>> The top level paragraph of the QER field in the JESD216B mentions:
>>
>> "In this standard, [...] Status register 2 refers to the byte read
>> using instruction 35h. Status register 2 is the second byte transferred
>> in a Write Status (01h) command. [...]"
>>
>> Value 100b, named in Linux BFPT_DWORD15_QER_SR2_BIT1_NO_RD, does not
>> mention anything about reads and only brings details about writes.
>>
>> This has been interpreted in the spi-nor core by the absence of read
>> capability, but there is no explicit reason for that, except that there
>> were probably some very old chips which didn't support command 35h.
>
> I agree. But making it a vendor default we always have to have an
> entry. So if this is really for all winbond chips, we shall do a
> catch all entry (like in macronix.c).
Good catch, I didn't think about that. Added.
[...]
>> + if (nor->info->id->bytes[0] == 0xef &&
>> + nor->info->id->bytes[1] > 0x30)
>> + nor->flags &= ~SNOR_F_NO_READ_CR;
>
> This is somewhat hard to read and the byte[0] is redundant here.
> Maybe you can come up with some macro magic sugar :)
I dropped the first condition in the if which indeed is
redundant. However I don't know how to make the remainder more
explanatory, there is already a big comment telling why we do it.
Thanks!
Miquèl
next prev parent reply other threads:[~2026-07-31 9:38 UTC|newest]
Thread overview: 52+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-29 15:22 [PATCH 00/30] mtd: spi-nor: Clean Winbond W25QxxJV family Miquel Raynal
2026-05-29 15:22 ` [PATCH 01/30] mtd: spi-nor: winbond: Move W25Q01NW to its right place Miquel Raynal
2026-07-06 13:54 ` Michael Walle
2026-05-29 15:22 ` [PATCH 02/30] mtd: spi-nor: winbond: Normalize names Miquel Raynal
2026-07-06 13:57 ` Michael Walle
2026-07-22 12:52 ` Miquel Raynal
2026-07-22 13:07 ` Michael Walle
2026-07-22 15:19 ` Miquel Raynal
2026-05-29 15:22 ` [PATCH 03/30] mtd: spi-nor: winbond: Stop filling the .name entry Miquel Raynal
2026-07-06 13:59 ` Michael Walle
2026-07-22 12:56 ` Miquel Raynal
2026-07-22 13:23 ` Michael Walle
2026-07-22 15:51 ` Miquel Raynal
2026-05-29 15:22 ` [PATCH 04/30] mtd: spi-nor: winbond: Make the RDCR fixup Winbond wide Miquel Raynal
2026-07-06 14:11 ` Michael Walle
2026-07-31 9:38 ` Miquel Raynal [this message]
2026-05-29 15:22 ` [PATCH 05/30] mtd: spi-nor: winbond: W25Q32JV-Q/N: Drop redundant data Miquel Raynal
2026-07-06 14:13 ` Michael Walle
2026-07-22 13:00 ` Miquel Raynal
2026-05-29 15:22 ` [PATCH 06/30] mtd: spi-nor: winbond: W25Q64JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 07/30] mtd: spi-nor: winbond: W25Q512JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 08/30] mtd: spi-nor: winbond: W25Q32JV-Q/N: Add quad page program capability Miquel Raynal
2026-07-06 14:16 ` Michael Walle
2026-07-22 13:01 ` Miquel Raynal
2026-05-29 15:22 ` [PATCH 09/30] mtd: spi-nor: winbond: W25Q64JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 10/30] mtd: spi-nor: winbond: W25Q128JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 11/30] mtd: spi-nor: winbond: W25Q32JV-Q/N: Fill locking information Miquel Raynal
2026-07-06 14:21 ` Michael Walle
2026-07-22 15:00 ` Miquel Raynal
2026-05-29 15:22 ` [PATCH 12/30] mtd: spi-nor: winbond: W25Q64JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 13/30] mtd: spi-nor: winbond: W25Q128JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 14/30] mtd: spi-nor: winbond: W25Q512JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 15/30] mtd: spi-nor: winbond: W25Q01JV-Q/N: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 16/30] mtd: spi-nor: winbond: W25Q32JV-M: Drop redundant data Miquel Raynal
2026-07-06 14:23 ` Michael Walle
2026-07-22 15:09 ` Miquel Raynal
2026-05-29 15:22 ` [PATCH 17/30] mtd: spi-nor: winbond: W25Q64JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 18/30] mtd: spi-nor: winbond: W25Q128JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 19/30] mtd: spi-nor: winbond: W25Q32JV-M: Add quad page program capability Miquel Raynal
2026-05-29 15:22 ` [PATCH 20/30] mtd: spi-nor: winbond: W25Q64JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 21/30] mtd: spi-nor: winbond: W25Q128JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 22/30] mtd: spi-nor: winbond: W25Q32JV-M: Fill locking information Miquel Raynal
2026-05-29 15:22 ` [PATCH 23/30] mtd: spi-nor: winbond: W25Q64JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 24/30] mtd: spi-nor: winbond: W25Q128JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 25/30] mtd: spi-nor: winbond: W25Q02JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 26/30] mtd: spi-nor: winbond: W25Q512JV-M: New chip Miquel Raynal
2026-05-29 15:22 ` [PATCH 27/30] mtd: spi-nor: winbond: W25Q01JV-M: " Miquel Raynal
2026-05-29 15:22 ` [PATCH 28/30] mtd: spi-nor: winbond: W25QxxJV-Q/N/M: Drop redundant data Miquel Raynal
2026-05-29 15:22 ` [PATCH 29/30] mtd: spi-nor: winbond: W25QxxJV-Q/N/M: Add quad page program capability Miquel Raynal
2026-05-29 15:22 ` [PATCH 30/30] mtd: spi-nor: winbond: W25QxxJV-Q/N/M: Fill locking information Miquel Raynal
2026-07-06 14:27 ` [PATCH 00/30] mtd: spi-nor: Clean Winbond W25QxxJV family Michael Walle
2026-07-22 12:45 ` Miquel Raynal
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=874ihfjy7o.fsf@bootlin.com \
--to=miquel.raynal@bootlin.com \
--cc=STLin2@winbond.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=mwalle@kernel.org \
--cc=pratyush@kernel.org \
--cc=richard@nod.at \
--cc=takahiro.kuwano@infineon.com \
--cc=thomas.petazzoni@bootlin.com \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox