From: "Robert P. J. Day" <rpjday@mindspring.com>
To: Jan Engelhardt <jengelh@linux01.gwdg.de>
Cc: Stefan Richter <stefanr@s5r6.in-berlin.de>,
Zach Brown <zach.brown@oracle.com>,
Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: lots of code could be simplified by using ARRAY_SIZE()
Date: Fri, 15 Dec 2006 15:48:09 -0500 (EST) [thread overview]
Message-ID: <Pine.LNX.4.64.0612151547290.6136@localhost.localdomain> (raw)
In-Reply-To: <Pine.LNX.4.61.0612151135330.22867@yvahk01.tjqt.qr>
On Fri, 15 Dec 2006, Jan Engelhardt wrote:
>
> >>> Indeed, there seems to be lots of potential clean-up there.
> >>> Including duplicate macros like:
> >>>
> >>> ./drivers/ide/ide-cd.h:#define ARY_LEN(a) ((sizeof(a) / sizeof(a[0])))
> >>
> >> not surprisingly, i have a script "arraysize.sh":
> >...
> >
> >This could also come in the flavor "sizeof(a) / sizeof(*a)".
> >I haven't checked if there are actual instances.
>
> Even sizeof a / sizeof *a
>
> may happen.
yes, sadly, there are a number of those as well. back to the drawing
board.
rday
p.s. you know, once i nail this script, somebody better apply the end
result. :-)
next prev parent reply other threads:[~2006-12-15 20:52 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-12-13 19:58 lots of code could be simplified by using ARRAY_SIZE() Robert P. J. Day
[not found] ` <2F8F687E-C5E5-4F7D-9585-97DA97AE1376@oracle.com>
2006-12-14 22:27 ` Robert P. J. Day
2006-12-14 23:13 ` Stefan Richter
2006-12-15 10:36 ` Jan Engelhardt
2006-12-15 20:48 ` Robert P. J. Day [this message]
2006-12-15 22:54 ` Tim Schmielau
2006-12-16 11:59 ` Robert P. J. Day
2006-12-16 13:30 ` Tim Schmielau
2006-12-16 13:55 ` Robert P. J. Day
2006-12-17 18:13 ` Robert P. J. Day
2006-12-17 18:27 ` Randy Dunlap
2006-12-17 18:25 ` Robert P. J. Day
2006-12-14 23:16 ` Miguel Ojeda
2006-12-15 0:12 ` Robert P. J. Day
2006-12-16 8:40 ` Pavel Machek
2006-12-16 13:09 ` Robert P. J. Day
2006-12-16 18:14 ` Jan Engelhardt
2006-12-17 11:44 ` Stefan Richter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.0612151547290.6136@localhost.localdomain \
--to=rpjday@mindspring.com \
--cc=jengelh@linux01.gwdg.de \
--cc=linux-kernel@vger.kernel.org \
--cc=stefanr@s5r6.in-berlin.de \
--cc=zach.brown@oracle.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox