From: "Robert P. J. Day" <rpjday@mindspring.com>
To: Pavel Machek <pavel@ucw.cz>
Cc: Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: lots of code could be simplified by using ARRAY_SIZE()
Date: Sat, 16 Dec 2006 08:09:25 -0500 (EST) [thread overview]
Message-ID: <Pine.LNX.4.64.0612160802250.3660@localhost.localdomain> (raw)
In-Reply-To: <20061216084007.GC4049@ucw.cz>
On Sat, 16 Dec 2006, Pavel Machek wrote:
> Hi!
>
> > there are numerous places throughout the source tree that apparently
> > calculate the size of an array using the construct
> > "sizeof(fubar)/sizeof(fubar[0])". see for yourself:
> >
> > $ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
> >
> > but we already have, from "include/linux/kernel.h":
> >
> > #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
>
> Hmmm. quite misleading name :-(. ARRAY_LEN would be better.
i suspect it's *way* too late to make that kind of change, given that
"ARRAY_SIZE" is firmly ensconced in countless places in the source
tree and that would be a major, disruptive change.
even *i* wouldn't try to promote that idea. :-)
rday
next prev parent reply other threads:[~2006-12-16 13:13 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-12-13 19:58 lots of code could be simplified by using ARRAY_SIZE() Robert P. J. Day
[not found] ` <2F8F687E-C5E5-4F7D-9585-97DA97AE1376@oracle.com>
2006-12-14 22:27 ` Robert P. J. Day
2006-12-14 23:13 ` Stefan Richter
2006-12-15 10:36 ` Jan Engelhardt
2006-12-15 20:48 ` Robert P. J. Day
2006-12-15 22:54 ` Tim Schmielau
2006-12-16 11:59 ` Robert P. J. Day
2006-12-16 13:30 ` Tim Schmielau
2006-12-16 13:55 ` Robert P. J. Day
2006-12-17 18:13 ` Robert P. J. Day
2006-12-17 18:27 ` Randy Dunlap
2006-12-17 18:25 ` Robert P. J. Day
2006-12-14 23:16 ` Miguel Ojeda
2006-12-15 0:12 ` Robert P. J. Day
2006-12-16 8:40 ` Pavel Machek
2006-12-16 13:09 ` Robert P. J. Day [this message]
2006-12-16 18:14 ` Jan Engelhardt
2006-12-17 11:44 ` Stefan Richter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Pine.LNX.4.64.0612160802250.3660@localhost.localdomain \
--to=rpjday@mindspring.com \
--cc=linux-kernel@vger.kernel.org \
--cc=pavel@ucw.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox