The Linux Kernel Mailing List
 help / color / mirror / Atom feed
* [PATCHv3 00/11] Get rid of PG_reclaim and rename PG_dropbehind
@ 2025-01-30 10:00 Kirill A. Shutemov
  2025-01-30 10:00 ` [PATCHv3 01/11] mm/migrate: Transfer PG_dropbehind to the new folio Kirill A. Shutemov
                   ` (10 more replies)
  0 siblings, 11 replies; 26+ messages in thread
From: Kirill A. Shutemov @ 2025-01-30 10:00 UTC (permalink / raw)
  To: Andrew Morton, Matthew Wilcox (Oracle), Jens Axboe
  Cc: Jason A. Donenfeld, Kirill A. Shutemov, Andi Shyti,
	Chengming Zhou, Christian Brauner, Christophe Leroy,
	Dan Carpenter, David Airlie, David Hildenbrand, Hao Ge,
	Jani Nikula, Johannes Weiner, Joonas Lahtinen, Josef Bacik,
	Masami Hiramatsu, Mathieu Desnoyers, Miklos Szeredi, Nhat Pham,
	Oscar Salvador, Ran Xiaokai, Rodrigo Vivi, Simona Vetter,
	Steven Rostedt, Tvrtko Ursulin, Vlastimil Babka, Yosry Ahmed,
	Yu Zhao, intel-gfx, dri-devel, linux-kernel, linux-fsdevel,
	linux-mm, linux-trace-kernel

Use PG_dropbehind instead of PG_reclaim and remove PG_reclaim.

After removing PG_relcaim, PG_readahead is exclusive user of the page
flag bit.

Once PG_reclaim is gone, we can rename PG_dropbehind to PG_reclaim.

v3:
  - Condition folio_set_dropbehind() call in mapping_try_invalidate() on
    !unevictable and !mapped;
  - Add Reviewed-by tag by Yu Zhao;

Kirill A. Shutemov (11):
  mm/migrate: Transfer PG_dropbehind to the new folio
  drm/i915/gem: Convert __shmem_writeback() to folios
  drm/i915/gem: Use PG_dropbehind instead of PG_reclaim
  mm/zswap: Use PG_dropbehind instead of PG_reclaim
  mm/truncate: Use folio_set_dropbehind() instead of
    deactivate_file_folio()
  mm/vmscan: Use PG_dropbehind instead of PG_reclaim
  mm/vmscan: Use PG_dropbehind instead of PG_reclaim in
    shrink_folio_list()
  mm/mglru: Check PG_dropbehind instead of PG_reclaim in
    lru_gen_folio_seq()
  mm: Remove PG_reclaim
  mm/vmscan: Do not demote PG_dropbehind folios
  mm: Rename PG_dropbehind to PG_reclaim

 drivers/gpu/drm/i915/gem/i915_gem_shmem.c |  18 ++-
 fs/fuse/dev.c                             |   2 +-
 fs/proc/page.c                            |   2 +-
 include/linux/mm_inline.h                 |  18 +--
 include/linux/page-flags.h                |  23 ++--
 include/linux/pagemap.h                   |   2 +-
 include/trace/events/mmflags.h            |   4 +-
 include/uapi/linux/kernel-page-flags.h    |   2 +-
 mm/filemap.c                              |  46 +++----
 mm/internal.h                             |   1 -
 mm/migrate.c                              |  14 +-
 mm/page-writeback.c                       |  16 +--
 mm/page_io.c                              |  15 +--
 mm/readahead.c                            |   4 +-
 mm/swap.c                                 | 153 +---------------------
 mm/truncate.c                             |   5 +-
 mm/vmscan.c                               |  28 +---
 mm/zswap.c                                |   2 +-
 tools/mm/page-types.c                     |   8 +-
 19 files changed, 68 insertions(+), 295 deletions(-)

-- 
2.47.2


^ permalink raw reply	[flat|nested] 26+ messages in thread

end of thread, other threads:[~2025-02-06  6:34 UTC | newest]

Thread overview: 26+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-01-30 10:00 [PATCHv3 00/11] Get rid of PG_reclaim and rename PG_dropbehind Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 01/11] mm/migrate: Transfer PG_dropbehind to the new folio Kirill A. Shutemov
2025-01-30 20:36   ` Yu Zhao
2025-01-30 10:00 ` [PATCHv3 02/11] drm/i915/gem: Convert __shmem_writeback() to folios Kirill A. Shutemov
2025-01-31 13:37   ` Andi Shyti
2025-01-31 14:21   ` Matthew Wilcox
2025-01-31 20:27   ` Shakeel Butt
2025-01-30 10:00 ` [PATCHv3 03/11] drm/i915/gem: Use PG_dropbehind instead of PG_reclaim Kirill A. Shutemov
2025-01-31 13:38   ` Andi Shyti
2025-01-30 10:00 ` [PATCHv3 04/11] mm/zswap: " Kirill A. Shutemov
2025-01-30 17:39   ` Nhat Pham
2025-01-30 10:00 ` [PATCHv3 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio() Kirill A. Shutemov
2025-01-30 20:34   ` Yu Zhao
2025-01-30 10:00 ` [PATCHv3 06/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim Kirill A. Shutemov
2025-01-31 21:32   ` Shakeel Butt
2025-02-01  8:01   ` Kairui Song
2025-02-03  7:14     ` Yu Zhao
2025-02-03  8:39     ` Kirill A. Shutemov
2025-02-04  0:47       ` Andrew Morton
2025-02-06  6:34       ` Sergey Senozhatsky
2025-01-30 10:00 ` [PATCHv3 07/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim in shrink_folio_list() Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 08/11] mm/mglru: Check PG_dropbehind instead of PG_reclaim in lru_gen_folio_seq() Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 09/11] mm: Remove PG_reclaim Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 10/11] mm/vmscan: Do not demote PG_dropbehind folios Kirill A. Shutemov
2025-01-30 10:00 ` [PATCHv3 11/11] mm: Rename PG_dropbehind to PG_reclaim Kirill A. Shutemov
2025-01-30 20:38   ` Yu Zhao

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox