* [GIT PULL] Driver core changes for 6.16-rc1
@ 2025-05-28 15:56 Greg KH
2025-05-28 16:16 ` Thomas Weißschuh
2025-05-29 16:42 ` pr-tracker-bot
0 siblings, 2 replies; 6+ messages in thread
From: Greg KH @ 2025-05-28 15:56 UTC (permalink / raw)
To: Linus Torvalds, Andrew Morton
Cc: Rafael J. Wysocki, Danilo Krummrich, linux-kernel,
Stephen Rothwell
The following changes since commit 82f2b0b97b36ee3fcddf0f0780a9a0825d52fec3:
Linux 6.15-rc6 (2025-05-11 14:54:11 -0700)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/driver-core/driver-core.git tags/driver-core-6.16-rc1
for you to fetch changes up to 071d8e4c2a3b0999a9b822e2eb8854784a350f8a:
kernfs: Relax constraint in draining guard (2025-05-21 14:23:13 +0200)
----------------------------------------------------------------
Driver core changes for 6.16-rc1
Here are the driver core / kernfs changes for 6.16-rc1.
Not a huge number of changes this development cycle, here's the summary
of what is included in here:
- kernfs locking tweaks, pushing some global locks down into a per-fs
image lock
- rust driver core and pci device bindings added for new features.
- sysfs const work for bin_attributes. This churn should now be
completed for those types of attributes
- auxbus device creation helpers added
- fauxbus fix for creating sysfs files after the probe completed
properly
- other tiny updates for driver core things.
All of these have been in linux-next for over a week with no reported
issues.
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
----------------------------------------------------------------
Andy Shevchenko (2):
devres: Move devm_*_action*() APIs to devres.h
devres: Add devm_is_action_added() helper
Dan Carpenter (1):
driver core: auxiliary bus: Fix IS_ERR() vs NULL mixup in __devm_auxiliary_device_create()
Danilo Krummrich (10):
rust: device: implement impl_device_context_deref!
rust: device: implement impl_device_context_into_aref!
rust: device: implement device context for Device
rust: platform: preserve device context in AsRef
rust: pci: preserve device context in AsRef
rust: device: implement Bound device context
rust: pci: move iomap_region() to impl Device<Bound>
rust: devres: require a bound device
rust: dma: require a bound device
Merge tag 'topic/device-context-2025-04-17' into driver-core-next
Eric Biggers (1):
firmware_loader: use SHA-256 library API instead of crypto_shash API
Greg Kroah-Hartman (4):
Merge 6.15-rc4 into driver-core-next
Merge tag 'gpiod-devm-is-action-added-for-v6.16-rc1' of ssh://gitolite.kernel.org/pub/scm/linux/kernel/git/brgl/linux into driver-core-next
Merge 6.15-rc6 into driver-core-next
drivers: hv: fix up const issue with vmbus_chan_bin_attrs
Jerome Brunet (1):
driver core: auxiliary bus: add device creation helpers
Jinliang Zheng (2):
kernfs: switch global kernfs_idr_lock to per-fs lock
kernfs: switch global kernfs_rename_lock to per-fs lock
Johan Hovold (1):
component: do not try to unbind unbound components
Kurt Borja (1):
driver core: faux: Add sysfs groups after probing
Michael Ellerman (1):
Documentation: embargoed-hardware-issues.rst: Remove myself
Michal Koutný (1):
kernfs: Relax constraint in draining guard
Raag Jadav (1):
devres: simplify devm_kstrdup() using devm_kmemdup()
Thomas Weißschuh (2):
sysfs: constify bin_attribute argument of bin_attribute::read/write()
sysfs: constify attribute_group::bin_attrs
Timur Tabi (1):
docs: debugfs: do not recommend debugfs_remove_recursive
Woody Zhang (1):
platform: replace magic number with macro PLATFORM_DEVID_NONE
Zijun Hu (2):
software node: Correct a OOB check in software_node_get_reference_args()
PM: wakeup: Do not expose 4 device wakeup source APIs
Documentation/filesystems/debugfs.rst | 19 ++--
.../driver_development_debugging_guide.rst | 2 +-
.../process/embargoed-hardware-issues.rst | 1 -
drivers/base/auxiliary.c | 108 +++++++++++++++++++++
drivers/base/component.c | 3 +-
drivers/base/devres.c | 20 ++--
drivers/base/faux.c | 22 ++++-
drivers/base/firmware_loader/Kconfig | 4 +-
drivers/base/firmware_loader/main.c | 34 +------
drivers/base/platform.c | 2 +-
drivers/base/power/wakeup.c | 12 +--
drivers/base/swnode.c | 2 +-
drivers/hv/vmbus_drv.c | 2 +-
fs/kernfs/dir.c | 33 ++++---
fs/kernfs/file.c | 3 +-
fs/kernfs/kernfs-internal.h | 16 ++-
fs/sysfs/group.c | 6 +-
include/linux/auxiliary_bus.h | 17 ++++
include/linux/device.h | 38 --------
include/linux/device/devres.h | 41 ++++++++
include/linux/pm_wakeup.h | 15 ---
include/linux/sysfs.h | 27 +-----
rust/kernel/device.rs | 90 ++++++++++++++++-
rust/kernel/devres.rs | 17 ++--
rust/kernel/dma.rs | 14 +--
rust/kernel/pci.rs | 33 +++----
rust/kernel/platform.rs | 32 ++----
27 files changed, 378 insertions(+), 235 deletions(-)
^ permalink raw reply [flat|nested] 6+ messages in thread* Re: [GIT PULL] Driver core changes for 6.16-rc1
2025-05-28 15:56 [GIT PULL] Driver core changes for 6.16-rc1 Greg KH
@ 2025-05-28 16:16 ` Thomas Weißschuh
2025-05-28 16:29 ` Greg KH
2025-05-29 16:42 ` pr-tracker-bot
1 sibling, 1 reply; 6+ messages in thread
From: Thomas Weißschuh @ 2025-05-28 16:16 UTC (permalink / raw)
To: Greg KH
Cc: Linus Torvalds, Andrew Morton, Rafael J. Wysocki,
Danilo Krummrich, linux-kernel, Stephen Rothwell
Hi Greg,
On 2025-05-28 17:56:52+0200, Greg KH wrote:
> The following changes since commit 82f2b0b97b36ee3fcddf0f0780a9a0825d52fec3:
>
> Linux 6.15-rc6 (2025-05-11 14:54:11 -0700)
>
> are available in the Git repository at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/driver-core/driver-core.git tags/driver-core-6.16-rc1
>
> for you to fetch changes up to 071d8e4c2a3b0999a9b822e2eb8854784a350f8a:
>
> kernfs: Relax constraint in draining guard (2025-05-21 14:23:13 +0200)
>
> ----------------------------------------------------------------
> Driver core changes for 6.16-rc1
>
> Here are the driver core / kernfs changes for 6.16-rc1.
>
> Not a huge number of changes this development cycle, here's the summary
> of what is included in here:
> - kernfs locking tweaks, pushing some global locks down into a per-fs
> image lock
> - rust driver core and pci device bindings added for new features.
> - sysfs const work for bin_attributes. This churn should now be
> completed for those types of attributes
This is missing the switch away and removal of the transitional
struct members, "read_new", "write_new" and "bin_attrs_new".
These are the actually churny changes.
I have a branch with those, based on current linux-next/master, at
https://git.kernel.org/pub/scm/linux/kernel/git/thomas.weissschuh/linux.git b4/sysfs-const-bin_attr-final
(Has not yet passed 0day, but earlier versions this week did)
Do you want me to resubmit it to you? Now or shortly before the end of
the merge window?
> - auxbus device creation helpers added
> - fauxbus fix for creating sysfs files after the probe completed
> properly
> - other tiny updates for driver core things.
>
> All of these have been in linux-next for over a week with no reported
> issues.
<snip>
> Thomas Weißschuh (2):
> sysfs: constify bin_attribute argument of bin_attribute::read/write()
> sysfs: constify attribute_group::bin_attrs
<snip>
Thomas
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [GIT PULL] Driver core changes for 6.16-rc1
2025-05-28 16:16 ` Thomas Weißschuh
@ 2025-05-28 16:29 ` Greg KH
2025-05-31 11:40 ` Thomas Weißschuh
0 siblings, 1 reply; 6+ messages in thread
From: Greg KH @ 2025-05-28 16:29 UTC (permalink / raw)
To: Thomas Weißschuh
Cc: Linus Torvalds, Andrew Morton, Rafael J. Wysocki,
Danilo Krummrich, linux-kernel, Stephen Rothwell
On Wed, May 28, 2025 at 06:16:21PM +0200, Thomas Weißschuh wrote:
> Hi Greg,
>
> On 2025-05-28 17:56:52+0200, Greg KH wrote:
> > The following changes since commit 82f2b0b97b36ee3fcddf0f0780a9a0825d52fec3:
> >
> > Linux 6.15-rc6 (2025-05-11 14:54:11 -0700)
> >
> > are available in the Git repository at:
> >
> > git://git.kernel.org/pub/scm/linux/kernel/git/driver-core/driver-core.git tags/driver-core-6.16-rc1
> >
> > for you to fetch changes up to 071d8e4c2a3b0999a9b822e2eb8854784a350f8a:
> >
> > kernfs: Relax constraint in draining guard (2025-05-21 14:23:13 +0200)
> >
> > ----------------------------------------------------------------
> > Driver core changes for 6.16-rc1
> >
> > Here are the driver core / kernfs changes for 6.16-rc1.
> >
> > Not a huge number of changes this development cycle, here's the summary
> > of what is included in here:
> > - kernfs locking tweaks, pushing some global locks down into a per-fs
> > image lock
> > - rust driver core and pci device bindings added for new features.
>
> > - sysfs const work for bin_attributes. This churn should now be
> > completed for those types of attributes
>
> This is missing the switch away and removal of the transitional
> struct members, "read_new", "write_new" and "bin_attrs_new".
> These are the actually churny changes.
>
> I have a branch with those, based on current linux-next/master, at
> https://git.kernel.org/pub/scm/linux/kernel/git/thomas.weissschuh/linux.git b4/sysfs-const-bin_attr-final
>
> (Has not yet passed 0day, but earlier versions this week did)
>
> Do you want me to resubmit it to you? Now or shortly before the end of
> the merge window?
Ah, yes, those are still in my "to apply after -rc1 is out" queue, sorry
about that. And yes, I'll be glad to take updated versions as things
have changed.
thanks,
greg k-h
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [GIT PULL] Driver core changes for 6.16-rc1
2025-05-28 16:29 ` Greg KH
@ 2025-05-31 11:40 ` Thomas Weißschuh
2025-05-31 12:25 ` Greg KH
0 siblings, 1 reply; 6+ messages in thread
From: Thomas Weißschuh @ 2025-05-31 11:40 UTC (permalink / raw)
To: Greg KH; +Cc: Rafael J. Wysocki, Danilo Krummrich, linux-kernel
(trimmed the CC-list)
Hi Greg,
On 2025-05-28 18:29:20+0200, Greg KH wrote:
> On Wed, May 28, 2025 at 06:16:21PM +0200, Thomas Weißschuh wrote:
> > On 2025-05-28 17:56:52+0200, Greg KH wrote:
<snip>
> > > Here are the driver core / kernfs changes for 6.16-rc1.
> > >
> > > Not a huge number of changes this development cycle, here's the summary
> > > of what is included in here:
> > > - kernfs locking tweaks, pushing some global locks down into a per-fs
> > > image lock
> > > - rust driver core and pci device bindings added for new features.
> >
> > > - sysfs const work for bin_attributes. This churn should now be
> > > completed for those types of attributes
> >
> > This is missing the switch away and removal of the transitional
> > struct members, "read_new", "write_new" and "bin_attrs_new".
> > These are the actually churny changes.
<snip>
> > Do you want me to resubmit it to you? Now or shortly before the end of
> > the merge window?
>
> Ah, yes, those are still in my "to apply after -rc1 is out" queue, sorry
> about that. And yes, I'll be glad to take updated versions as things
> have changed.
In case you don't see patches submitted during the merge window,
here is the updated series:
https://lore.kernel.org/lkml/20250530-sysfs-const-bin_attr-final-v3-0-724bfcf05b99@weissschuh.net/
Based on linux-next to make sure that all changes that could go into the
merge window are accounted for.
Thomas
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [GIT PULL] Driver core changes for 6.16-rc1
2025-05-31 11:40 ` Thomas Weißschuh
@ 2025-05-31 12:25 ` Greg KH
0 siblings, 0 replies; 6+ messages in thread
From: Greg KH @ 2025-05-31 12:25 UTC (permalink / raw)
To: Thomas Weißschuh; +Cc: Rafael J. Wysocki, Danilo Krummrich, linux-kernel
On Sat, May 31, 2025 at 01:40:13PM +0200, Thomas Weißschuh wrote:
> (trimmed the CC-list)
>
> Hi Greg,
>
> On 2025-05-28 18:29:20+0200, Greg KH wrote:
> > On Wed, May 28, 2025 at 06:16:21PM +0200, Thomas Weißschuh wrote:
> > > On 2025-05-28 17:56:52+0200, Greg KH wrote:
>
> <snip>
>
> > > > Here are the driver core / kernfs changes for 6.16-rc1.
> > > >
> > > > Not a huge number of changes this development cycle, here's the summary
> > > > of what is included in here:
> > > > - kernfs locking tweaks, pushing some global locks down into a per-fs
> > > > image lock
> > > > - rust driver core and pci device bindings added for new features.
> > >
> > > > - sysfs const work for bin_attributes. This churn should now be
> > > > completed for those types of attributes
> > >
> > > This is missing the switch away and removal of the transitional
> > > struct members, "read_new", "write_new" and "bin_attrs_new".
> > > These are the actually churny changes.
>
> <snip>
>
> > > Do you want me to resubmit it to you? Now or shortly before the end of
> > > the merge window?
> >
> > Ah, yes, those are still in my "to apply after -rc1 is out" queue, sorry
> > about that. And yes, I'll be glad to take updated versions as things
> > have changed.
>
> In case you don't see patches submitted during the merge window,
> here is the updated series:
>
> https://lore.kernel.org/lkml/20250530-sysfs-const-bin_attr-final-v3-0-724bfcf05b99@weissschuh.net/
>
> Based on linux-next to make sure that all changes that could go into the
> merge window are accounted for.
I saw them, thanks! I'll look at them at the end of next week.
greg k-h
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [GIT PULL] Driver core changes for 6.16-rc1
2025-05-28 15:56 [GIT PULL] Driver core changes for 6.16-rc1 Greg KH
2025-05-28 16:16 ` Thomas Weißschuh
@ 2025-05-29 16:42 ` pr-tracker-bot
1 sibling, 0 replies; 6+ messages in thread
From: pr-tracker-bot @ 2025-05-29 16:42 UTC (permalink / raw)
To: Greg KH
Cc: Linus Torvalds, Andrew Morton, Rafael J. Wysocki,
Danilo Krummrich, linux-kernel, Stephen Rothwell
The pull request you sent on Wed, 28 May 2025 17:56:52 +0200:
> git://git.kernel.org/pub/scm/linux/kernel/git/driver-core/driver-core.git tags/driver-core-6.16-rc1
has been merged into torvalds/linux.git:
https://git.kernel.org/torvalds/c/9d230d500b0e5f7be863e2bf2386be5f80dd18aa
Thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/prtracker.html
^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2025-05-31 12:26 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-05-28 15:56 [GIT PULL] Driver core changes for 6.16-rc1 Greg KH
2025-05-28 16:16 ` Thomas Weißschuh
2025-05-28 16:29 ` Greg KH
2025-05-31 11:40 ` Thomas Weißschuh
2025-05-31 12:25 ` Greg KH
2025-05-29 16:42 ` pr-tracker-bot
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox