From: Wolfram Sang <wsa+renesas@sang-engineering.com>
To: Philipp Zabel <p.zabel@pengutronix.de>
Cc: linux-renesas-soc@vger.kernel.org,
Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>,
Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>,
linux-kernel@vger.kernel.org
Subject: Re: [RFC PATCH] reset: always bail out on missing RESET_GPIO driver
Date: Wed, 15 Oct 2025 20:08:09 +0200 [thread overview]
Message-ID: <aO_jCaplR1xUpj9M@shikoro> (raw)
In-Reply-To: <c4996204c8b72f10324af87516b92a3a2819091c.camel@pengutronix.de>
[-- Attachment #1: Type: text/plain, Size: 902 bytes --]
Hi Philipp,
> > On the other hand, the fallback is a really nice feature which could
> > remove duplicated code. But if the fallback is not present by default,
> > it makes it cumbersome to use IMO.
>
> And it's not easy to automatically determine whether RESET_GPIO is
> actually required, because that depends on both device tree and
> individual drivers.
Well, the driver is small enough to be included always, I'd think.
What about adding this to RESET_GPIO:
default y if GPIOLIB
?
> In short, if both of_parse_phandle_with_args() return -ENOENT, we
> should continue to silently return (optional ? NULL : -ENOENT), even if
> CONFIG_RESET_GPIO=n.
I think I got it.
> I think the message should be pr_err() level if we return an error that
> will cause the consumer driver probe to fail.
Ok, will send v2 tomorrow.
Thanks for the fast review!
Wolfram
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]
prev parent reply other threads:[~2025-10-15 18:08 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-15 11:28 [RFC PATCH] reset: always bail out on missing RESET_GPIO driver Wolfram Sang
2025-10-15 14:30 ` Philipp Zabel
2025-10-15 18:08 ` Wolfram Sang [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=aO_jCaplR1xUpj9M@shikoro \
--to=wsa+renesas@sang-engineering.com \
--cc=krzysztof.kozlowski@linaro.org \
--cc=kuninori.morimoto.gx@renesas.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=p.zabel@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox