The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Joao Martins <joao.m.martins@oracle.com>
Cc: Paolo Bonzini <pbonzini@redhat.com>,
	Ingo Molnar <mingo@redhat.com>, "H. Peter Anvin" <hpa@zytor.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org,
	kvm@vger.kernel.org, Radim Krcmar <rkrcmar@redhat.com>,
	xen-devel <xen-devel@lists.xenproject.org>,
	Boris Ostrovsky <boris.ostrovsky@oracle.com>,
	Juergen Gross <jgross@suse.com>,
	Andy Lutomirski <luto@amacapital.net>
Subject: Re: [PATCH v7 2/5] x86/pvclock: add setter for pvclock_pvti_cpu0_va
Date: Wed, 8 Nov 2017 14:10:55 +0100 (CET)	[thread overview]
Message-ID: <alpine.DEB.2.20.1711081410000.1937@nanos> (raw)
In-Reply-To: <36a22b0a-e745-4f6f-ca9a-fe549aad930e@oracle.com>

On Wed, 8 Nov 2017, Joao Martins wrote:
> On 11/08/2017 11:06 AM, Thomas Gleixner wrote:
> > The only nit-pick I have are the convoluted function names:
> > 
> >     pvclock_set_pvti_cpu0_va() pvclock_pvti_cpu0_va()
> > 
> > What on earth does that mean?
> >
> Those two functions respectively set and get in pvclock common code the address
> of a page for vCPU 0 containing time info (pvti, which is periodically updated
> by hypervisor). This region is guest memory and registered with hypervisor by
> guest PV clocksource and set in pvclock if certain conditions are met (i.e.
> PVCLOCK_TSC_STABLE_BIT is supported by hypervisor), and the getter is afterwards
> used by vdso and ptp_kvm.
> 
> FWIW I merely followed the current style/code of the existent function but there
> could be a better name like "pvclock_set_data() pvclock_get_data()". Albeit the
> current names are more explicit on what we should expect to set or return from
> the functions.

Fair enough.

> 
> > Aside of that can you please make it at least symetric, i.e. _set_ and
> > _get_ ?
> > 
> OK - Provided this is changing an exported symbol (pvclock_pvti_cpu0_va in use
> by ptp_kvm) and a non-functional change would you want me to address in a
> separate patch or it is OK to have in this one?

Just fixup the ptp_kvm call site in the very same patch.

Thanks,

	tglx

  reply	other threads:[~2017-11-08 13:11 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-10-19 13:39 [PATCH v7 0/5] x86/xen: pvclock vdso support Joao Martins
2017-10-19 13:39 ` [PATCH v7 1/5] ptp_kvm: probe for kvm guest availability Joao Martins
2017-10-20 14:33   ` Radim Krcmar
2017-10-19 13:39 ` [PATCH v7 2/5] x86/pvclock: add setter for pvclock_pvti_cpu0_va Joao Martins
2017-11-06 16:09   ` Paolo Bonzini
2017-11-07 19:29     ` Joao Martins
2017-11-08 11:06       ` Thomas Gleixner
2017-11-08 13:01         ` Joao Martins
2017-11-08 13:10           ` Thomas Gleixner [this message]
2017-10-19 13:39 ` [PATCH v7 3/5] x86/xen/time: set pvclock flags on xen_time_init() Joao Martins
2017-10-19 13:39 ` [PATCH v7 4/5] x86/xen/time: setup vcpu 0 time info page Joao Martins
2017-10-19 13:39 ` [PATCH v7 5/5] MAINTAINERS: xen, kvm: track pvclock-abi.h changes Joao Martins

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.20.1711081410000.1937@nanos \
    --to=tglx@linutronix.de \
    --cc=boris.ostrovsky@oracle.com \
    --cc=hpa@zytor.com \
    --cc=jgross@suse.com \
    --cc=joao.m.martins@oracle.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@amacapital.net \
    --cc=mingo@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=rkrcmar@redhat.com \
    --cc=x86@kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox