From: "Adrián Larumbe" <adrian.larumbe@collabora.com>
To: Boris Brezillon <boris.brezillon@collabora.com>
Cc: Rob Herring <robh@kernel.org>,
Steven Price <steven.price@arm.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>,
Simona Vetter <simona@ffwll.ch>,
Faith Ekstrand <faith.ekstrand@collabora.com>,
"Marty E. Plummer" <hanetzer@startmail.com>,
Tomeu Vizoso <tomeu@tomeuvizoso.net>,
Eric Anholt <eric@anholt.net>,
Alyssa Rosenzweig <alyssa.rosenzweig@collabora.com>,
Robin Murphy <robin.murphy@arm.com>,
Philipp Zabel <p.zabel@pengutronix.de>,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
Collabora Kernel Team <kernel@collabora.com>,
Neil Armstrong <neil.armstrong@linaro.org>
Subject: Re: [PATCH v5 07/11] drm/panfrost: Add debugfs knob for manually triggering a GPU reset
Date: Thu, 13 Aug 2026 13:20:29 +0100 [thread overview]
Message-ID: <an215ifaeM2C4gvL@sobremesa> (raw)
In-Reply-To: <20260812111751.285b5080@fedora-21.home>
On 12.08.2026 11:17, Boris Brezillon wrote:
> On Tue, 11 Aug 2026 22:42:16 +0100
> Adrián Larumbe <adrian.larumbe@collabora.com> wrote:
>
> > This will be of great help when testing potential races between the GPU
> > reset sequence and other parts of the code accessing HW registers.
> >
> > Signed-off-by: Adrián Larumbe <adrian.larumbe@collabora.com>
> > ---
> > drivers/gpu/drm/panfrost/panfrost_device.c | 39 ++++++++++++++++++++++++++++++
> > drivers/gpu/drm/panfrost/panfrost_device.h | 3 +++
> > drivers/gpu/drm/panfrost/panfrost_drv.c | 1 +
> > 3 files changed, 43 insertions(+)
> >
> > diff --git a/drivers/gpu/drm/panfrost/panfrost_device.c b/drivers/gpu/drm/panfrost/panfrost_device.c
> > index 52f4b8c6a05f..5b66173c75b9 100644
> > --- a/drivers/gpu/drm/panfrost/panfrost_device.c
> > +++ b/drivers/gpu/drm/panfrost/panfrost_device.c
> > @@ -2,6 +2,7 @@
> > /* Copyright 2018 Marty E. Plummer <hanetzer@startmail.com> */
> > /* Copyright 2019 Linaro, Ltd, Rob Herring <robh@kernel.org> */
> >
> > +#include <linux/debugfs.h>
> > #include <linux/clk.h>
> > #include <linux/reset.h>
> > #include <linux/platform_device.h>
> > @@ -608,3 +609,41 @@ void panfrost_device_reset(struct panfrost_device *pfdev, bool enable_job_int)
> > if (enable_job_int)
> > panfrost_jm_enable_interrupts(pfdev);
> > }
> > +
> > +#ifdef CONFIG_DEBUG_FS
> > +static int reset_get(void *data, u64 *val)
> > +{
> > + struct panfrost_device *pfdev =
> > + container_of(data, struct panfrost_device, base);
> > +
> > + *val = atomic_read(&pfdev->reset.pending);
> > + return 0;
> > +}
> > +
> > +static int reset_set(void *data, u64 val)
> > +{
> > + struct panfrost_device *pfdev =
> > + container_of(data, struct panfrost_device, base);
> > + int ret;
> > +
> > + ret = pm_runtime_get_if_in_use(pfdev->base.dev);
> > +
> > + if (ret > 0) {
> > + panfrost_device_schedule_reset(pfdev);
> > + flush_work(&pfdev->reset.work);
> > + pm_runtime_put(pfdev->base.dev);
> > + }
> > +
> > + return 0;
> > +}
> > +
> > +DEFINE_DEBUGFS_ATTRIBUTE(panfrost_reset_debugfs_fops,
> > + reset_get, reset_set,
> > + "0x%08llx\n");
> > +
> > +void panfrost_reset_debugfs_init(struct drm_minor *minor)
> > +{
> > + debugfs_create_file("reset", 0600, minor->debugfs_root,
> > + minor->dev, &panfrost_reset_debugfs_fops);
> > +}
> > +#endif // CONFIG_DEBUG_FS
> > diff --git a/drivers/gpu/drm/panfrost/panfrost_device.h b/drivers/gpu/drm/panfrost/panfrost_device.h
> > index 0fd33bc5b86f..4bbaaaf827a5 100644
> > --- a/drivers/gpu/drm/panfrost/panfrost_device.h
> > +++ b/drivers/gpu/drm/panfrost/panfrost_device.h
> > @@ -350,4 +350,7 @@ panfrost_device_started(struct panfrost_device *pfdev)
> > return pfdev->js;
> > }
> >
> > +#ifdef CONFIG_DEBUG_FS
> > +void panfrost_reset_debugfs_init(struct drm_minor *minor);
> > +#endif // CONFIG_DEBUG_FS
> > #endif
> > diff --git a/drivers/gpu/drm/panfrost/panfrost_drv.c b/drivers/gpu/drm/panfrost/panfrost_drv.c
> > index 8410de95e364..958f1d36ab10 100644
> > --- a/drivers/gpu/drm/panfrost/panfrost_drv.c
> > +++ b/drivers/gpu/drm/panfrost/panfrost_drv.c
> > @@ -916,6 +916,7 @@ static void panfrost_debugfs_init(struct drm_minor *minor)
> > {
> > panthor_gems_debugfs_init(minor);
> > panfrost_sched_debugfs_init(minor);
> > + panfrost_reset_debugfs_init(minor);
>
> Nit: I'd probably go for panfrost_device_debugfs_init(), and since gems
> and sched are sub-components of the device, I'd call the other
> panfrost_{gems,sched}_debugfs_init() helpers from
> panfrost_device_debugfs_init().
Acked, will do for the next iteration. Also, I noticed there's quite a bit of debugfs stuff
in panfrost_drv.c. I should probably move it all under the relevant subsystem file and make
the debugfs init functions available to panfrost_drv.c
> > }
> > #endif
> >
> >
next prev parent reply other threads:[~2026-08-13 12:21 UTC|newest]
Thread overview: 29+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-11 21:42 [PATCH v5 00/11] RPM, perfcnt and other minor fixes for Panfrost Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 01/11] drm/panfrost: Check another bo field for cache option query Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 02/11] drm/panfrost: Prevent division by 0 Adrián Larumbe
2026-08-12 7:59 ` Boris Brezillon
2026-08-11 21:42 ` [PATCH v5 03/11] drm/panfrost: Remove unnecessary header file include Adrián Larumbe
2026-08-12 8:00 ` Boris Brezillon
2026-08-11 21:42 ` [PATCH v5 04/11] drm/panfrost: Move shrinker initialization and unplug one level down Adrián Larumbe
2026-08-12 8:07 ` Boris Brezillon
2026-08-13 12:13 ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 05/11] drm/panfrost: Move all device power up and down into RPM callbacks Adrián Larumbe
2026-08-12 9:07 ` Boris Brezillon
2026-08-13 13:22 ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 06/11] drm/panfrost: Explicitly enable MMU interrupts at device init Adrián Larumbe
2026-08-12 9:14 ` Boris Brezillon
2026-08-13 12:41 ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 07/11] drm/panfrost: Add debugfs knob for manually triggering a GPU reset Adrián Larumbe
2026-08-12 9:17 ` Boris Brezillon
2026-08-13 12:20 ` Adrián Larumbe [this message]
2026-08-11 21:42 ` [PATCH v5 08/11] drm/panfrost: Move perfcnt GPU disable sequence into a helper Adrián Larumbe
2026-08-12 9:48 ` Boris Brezillon
2026-08-13 12:28 ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 09/11] drm/panfrost: Introduce a reset lock Adrián Larumbe
2026-08-12 9:44 ` Boris Brezillon
2026-08-12 9:45 ` Boris Brezillon
2026-08-13 12:50 ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 10/11] drm/panfrost: Fix races between perfcnt and reset sequence Adrián Larumbe
2026-08-12 10:06 ` Boris Brezillon
2026-08-13 12:50 ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 11/11] drm/panfrost: Bump driver minor to reflect new DUMP IOCTL req field Adrián Larumbe
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=an215ifaeM2C4gvL@sobremesa \
--to=adrian.larumbe@collabora.com \
--cc=airlied@gmail.com \
--cc=alyssa.rosenzweig@collabora.com \
--cc=boris.brezillon@collabora.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=eric@anholt.net \
--cc=faith.ekstrand@collabora.com \
--cc=hanetzer@startmail.com \
--cc=kernel@collabora.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=p.zabel@pengutronix.de \
--cc=robh@kernel.org \
--cc=robin.murphy@arm.com \
--cc=simona@ffwll.ch \
--cc=steven.price@arm.com \
--cc=tomeu@tomeuvizoso.net \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox