The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: "Adrián Larumbe" <adrian.larumbe@collabora.com>
To: Boris Brezillon <boris.brezillon@collabora.com>
Cc: Rob Herring <robh@kernel.org>,
	Steven Price <steven.price@arm.com>,
	 Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	Maxime Ripard <mripard@kernel.org>,
	 Thomas Zimmermann <tzimmermann@suse.de>,
	David Airlie <airlied@gmail.com>,
	 Simona Vetter <simona@ffwll.ch>,
	Faith Ekstrand <faith.ekstrand@collabora.com>,
	 "Marty E. Plummer" <hanetzer@startmail.com>,
	Tomeu Vizoso <tomeu@tomeuvizoso.net>,
	 Eric Anholt <eric@anholt.net>,
	Alyssa Rosenzweig <alyssa.rosenzweig@collabora.com>,
	 Robin Murphy <robin.murphy@arm.com>,
	Philipp Zabel <p.zabel@pengutronix.de>,
	 dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
	 Collabora Kernel Team <kernel@collabora.com>,
	Neil Armstrong <neil.armstrong@linaro.org>
Subject: Re: [PATCH v5 08/11] drm/panfrost: Move perfcnt GPU disable sequence into a helper
Date: Thu, 13 Aug 2026 13:28:35 +0100	[thread overview]
Message-ID: <an24SCQL-OGjFwRE@sobremesa> (raw)
In-Reply-To: <20260812114816.4d87360c@fedora-21.home>

On 12.08.2026 11:48, Boris Brezillon wrote:
> On Tue, 11 Aug 2026 22:42:17 +0100
> Adrián Larumbe <adrian.larumbe@collabora.com> wrote:
> 
> > Just for the sake of avoiding repetition.
> > 
> > Reviewed-by: Steven Price <steven.price@arm.com>
> > Reviewed-by: Boris Brezillon <boris.brezillon@collabora.com>
> > Signed-off-by: Adrián Larumbe <adrian.larumbe@collabora.com>
> > ---
> >  drivers/gpu/drm/panfrost/panfrost_perfcnt.c | 31 ++++++++++++-----------------
> >  1 file changed, 13 insertions(+), 18 deletions(-)
> > 
> > diff --git a/drivers/gpu/drm/panfrost/panfrost_perfcnt.c b/drivers/gpu/drm/panfrost/panfrost_perfcnt.c
> > index 7020c0192e18..ad1156678e91 100644
> > --- a/drivers/gpu/drm/panfrost/panfrost_perfcnt.c
> > +++ b/drivers/gpu/drm/panfrost/panfrost_perfcnt.c
> > @@ -35,6 +35,16 @@ struct panfrost_perfcnt {
> >  	struct completion dump_comp;
> >  };
> >  
> > +static void panfrost_perfcnt_gpu_disable(struct panfrost_device *pfdev)
> 
> I see you introduce panfrost_perfcnt_hw_enable() in patch 10, so maybe
> s/panfrost_perfcnt_gpu_disable/panfrost_perfcnt_hw_disable/ to be
> consistent.

Acked.

> > +{
> > +	gpu_write(pfdev, GPU_PERFCNT_CFG,
> > +		  GPU_PERFCNT_CFG_MODE(GPU_PERFCNT_CFG_MODE_OFF));
> > +	gpu_write(pfdev, GPU_PRFCNT_JM_EN, 0x0);
> > +	gpu_write(pfdev, GPU_PRFCNT_SHADER_EN, 0x0);
> > +	gpu_write(pfdev, GPU_PRFCNT_MMU_L2_EN, 0x0);
> > +	gpu_write(pfdev, GPU_PRFCNT_TILER_EN, 0);
> > +}
> > +
> >  void panfrost_perfcnt_clean_cache_done(struct panfrost_device *pfdev)
> >  {
> >  	complete(&pfdev->perfcnt->dump_comp);
> > @@ -193,12 +203,7 @@ static int panfrost_perfcnt_disable_locked(struct panfrost_device *pfdev,
> >  	if (user != perfcnt->user)
> >  		return -EINVAL;
> >  
> > -	gpu_write(pfdev, GPU_PRFCNT_JM_EN, 0x0);
> > -	gpu_write(pfdev, GPU_PRFCNT_SHADER_EN, 0x0);
> > -	gpu_write(pfdev, GPU_PRFCNT_MMU_L2_EN, 0x0);
> > -	gpu_write(pfdev, GPU_PRFCNT_TILER_EN, 0);
> > -	gpu_write(pfdev, GPU_PERFCNT_CFG,
> > -		  GPU_PERFCNT_CFG_MODE(GPU_PERFCNT_CFG_MODE_OFF));
> > +	panfrost_perfcnt_gpu_disable(pfdev);
> >  
> >  	perfcnt->user = NULL;
> >  	drm_gem_vunmap(&perfcnt->mapping->obj->base.base, &map);
> > @@ -327,12 +332,7 @@ int panfrost_perfcnt_init(struct panfrost_device *pfdev)
> >  	perfcnt->bosize = size;
> >  
> >  	/* Start with everything disabled. */
> > -	gpu_write(pfdev, GPU_PERFCNT_CFG,
> > -		  GPU_PERFCNT_CFG_MODE(GPU_PERFCNT_CFG_MODE_OFF));
> > -	gpu_write(pfdev, GPU_PRFCNT_JM_EN, 0);
> > -	gpu_write(pfdev, GPU_PRFCNT_SHADER_EN, 0);
> > -	gpu_write(pfdev, GPU_PRFCNT_MMU_L2_EN, 0);
> > -	gpu_write(pfdev, GPU_PRFCNT_TILER_EN, 0);
> > +	panfrost_perfcnt_gpu_disable(pfdev);
> >  
> >  	init_completion(&perfcnt->dump_comp);
> >  	mutex_init(&perfcnt->lock);
> > @@ -344,10 +344,5 @@ int panfrost_perfcnt_init(struct panfrost_device *pfdev)
> >  void panfrost_perfcnt_fini(struct panfrost_device *pfdev)
> >  {
> >  	/* Disable everything before leaving. */
> > -	gpu_write(pfdev, GPU_PERFCNT_CFG,
> > -		  GPU_PERFCNT_CFG_MODE(GPU_PERFCNT_CFG_MODE_OFF));
> > -	gpu_write(pfdev, GPU_PRFCNT_JM_EN, 0);
> > -	gpu_write(pfdev, GPU_PRFCNT_SHADER_EN, 0);
> > -	gpu_write(pfdev, GPU_PRFCNT_MMU_L2_EN, 0);
> > -	gpu_write(pfdev, GPU_PRFCNT_TILER_EN, 0);
> > +	panfrost_perfcnt_gpu_disable(pfdev);
> >  }
> > 


Adrian Larumbe

  reply	other threads:[~2026-08-13 12:29 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-11 21:42 [PATCH v5 00/11] RPM, perfcnt and other minor fixes for Panfrost Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 01/11] drm/panfrost: Check another bo field for cache option query Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 02/11] drm/panfrost: Prevent division by 0 Adrián Larumbe
2026-08-12  7:59   ` Boris Brezillon
2026-08-11 21:42 ` [PATCH v5 03/11] drm/panfrost: Remove unnecessary header file include Adrián Larumbe
2026-08-12  8:00   ` Boris Brezillon
2026-08-11 21:42 ` [PATCH v5 04/11] drm/panfrost: Move shrinker initialization and unplug one level down Adrián Larumbe
2026-08-12  8:07   ` Boris Brezillon
2026-08-13 12:13     ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 05/11] drm/panfrost: Move all device power up and down into RPM callbacks Adrián Larumbe
2026-08-12  9:07   ` Boris Brezillon
2026-08-13 13:22     ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 06/11] drm/panfrost: Explicitly enable MMU interrupts at device init Adrián Larumbe
2026-08-12  9:14   ` Boris Brezillon
2026-08-13 12:41     ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 07/11] drm/panfrost: Add debugfs knob for manually triggering a GPU reset Adrián Larumbe
2026-08-12  9:17   ` Boris Brezillon
2026-08-13 12:20     ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 08/11] drm/panfrost: Move perfcnt GPU disable sequence into a helper Adrián Larumbe
2026-08-12  9:48   ` Boris Brezillon
2026-08-13 12:28     ` Adrián Larumbe [this message]
2026-08-11 21:42 ` [PATCH v5 09/11] drm/panfrost: Introduce a reset lock Adrián Larumbe
2026-08-12  9:44   ` Boris Brezillon
2026-08-12  9:45   ` Boris Brezillon
2026-08-13 12:50     ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 10/11] drm/panfrost: Fix races between perfcnt and reset sequence Adrián Larumbe
2026-08-12 10:06   ` Boris Brezillon
2026-08-13 12:50     ` Adrián Larumbe
2026-08-11 21:42 ` [PATCH v5 11/11] drm/panfrost: Bump driver minor to reflect new DUMP IOCTL req field Adrián Larumbe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=an24SCQL-OGjFwRE@sobremesa \
    --to=adrian.larumbe@collabora.com \
    --cc=airlied@gmail.com \
    --cc=alyssa.rosenzweig@collabora.com \
    --cc=boris.brezillon@collabora.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=eric@anholt.net \
    --cc=faith.ekstrand@collabora.com \
    --cc=hanetzer@startmail.com \
    --cc=kernel@collabora.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mripard@kernel.org \
    --cc=neil.armstrong@linaro.org \
    --cc=p.zabel@pengutronix.de \
    --cc=robh@kernel.org \
    --cc=robin.murphy@arm.com \
    --cc=simona@ffwll.ch \
    --cc=steven.price@arm.com \
    --cc=tomeu@tomeuvizoso.net \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox