From: Akash Sukhavasi <akash.sukhavasi@gmail.com>
To: Neil Armstrong <neil.armstrong@linaro.org>
Cc: Doug Anderson <dianders@chromium.org>,
Linus Walleij <linusw@kernel.org>,
Jessica Zhang <jesszhan0024@gmail.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>,
Simona Vetter <simona@ffwll.ch>,
dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] drm/panel: samsung-s6d16d0: Use mipi_dsi_*_multi(); fix minor bugs
Date: Mon, 10 Aug 2026 17:46:12 -0500 [thread overview]
Message-ID: <anoquszHQ6LAMPbF@gmail.com> (raw)
In-Reply-To: <3aaca93e-ea45-4a57-9532-7fb95f23c4fa@linaro.org>
On Mon, Aug 10, 2026 at 11:57:06AM +0200, Neil Armstrong wrote:
> > + struct mipi_dsi_multi_context dsi_ctx = { .dsi = to_mipi_dsi_device(s6->dev) };
>
> Ok why not keeping the original:
>
> struct mipi_dsi_device *dsi = to_mipi_dsi_device(s6->dev);
> struct mipi_dsi_multi_context dsi_ctx = { .dsi = dsi };
>
>
> It's much easier to read, for me at least, but I won't block it...
>
> > /* Enter sleep mode */
> > - ret = mipi_dsi_dcs_enter_sleep_mode(dsi);
> > - if (ret) {
> > - dev_err(s6->dev, "failed to enter sleep mode (%d)\n", ret);
> > - return ret;
> > - }
> > + mipi_dsi_dcs_enter_sleep_mode_multi(&dsi_ctx);
>
> Add a comment you ignore the the dsi_ctx.accum_err and it's fine
> You could write:
>
> if (dsi_ctx.accum_err) {
> gpiod_set_value_cansleep(s6->reset_gpio, 1);
> regulator_disable(s6->supply);
> }
>
> return dsi_ctx.accum_err;
Thanks for the review, Neil. Will address all three in v2.
On the intermediate dsi variable, I prefer inlining it to keep one fewer
variable in scope, but I see the readability argument. Will revert it.
--
Thanks,
Akash
prev parent reply other threads:[~2026-08-10 22:46 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-07 22:55 [PATCH] drm/panel: samsung-s6d16d0: Use mipi_dsi_*_multi(); fix minor bugs Akash Sukhavasi
2026-08-10 9:57 ` Neil Armstrong
2026-08-10 22:46 ` Akash Sukhavasi [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anoquszHQ6LAMPbF@gmail.com \
--to=akash.sukhavasi@gmail.com \
--cc=airlied@gmail.com \
--cc=dianders@chromium.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=jesszhan0024@gmail.com \
--cc=linusw@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).