* + powernow-k8-fix-misleading-variable-naming.patch added to -mm tree
@ 2010-07-08 22:13 akpm
0 siblings, 0 replies; only message in thread
From: akpm @ 2010-07-08 22:13 UTC (permalink / raw)
To: mm-commits; +Cc: borislav.petkov, Mark.Langsdorf, davej, trenn
The patch titled
powernow-k8: fix misleading variable naming
has been added to the -mm tree. Its filename is
powernow-k8-fix-misleading-variable-naming.patch
Before you just go and hit "reply", please:
a) Consider who else should be cc'ed
b) Prefer to cc a suitable mailing list as well
c) Ideally: find the original patch on the mailing list and do a
reply-to-all to that, adding suitable additional cc's
*** Remember to use Documentation/SubmitChecklist when testing your code ***
See http://userweb.kernel.org/~akpm/stuff/added-to-mm.txt to find
out what to do about this
The current -mm tree may be found at http://userweb.kernel.org/~akpm/mmotm/
------------------------------------------------------
Subject: powernow-k8: fix misleading variable naming
From: Borislav Petkov <borislav.petkov@amd.com>
rdmsr() takes the lower 32 bits as a second argument and the high 32 as a
third. Fix the names accordingly since they were swapped.
There should be no functionality change resulting from this patch.
Signed-off-by: Borislav Petkov <borislav.petkov@amd.com>
Cc: Dave Jones <davej@redhat.com>
Cc: Mark Langsdorf <Mark.Langsdorf@amd.com>
Cc: Thomas Renninger <trenn@suse.de>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
---
arch/x86/kernel/cpu/cpufreq/powernow-k8.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff -puN arch/x86/kernel/cpu/cpufreq/powernow-k8.c~powernow-k8-fix-misleading-variable-naming arch/x86/kernel/cpu/cpufreq/powernow-k8.c
--- a/arch/x86/kernel/cpu/cpufreq/powernow-k8.c~powernow-k8-fix-misleading-variable-naming
+++ a/arch/x86/kernel/cpu/cpufreq/powernow-k8.c
@@ -912,8 +912,8 @@ static int fill_powernow_table_pstate(st
{
int i;
u32 hi = 0, lo = 0;
- rdmsr(MSR_PSTATE_CUR_LIMIT, hi, lo);
- data->max_hw_pstate = (hi & HW_PSTATE_MAX_MASK) >> HW_PSTATE_MAX_SHIFT;
+ rdmsr(MSR_PSTATE_CUR_LIMIT, lo, hi);
+ data->max_hw_pstate = (lo & HW_PSTATE_MAX_MASK) >> HW_PSTATE_MAX_SHIFT;
for (i = 0; i < data->acpi_data.state_count; i++) {
u32 index;
_
Patches currently in -mm which might be from borislav.petkov@amd.com are
linux-next.patch
powernow-k8-limit-pstate-transition-latency-check.patch
powernow-k8-fix-misleading-variable-naming.patch
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2010-07-08 22:14 UTC | newest]
Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2010-07-08 22:13 + powernow-k8-fix-misleading-variable-naming.patch added to -mm tree akpm
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox