* + fuse-use-clear_highpage-and-km_user0-instead-of-km_user1.patch added to -mm tree
@ 2010-09-15 19:12 akpm
0 siblings, 0 replies; only message in thread
From: akpm @ 2010-09-15 19:12 UTC (permalink / raw)
To: mm-commits; +Cc: mszeredi, jbeulich
The patch titled
fuse: use clear_highpage() and KM_USER0 instead of KM_USER1
has been added to the -mm tree. Its filename is
fuse-use-clear_highpage-and-km_user0-instead-of-km_user1.patch
Before you just go and hit "reply", please:
a) Consider who else should be cc'ed
b) Prefer to cc a suitable mailing list as well
c) Ideally: find the original patch on the mailing list and do a
reply-to-all to that, adding suitable additional cc's
*** Remember to use Documentation/SubmitChecklist when testing your code ***
See http://userweb.kernel.org/~akpm/stuff/added-to-mm.txt to find
out what to do about this
The current -mm tree may be found at http://userweb.kernel.org/~akpm/mmotm/
------------------------------------------------------
Subject: fuse: use clear_highpage() and KM_USER0 instead of KM_USER1
From: Miklos Szeredi <mszeredi@suse.cz>
Commit 7909b1c640 (fuse: don't use atomic kmap) removed KM_USER0 usage
from fuse/dev.c. Switch KM_USER1 uses to KM_USER0 for clarity. Also
replace open coded clear_highpage().
Signed-off-by: Miklos Szeredi <mszeredi@suse.cz>
Cc: Jan Beulich <jbeulich@novell.com>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
---
fs/fuse/dev.c | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)
diff -puN fs/fuse/dev.c~fuse-use-clear_highpage-and-km_user0-instead-of-km_user1 fs/fuse/dev.c
--- a/fs/fuse/dev.c~fuse-use-clear_highpage-and-km_user0-instead-of-km_user1
+++ a/fs/fuse/dev.c
@@ -809,11 +809,9 @@ static int fuse_copy_page(struct fuse_co
int err;
struct page *page = *pagep;
- if (page && zeroing && count < PAGE_SIZE) {
- void *mapaddr = kmap_atomic(page, KM_USER1);
- clear_page(mapaddr);
- kunmap_atomic(mapaddr, KM_USER1);
- }
+ if (page && zeroing && count < PAGE_SIZE)
+ clear_highpage(page);
+
while (count) {
if (cs->write && cs->pipebufs && page) {
return fuse_ref_page(cs, page, offset, count);
@@ -830,10 +828,10 @@ static int fuse_copy_page(struct fuse_co
}
}
if (page) {
- void *mapaddr = kmap_atomic(page, KM_USER1);
+ void *mapaddr = kmap_atomic(page, KM_USER0);
void *buf = mapaddr + offset;
offset += fuse_copy_do(cs, &buf, &count);
- kunmap_atomic(mapaddr, KM_USER1);
+ kunmap_atomic(mapaddr, KM_USER0);
} else
offset += fuse_copy_do(cs, NULL, &count);
}
_
Patches currently in -mm which might be from mszeredi@suse.cz are
fuse-use-clear_highpage-and-km_user0-instead-of-km_user1.patch
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2010-09-15 19:12 UTC | newest]
Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2010-09-15 19:12 + fuse-use-clear_highpage-and-km_user0-instead-of-km_user1.patch added to -mm tree akpm
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox