From: akpm@linux-foundation.org
To: pmladek@suse.com, akpm@linux-foundation.org, bp@suse.de,
jkosina@suse.cz, josh@joshtriplett.org, mhocko@suse.cz,
mingo@redhat.com, oleg@redhat.com, paulmck@linux.vnet.ibm.com,
peterz@infradead.org, rostedt@goodmis.org, tglx@linutronix.de,
tj@kernel.org, vbabka@suse.cz, mm-commits@vger.kernel.org
Subject: [merged] kthread-rename-probe_kthread_data-to-kthread_probe_data.patch removed from -mm tree
Date: Wed, 12 Oct 2016 12:26:00 -0700 [thread overview]
Message-ID: <57fe8e48.hddIL7j38uiKBZCj%akpm@linux-foundation.org> (raw)
The patch titled
Subject: kthread: rename probe_kthread_data() to kthread_probe_data()
has been removed from the -mm tree. Its filename was
kthread-rename-probe_kthread_data-to-kthread_probe_data.patch
This patch was dropped because it was merged into mainline or a subsystem tree
------------------------------------------------------
From: Petr Mladek <pmladek@suse.com>
Subject: kthread: rename probe_kthread_data() to kthread_probe_data()
Patch series "kthread: Kthread worker API improvements"
The intention of this patchset is to make it easier to manipulate and
maintain kthreads. Especially, I want to replace all the custom main
cycles with a generic one. Also I want to make the kthreads sleep in a
consistent state in a common place when there is no work.
This patch (of 11):
A good practice is to prefix the names of functions by the name of the
subsystem.
This patch fixes the name of probe_kthread_data(). The other wrong
functions names are part of the kthread worker API and will be fixed
separately.
Link: http://lkml.kernel.org/r/1470754545-17632-2-git-send-email-pmladek@suse.com
Signed-off-by: Petr Mladek <pmladek@suse.com>
Suggested-by: Andrew Morton <akpm@linux-foundation.org>
Acked-by: Tejun Heo <tj@kernel.org>
Cc: Oleg Nesterov <oleg@redhat.com>
Cc: Ingo Molnar <mingo@redhat.com>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Steven Rostedt <rostedt@goodmis.org>
Cc: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Cc: Josh Triplett <josh@joshtriplett.org>
Cc: Thomas Gleixner <tglx@linutronix.de>
Cc: Jiri Kosina <jkosina@suse.cz>
Cc: Borislav Petkov <bp@suse.de>
Cc: Michal Hocko <mhocko@suse.cz>
Cc: Vlastimil Babka <vbabka@suse.cz>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
---
include/linux/kthread.h | 2 +-
kernel/kthread.c | 4 ++--
kernel/workqueue.c | 2 +-
3 files changed, 4 insertions(+), 4 deletions(-)
diff -puN include/linux/kthread.h~kthread-rename-probe_kthread_data-to-kthread_probe_data include/linux/kthread.h
--- a/include/linux/kthread.h~kthread-rename-probe_kthread_data-to-kthread_probe_data
+++ a/include/linux/kthread.h
@@ -44,7 +44,7 @@ bool kthread_should_stop(void);
bool kthread_should_park(void);
bool kthread_freezable_should_stop(bool *was_frozen);
void *kthread_data(struct task_struct *k);
-void *probe_kthread_data(struct task_struct *k);
+void *kthread_probe_data(struct task_struct *k);
int kthread_park(struct task_struct *k);
void kthread_unpark(struct task_struct *k);
void kthread_parkme(void);
diff -puN kernel/kthread.c~kthread-rename-probe_kthread_data-to-kthread_probe_data kernel/kthread.c
--- a/kernel/kthread.c~kthread-rename-probe_kthread_data-to-kthread_probe_data
+++ a/kernel/kthread.c
@@ -138,7 +138,7 @@ void *kthread_data(struct task_struct *t
}
/**
- * probe_kthread_data - speculative version of kthread_data()
+ * kthread_probe_data - speculative version of kthread_data()
* @task: possible kthread task in question
*
* @task could be a kthread task. Return the data value specified when it
@@ -146,7 +146,7 @@ void *kthread_data(struct task_struct *t
* inaccessible for any reason, %NULL is returned. This function requires
* that @task itself is safe to dereference.
*/
-void *probe_kthread_data(struct task_struct *task)
+void *kthread_probe_data(struct task_struct *task)
{
struct kthread *kthread = to_kthread(task);
void *data = NULL;
diff -puN kernel/workqueue.c~kthread-rename-probe_kthread_data-to-kthread_probe_data kernel/workqueue.c
--- a/kernel/workqueue.c~kthread-rename-probe_kthread_data-to-kthread_probe_data
+++ a/kernel/workqueue.c
@@ -4261,7 +4261,7 @@ void print_worker_info(const char *log_l
* This function is called without any synchronization and @task
* could be in any state. Be careful with dereferences.
*/
- worker = probe_kthread_data(task);
+ worker = kthread_probe_data(task);
/*
* Carefully copy the associated workqueue's workfn and name. Keep
_
Patches currently in -mm which might be from pmladek@suse.com are
reply other threads:[~2016-10-12 19:26 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=57fe8e48.hddIL7j38uiKBZCj%akpm@linux-foundation.org \
--to=akpm@linux-foundation.org \
--cc=bp@suse.de \
--cc=jkosina@suse.cz \
--cc=josh@joshtriplett.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mhocko@suse.cz \
--cc=mingo@redhat.com \
--cc=mm-commits@vger.kernel.org \
--cc=oleg@redhat.com \
--cc=paulmck@linux.vnet.ibm.com \
--cc=peterz@infradead.org \
--cc=pmladek@suse.com \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
--cc=tj@kernel.org \
--cc=vbabka@suse.cz \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox