From: Joe Perches <joe@perches.com>
To: Anirban Chakraborty <anirban.chakraborty@qlogic.com>
Cc: David Miller <davem@davemloft.net>,
netdev <netdev@vger.kernel.org>,
Dept_NX_Linux_NIC_Driver <Dept_NX_Linux_NIC_Driver@qlogic.com>
Subject: Re: [PATCH net-next 2/2] qlcnic: Change CDRP function
Date: Tue, 13 Sep 2011 13:56:24 -0700 [thread overview]
Message-ID: <1315947384.25776.30.camel@Joe-Laptop> (raw)
In-Reply-To: <33055D09-742C-4751-9A4B-1AF11ED34E31@qlogic.com>
On Tue, 2011-09-13 at 13:28 -0700, Anirban Chakraborty wrote:
> On Sep 13, 2011, at 11:22 AM, Joe Perches wrote:
> > On Tue, 2011-09-13 at 11:06 -0700, Anirban Chakraborty wrote:
> >> Argument list to CDRP function has become unmanageably long. Fix it by properly
> >> declaring a struct that encompasses all the input and output parameters.
> > I don't think this is better.
> > I think you've overloaded the issue_cmd function and should
> > use separate issue_cmd_<type> functions instead.
> I did not overload issue_cmd(), instead I changed the function signature.
> -u32
> -qlcnic_issue_cmd(struct qlcnic_adapter *adapter,
> - u32 pci_fn, u32 version, u32 arg1, u32 arg2, u32 arg3, u32 cmd,
> - u32 *rd_args[3])
> +void
> +qlcnic_issue_cmd(struct qlcnic_adapter *adapter, struct qlcnic_cmd_args *cmd)
> Instead of having a long list of arguments, I put them into a struct and passed it around.
Yes, I saw that.
I think that if restructuring is done, perhaps there are
better alternatives to bundling all the arguments into a
single struct.
I think it might be more sensible to have multiple
issue_cmd_<cmd>(adapter, [appropriate_args]) functions
instead so that the arguments and returns are appropriate
for the cmd performed.
or maybe use
issue_cmd(adapter, cmd, struct)
so you make cmd explicit and it's a bit easier to read
if you really must use some struct where cmd doesn't
use all the elements of struct.
next prev parent reply other threads:[~2011-09-13 20:56 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-09-13 18:06 [PATCH net-next 1/2] qlcnic: Added error logging for firmware abort Anirban Chakraborty
2011-09-13 18:06 ` [PATCH net-next 2/2] qlcnic: Change CDRP function Anirban Chakraborty
2011-09-13 18:22 ` Joe Perches
2011-09-13 20:28 ` Anirban Chakraborty
2011-09-13 20:56 ` Joe Perches [this message]
2011-09-13 21:15 ` Anirban Chakraborty
2011-09-13 18:06 ` [PATCH net-next 0/2] qlcnic: Fixes Anirban Chakraborty
2011-09-23 18:10 ` Anirban Chakraborty
2011-09-23 18:24 ` David Miller
2011-09-23 18:29 ` Anirban Chakraborty
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1315947384.25776.30.camel@Joe-Laptop \
--to=joe@perches.com \
--cc=Dept_NX_Linux_NIC_Driver@qlogic.com \
--cc=anirban.chakraborty@qlogic.com \
--cc=davem@davemloft.net \
--cc=netdev@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox