* [PATCH net-next v2] net: libwx: rename wx_pf_flags to wx_flags
@ 2026-09-01 6:56 Jiawen Wu
2026-09-03 13:40 ` patchwork-bot+netdevbpf
0 siblings, 1 reply; 2+ messages in thread
From: Jiawen Wu @ 2026-09-01 6:56 UTC (permalink / raw)
To: netdev
Cc: Mengyuan Lou, Andrew Lunn, David S. Miller, Eric Dumazet,
Jakub Kicinski, Paolo Abeni, Jacob Keller, Kees Cook,
Aleksandr Loktionov, Jiawen Wu, Breno Leitao
The flags defined in `enum wx_pf_flags` and its terminator
`WX_PF_FLAGS_NBITS` were originally named with a "PF" (Physical Function)
prefix. However, these flags are not exclusive to PFs and are also
utilized by Virtual Functions (VFs).
Rename the enumeration to `enum wx_flags` and the bit count to
`WX_FLAGS_NBITS` to accurately reflect their shared usage across both PF
and VF drivers, and to prevent potential confusion.
Signed-off-by: Jiawen Wu <jiawenwu@trustnetic.com>
Reviewed-by: Breno Leitao <leitao@debian.org>
---
Changes in v2:
- Rebase on new fixes.
---
drivers/net/ethernet/wangxun/libwx/wx_hw.c | 2 +-
drivers/net/ethernet/wangxun/libwx/wx_type.h | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/net/ethernet/wangxun/libwx/wx_hw.c b/drivers/net/ethernet/wangxun/libwx/wx_hw.c
index 122c4952d203..59cdd7d71e44 100644
--- a/drivers/net/ethernet/wangxun/libwx/wx_hw.c
+++ b/drivers/net/ethernet/wangxun/libwx/wx_hw.c
@@ -2520,7 +2520,7 @@ int wx_sw_init(struct wx *wx)
spin_lock_init(&wx->hw_stats_lock);
mutex_init(&wx->reset_lock);
bitmap_zero(wx->state, WX_STATE_NBITS);
- bitmap_zero(wx->flags, WX_PF_FLAGS_NBITS);
+ bitmap_zero(wx->flags, WX_FLAGS_NBITS);
set_bit(WX_STATE_DOWN, wx->state);
wx->misc_irq_domain = false;
diff --git a/drivers/net/ethernet/wangxun/libwx/wx_type.h b/drivers/net/ethernet/wangxun/libwx/wx_type.h
index 9454e90258d8..a05a8c1f4049 100644
--- a/drivers/net/ethernet/wangxun/libwx/wx_type.h
+++ b/drivers/net/ethernet/wangxun/libwx/wx_type.h
@@ -1269,7 +1269,7 @@ struct wx_rss_flow_map {
u8 flag;
};
-enum wx_pf_flags {
+enum wx_flags {
WX_FLAG_MULTI_64_FUNC,
WX_FLAG_SWFW_RING,
WX_FLAG_VMDQ_ENABLED,
@@ -1291,13 +1291,13 @@ enum wx_pf_flags {
WX_FLAG_RX_MERGE_ENABLED,
WX_FLAG_TXHEAD_WB_ENABLED,
WX_FLAG_NEED_PCIE_RECOVERY,
- WX_PF_FLAGS_NBITS /* must be last */
+ WX_FLAGS_NBITS /* must be last */
};
struct wx {
unsigned long active_vlans[BITS_TO_LONGS(VLAN_N_VID)];
DECLARE_BITMAP(state, WX_STATE_NBITS);
- DECLARE_BITMAP(flags, WX_PF_FLAGS_NBITS);
+ DECLARE_BITMAP(flags, WX_FLAGS_NBITS);
void *priv;
u8 __iomem *hw_addr;
--
2.51.0
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH net-next v2] net: libwx: rename wx_pf_flags to wx_flags
2026-09-01 6:56 [PATCH net-next v2] net: libwx: rename wx_pf_flags to wx_flags Jiawen Wu
@ 2026-09-03 13:40 ` patchwork-bot+netdevbpf
0 siblings, 0 replies; 2+ messages in thread
From: patchwork-bot+netdevbpf @ 2026-09-03 13:40 UTC (permalink / raw)
To: Jiawen Wu
Cc: netdev, mengyuanlou, andrew+netdev, davem, edumazet, kuba, pabeni,
jacob.e.keller, kees, aleksandr.loktionov, leitao
Hello:
This patch was applied to netdev/net-next.git (main)
by Paolo Abeni <pabeni@redhat.com>:
On Tue, 1 Sep 2026 14:56:59 +0800 you wrote:
> The flags defined in `enum wx_pf_flags` and its terminator
> `WX_PF_FLAGS_NBITS` were originally named with a "PF" (Physical Function)
> prefix. However, these flags are not exclusive to PFs and are also
> utilized by Virtual Functions (VFs).
>
> Rename the enumeration to `enum wx_flags` and the bit count to
> `WX_FLAGS_NBITS` to accurately reflect their shared usage across both PF
> and VF drivers, and to prevent potential confusion.
>
> [...]
Here is the summary with links:
- [net-next,v2] net: libwx: rename wx_pf_flags to wx_flags
https://git.kernel.org/netdev/net-next/c/7042c8c193e5
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-09-03 13:41 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-09-01 6:56 [PATCH net-next v2] net: libwx: rename wx_pf_flags to wx_flags Jiawen Wu
2026-09-03 13:40 ` patchwork-bot+netdevbpf
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox