Netdev List
 help / color / mirror / Atom feed
From: David Miller <davem@davemloft.net>
To: gerrit@erg.abdn.ac.uk
Cc: netdev@vger.kernel.org, yoshfuji@linux-ipv6.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCHv2 2.6.17] net/ipv6/udp.c: remove duplicate udp_get_port code
Date: Sat, 26 Aug 2006 20:07:16 -0700 (PDT)	[thread overview]
Message-ID: <20060826.200716.85410384.davem@davemloft.net> (raw)
In-Reply-To: <200608171325.47349@strip-the-willow>

From: gerrit@erg.abdn.ac.uk
Date: Thu, 17 Aug 2006 13:25:46 +0100

> [NET]: UDPv4 and UDPv6 use an almost identical version of the get_port function,
> which is unnecessary since the (long) code differs in only one if-statement.
> 
> This patch creates one common function which is called by udp_v4_get_port() and
> udp_v6_get_port(). As a result,
>   * duplicated code is removed
>   * udp_port_rover and local port lookup can now be removed from udp.h
>   * further savings follow since the same function will be used by UDP-Litev4 
>     and UDP-Litev6
> 
> In contrast to the patch sent in response to Yoshifujis comments (fixed by this
> variant), the code below also removes the EXPORT_SYMBOL(udp_port_rover), since
> udp_port_rover can now remain local to net/ipv4/udp.c.
> 
> Signed-off-by: Gerrit Renker <gerrit@erg.abdn.ac.uk>

Applied, and I marked udp_port_rover "static" for
good measure.

Thanks.


      parent reply	other threads:[~2006-08-27  3:07 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-08-17 12:25 [PATCHv2 2.6.17] net/ipv6/udp.c: remove duplicate udp_get_port code gerrit
2006-08-17 14:56 ` James Morris
2006-08-17 15:18   ` YOSHIFUJI Hideaki / 吉藤英明
2006-08-27  3:07 ` David Miller [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20060826.200716.85410384.davem@davemloft.net \
    --to=davem@davemloft.net \
    --cc=gerrit@erg.abdn.ac.uk \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=yoshfuji@linux-ipv6.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox