* [PATCH] qede: qede_fp: simplify a bit 'qede_rx_build_skb()'
@ 2019-09-20 4:56 Christophe JAILLET
2019-09-22 3:18 ` Jakub Kicinski
0 siblings, 1 reply; 2+ messages in thread
From: Christophe JAILLET @ 2019-09-20 4:56 UTC (permalink / raw)
To: aelior, GR-everest-linux-l2, davem
Cc: netdev, linux-kernel, kernel-janitors, Christophe JAILLET
Use 'skb_put_data()' instead of rewritting it.
This improves readability.
Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
drivers/net/ethernet/qlogic/qede/qede_fp.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/net/ethernet/qlogic/qede/qede_fp.c b/drivers/net/ethernet/qlogic/qede/qede_fp.c
index 0ae28f0d2523..004c0bfec41d 100644
--- a/drivers/net/ethernet/qlogic/qede/qede_fp.c
+++ b/drivers/net/ethernet/qlogic/qede/qede_fp.c
@@ -779,8 +779,7 @@ qede_rx_build_skb(struct qede_dev *edev,
return NULL;
skb_reserve(skb, pad);
- memcpy(skb_put(skb, len),
- page_address(bd->data) + offset, len);
+ skb_put_data(skb, page_address(bd->data) + offset, len);
qede_reuse_page(rxq, bd);
goto out;
}
--
2.20.1
^ permalink raw reply related [flat|nested] 2+ messages in thread
end of thread, other threads:[~2019-09-22 3:18 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2019-09-20 4:56 [PATCH] qede: qede_fp: simplify a bit 'qede_rx_build_skb()' Christophe JAILLET
2019-09-22 3:18 ` Jakub Kicinski
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox