Netdev List
 help / color / mirror / Atom feed
From: Marc Kleine-Budde <mkl@pengutronix.de>
To: netdev@vger.kernel.org
Cc: davem@davemloft.net, kuba@kernel.org, linux-can@vger.kernel.org,
	kernel@pengutronix.de,
	Vincent Mailhol <mailhol.vincent@wanadoo.fr>,
	Marc Kleine-Budde <mkl@pengutronix.de>
Subject: [PATCH net-next 13/22] can: etas_es58x: replace es58x_device::rx_max_packet_size by usb_maxpacket()
Date: Sat, 25 Jun 2022 14:03:26 +0200	[thread overview]
Message-ID: <20220625120335.324697-14-mkl@pengutronix.de> (raw)
In-Reply-To: <20220625120335.324697-1-mkl@pengutronix.de>

From: Vincent Mailhol <mailhol.vincent@wanadoo.fr>

The field rx_max_packet_size of struct es58x_device in nothing else
than usb_endpoint_descriptor::wMaxPacketSize and can be easily
retrieved using usb_maxpacket(). Also, rx_max_packet_size being used a
single time, there is no merit to cache it locally.

Remove es58x_device::rx_max_packet_size and rely on usb_maxpacket()
instead.

Link: https://lore.kernel.org/all/20220611162037.1507-2-mailhol.vincent@wanadoo.fr
Signed-off-by: Vincent Mailhol <mailhol.vincent@wanadoo.fr>
Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
---
 drivers/net/can/usb/etas_es58x/es58x_core.c | 5 ++---
 drivers/net/can/usb/etas_es58x/es58x_core.h | 2 --
 2 files changed, 2 insertions(+), 5 deletions(-)

diff --git a/drivers/net/can/usb/etas_es58x/es58x_core.c b/drivers/net/can/usb/etas_es58x/es58x_core.c
index 2d73ebbf3836..7353745f92d7 100644
--- a/drivers/net/can/usb/etas_es58x/es58x_core.c
+++ b/drivers/net/can/usb/etas_es58x/es58x_core.c
@@ -1707,7 +1707,7 @@ static int es58x_alloc_rx_urbs(struct es58x_device *es58x_dev)
 {
 	const struct device *dev = es58x_dev->dev;
 	const struct es58x_parameters *param = es58x_dev->param;
-	size_t rx_buf_len = es58x_dev->rx_max_packet_size;
+	u16 rx_buf_len = usb_maxpacket(es58x_dev->udev, es58x_dev->rx_pipe);
 	struct urb *urb;
 	u8 *buf;
 	int i;
@@ -1739,7 +1739,7 @@ static int es58x_alloc_rx_urbs(struct es58x_device *es58x_dev)
 		dev_err(dev, "%s: Could not setup any rx URBs\n", __func__);
 		return ret;
 	}
-	dev_dbg(dev, "%s: Allocated %d rx URBs each of size %zu\n",
+	dev_dbg(dev, "%s: Allocated %d rx URBs each of size %u\n",
 		__func__, i, rx_buf_len);
 
 	return ret;
@@ -2223,7 +2223,6 @@ static struct es58x_device *es58x_init_es58x_dev(struct usb_interface *intf,
 					     ep_in->bEndpointAddress);
 	es58x_dev->tx_pipe = usb_sndbulkpipe(es58x_dev->udev,
 					     ep_out->bEndpointAddress);
-	es58x_dev->rx_max_packet_size = le16_to_cpu(ep_in->wMaxPacketSize);
 
 	return es58x_dev;
 }
diff --git a/drivers/net/can/usb/etas_es58x/es58x_core.h b/drivers/net/can/usb/etas_es58x/es58x_core.h
index e5033cb5e695..512c5b7a1cfa 100644
--- a/drivers/net/can/usb/etas_es58x/es58x_core.h
+++ b/drivers/net/can/usb/etas_es58x/es58x_core.h
@@ -380,7 +380,6 @@ struct es58x_operators {
  * @timestamps: a temporary buffer to store the time stamps before
  *	feeding them to es58x_can_get_echo_skb(). Can only be used
  *	in RX branches.
- * @rx_max_packet_size: Maximum length of bulk-in URB.
  * @num_can_ch: Number of CAN channel (i.e. number of elements of @netdev).
  * @opened_channel_cnt: number of channels opened. Free of race
  *	conditions because its two users (net_device_ops:ndo_open()
@@ -414,7 +413,6 @@ struct es58x_device {
 
 	u64 timestamps[ES58X_ECHO_BULK_MAX];
 
-	u16 rx_max_packet_size;
 	u8 num_can_ch;
 	u8 opened_channel_cnt;
 
-- 
2.35.1



  parent reply	other threads:[~2022-06-25 12:07 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-06-25 12:03 [PATCH net-next 0/22] pull-request: can-next 2022-06-25 Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 01/22] can: xilinx_can: add Transmitter Delay Compensation (TDC) feature support Marc Kleine-Budde
2022-06-27 11:00   ` patchwork-bot+netdevbpf
2022-06-25 12:03 ` [PATCH net-next 02/22] can: xilinx_can: fix typo prescalar -> prescaler Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 03/22] can: m_can: " Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 04/22] can: netlink: allow configuring of fixed bit rates without need for do_set_bittiming callback Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 05/22] can: Kconfig: rename config symbol CAN_DEV into CAN_NETLINK Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 06/22] can: Kconfig: turn menu "CAN Device Drivers" into a menuconfig using CAN_DEV Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 07/22] can: bittiming: move bittiming calculation functions to calc_bittiming.c Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 08/22] can: Kconfig: add CONFIG_CAN_RX_OFFLOAD Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 09/22] net: Kconfig: move the CAN device menu to the "Device Drivers" section Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 10/22] can: skb: move can_dropped_invalid_skb() and can_skb_headroom_valid() to skb.c Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 11/22] can: skb: drop tx skb if in listen only mode Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 12/22] can: Break loopback loop on loopback documentation Marc Kleine-Budde
2022-06-25 12:03 ` Marc Kleine-Budde [this message]
2022-06-25 12:03 ` [PATCH net-next 14/22] can: etas_es58x: fix signedness of USB RX and TX pipes Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 15/22] dt-bindings: can: mpfs: document the mpfs CAN controller Marc Kleine-Budde
2022-06-27 11:05   ` Conor.Dooley
2022-06-25 12:03 ` [PATCH net-next 16/22] riscv: dts: microchip: add mpfs's CAN controllers Marc Kleine-Budde
2022-06-27  7:12   ` Conor.Dooley
2022-06-27  7:30     ` Marc Kleine-Budde
2022-06-27 11:17       ` Conor.Dooley
2022-06-27 11:23         ` Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 17/22] can: netlink: allow configuring of fixed data bit rates without need for do_set_data_bittiming callback Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 18/22] can/esd_usb2: Rename esd_usb2.c to esd_usb.c Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 19/22] can/esd_usb: Add an entry to the MAINTAINERS file Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 20/22] can/esd_usb: Rename all terms USB2 to USB Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 21/22] can/esd_usb: Fixed some checkpatch.pl warnings Marc Kleine-Budde
2022-06-25 12:03 ` [PATCH net-next 22/22] can/esd_usb: Update to copyright, M_AUTHOR and M_DESCRIPTION Marc Kleine-Budde

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220625120335.324697-14-mkl@pengutronix.de \
    --to=mkl@pengutronix.de \
    --cc=davem@davemloft.net \
    --cc=kernel@pengutronix.de \
    --cc=kuba@kernel.org \
    --cc=linux-can@vger.kernel.org \
    --cc=mailhol.vincent@wanadoo.fr \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox