* [PATCH net] net: 6lowpan: fix mismatched comments
@ 2026-08-06 9:10 Chenguang Zhao
2026-08-07 14:30 ` Simon Horman
0 siblings, 1 reply; 2+ messages in thread
From: Chenguang Zhao @ 2026-08-06 9:10 UTC (permalink / raw)
To: alex.aring, davem, edumazet, kuba, pabeni
Cc: horms, linux-bluetooth, linux-wpan, netdev, chenguang.zhao,
Chenguang Zhao
From: Chenguang Zhao <zhaochenguang@kylinos.cn>
Rename @_nexthdrlen to @_hdrlen and drop stale @nhc from
lowpan_nhc_do_uncompression docs
Signed-off-by: Chenguang Zhao <zhaochenguang@kylinos.cn>
---
net/6lowpan/nhc.h | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/net/6lowpan/nhc.h b/net/6lowpan/nhc.h
index ab7b4977c32b..c995029696d0 100644
--- a/net/6lowpan/nhc.h
+++ b/net/6lowpan/nhc.h
@@ -15,7 +15,7 @@
* @__nhc: variable name of the lowpan_nhc struct.
* @_name: const char * of common header compression name.
* @_nexthdr: ipv6 nexthdr field for the header compression.
- * @_nexthdrlen: ipv6 nexthdr len for the reserved space.
+ * @_hdrlen: ipv6 nexthdr len for the reserved space.
* @_id: one byte nhc id value.
* @_idmask: one byte nhc id mask value.
* @_uncompress: callback for uncompression call.
@@ -102,7 +102,6 @@ int lowpan_nhc_do_compression(struct sk_buff *skb, const struct ipv6hdr *hdr,
/**
* lowpan_nhc_do_uncompression - calling uncompress callback for nhc
*
- * @nhc: 6LoWPAN nhc context, get by lowpan_nhc_by_ functions.
* @skb: skb of 6LoWPAN header, skb->data should be pointed to nhc id value.
* @dev: netdevice for print logging information.
* @hdr: ipv6hdr for setting nexthdr value.
--
2.25.1
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH net] net: 6lowpan: fix mismatched comments
2026-08-06 9:10 [PATCH net] net: 6lowpan: fix mismatched comments Chenguang Zhao
@ 2026-08-07 14:30 ` Simon Horman
0 siblings, 0 replies; 2+ messages in thread
From: Simon Horman @ 2026-08-07 14:30 UTC (permalink / raw)
To: Chenguang Zhao
Cc: alex.aring, davem, edumazet, kuba, pabeni, linux-bluetooth,
linux-wpan, netdev, Chenguang Zhao
On Thu, Aug 06, 2026 at 05:10:45PM +0800, Chenguang Zhao wrote:
> From: Chenguang Zhao <zhaochenguang@kylinos.cn>
>
> Rename @_nexthdrlen to @_hdrlen and drop stale @nhc from
> lowpan_nhc_do_uncompression docs
>
> Signed-off-by: Chenguang Zhao <zhaochenguang@kylinos.cn>
Reviewed-by: Simon Horman <horms@kernel.org>
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-08-07 14:30 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-06 9:10 [PATCH net] net: 6lowpan: fix mismatched comments Chenguang Zhao
2026-08-07 14:30 ` Simon Horman
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox