From: Edward Cree <ecree.xilinx@gmail.com>
To: Marcelo Ricardo Leitner <marcelo.leitner@gmail.com>,
Oz Shlomo <ozsh@nvidia.com>
Cc: Paul Blakey <paulb@nvidia.com>,
netdev@vger.kernel.org, Saeed Mahameed <saeedm@nvidia.com>,
Paolo Abeni <pabeni@redhat.com>, Jakub Kicinski <kuba@kernel.org>,
Eric Dumazet <edumazet@google.com>,
Jamal Hadi Salim <jhs@mojatatu.com>,
Cong Wang <xiyou.wangcong@gmail.com>,
"David S. Miller" <davem@davemloft.net>,
Jiri Pirko <jiri@nvidia.com>, Roi Dayan <roid@nvidia.com>,
Vlad Buslov <vladbu@nvidia.com>,
Simon Horman <simon.horman@corigine.com>
Subject: Re: [PATCH net-next v9 1/7] net/sched: cls_api: Support hardware miss to tc action
Date: Tue, 14 Feb 2023 19:24:52 +0000 [thread overview]
Message-ID: <c060bf5f-4598-8a12-91d4-6340ecd24e14@gmail.com> (raw)
In-Reply-To: <Y+vXhDvkFL3DBqJu@t14s.localdomain>
On 14/02/2023 18:48, Marcelo Ricardo Leitner wrote:
> On Tue, Feb 14, 2023 at 02:31:06PM +0200, Oz Shlomo wrote:
>> Actually, I think the current naming scheme of act_cookie and miss_cookie
>> makes sense.
>
> Then perhaps,
> act_cookie here -> instance_cookie
> miss_cookie -> config_cookie
>
> Sorry for the bikeshedding, btw, but these cookies are getting
> confusing. We need them to taste nice :-}
I'm with Oz, keep the current name for act_cookie.
(In my ideal world, it'd just be called cookie, and the existing
cookie in struct flow_action_entry would be renamed user_cookie.
Because act_cookie is the same thing conceptually as
flow_cls_offload.cookie. Though I wonder if that means it
belongs in struct flow_offload_action instead?)
-ed
next prev parent reply other threads:[~2023-02-14 19:25 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-02-06 17:43 [PATCH net-next v9 0/7] net/sched: cls_api: Support hardware miss to tc action Paul Blakey
2023-02-06 17:43 ` [PATCH net-next v9 1/7] " Paul Blakey
2023-02-10 2:21 ` Marcelo Ricardo Leitner
2023-02-13 16:13 ` Paul Blakey
2023-02-13 18:43 ` Marcelo Ricardo Leitner
2023-02-14 12:14 ` Paul Blakey
2023-02-14 12:31 ` Oz Shlomo
2023-02-14 18:48 ` Marcelo Ricardo Leitner
2023-02-14 19:24 ` Edward Cree [this message]
2023-02-15 10:09 ` Paul Blakey
2023-02-15 16:14 ` Marcelo Ricardo Leitner
2023-02-06 17:43 ` [PATCH net-next v9 2/7] net/sched: flower: Move filter handle initialization earlier Paul Blakey
2023-02-06 17:43 ` [PATCH net-next v9 3/7] net/sched: flower: Support hardware miss to tc action Paul Blakey
2023-02-06 17:44 ` [PATCH net-next v9 4/7] net/mlx5: Kconfig: Make tc offload depend on tc skb extension Paul Blakey
2023-02-10 2:29 ` Marcelo Ricardo Leitner
2023-02-06 17:44 ` [PATCH net-next v9 5/7] net/mlx5: Refactor tc miss handling to a single function Paul Blakey
2023-02-06 17:44 ` [PATCH net-next v9 6/7] net/mlx5e: Rename CHAIN_TO_REG to MAPPED_OBJ_TO_REG Paul Blakey
2023-02-06 17:44 ` [PATCH net-next v9 7/7] net/mlx5e: TC, Set CT miss to the specific ct action instance Paul Blakey
2023-02-10 1:56 ` [PATCH net-next v9 0/7] net/sched: cls_api: Support hardware miss to tc action Marcelo Ricardo Leitner
2023-02-13 16:25 ` Paul Blakey
2023-02-13 18:27 ` Marcelo Ricardo Leitner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c060bf5f-4598-8a12-91d4-6340ecd24e14@gmail.com \
--to=ecree.xilinx@gmail.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=jhs@mojatatu.com \
--cc=jiri@nvidia.com \
--cc=kuba@kernel.org \
--cc=marcelo.leitner@gmail.com \
--cc=netdev@vger.kernel.org \
--cc=ozsh@nvidia.com \
--cc=pabeni@redhat.com \
--cc=paulb@nvidia.com \
--cc=roid@nvidia.com \
--cc=saeedm@nvidia.com \
--cc=simon.horman@corigine.com \
--cc=vladbu@nvidia.com \
--cc=xiyou.wangcong@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox