From: Patrick McHardy <kaber@trash.net>
To: Jan Engelhardt <jengelh@medozas.de>
Cc: Netfilter Developer Mailing List <netfilter-devel@vger.kernel.org>
Subject: Re: 5/7 [NETFILTER]: Introduce NFPROTO_* constants
Date: Thu, 04 Sep 2008 16:59:38 +0200 [thread overview]
Message-ID: <48BFF7DA.9030808@trash.net> (raw)
In-Reply-To: <alpine.LNX.1.10.0808131935220.13154@fbirervta.pbzchgretzou.qr>
Jan Engelhardt wrote:
> Patrick McHardy wrote, I remember:
>
>> What about PF_DECnet?
>
> Good spot. Netfilter would have crashed when trying to access
> nf_hooks[PF_DECnet], because the array was not big enough. Added
> NFPROTO_DECNET which implies an increased NFPROTO_NUMPROTO so that the
> out-of-bounds access is gone.
>
> commit e3666c7f73328a3762136f07e29e52386d05d21e
> Author: Jan Engelhardt <jengelh@computergmbh.de>
> Date: Wed Aug 13 19:38:42 2008 -0400
>
> [NETFILTER]: Introduce NFPROTO_* constants
>
> The netfilter subsystem only supports a handful of protocols (much
> less than PF_*) and even non-PF protocols like ARP and
> pseudo-protocols like PF_BRIDGE. By creating NFPROTO_*, we can earn a
> few memory savings on arrays that previously were always PF_MAX-sized
> and keep the pseudo-protocols to ourselves.
Looks great, applied.
next prev parent reply other threads:[~2008-09-04 14:59 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-08-13 23:25 1/7 [NETFILTER]: Use unsigned types for hooknum and pf vars Jan Engelhardt
2008-08-13 23:27 ` 2/7 [NETFILTER]: Rename ipt_recent to xt_recent Jan Engelhardt
2008-09-04 14:45 ` Patrick McHardy
2008-08-13 23:27 ` 3/7 [NETFILTER]: xt_recent: IPv6 support Jan Engelhardt
2008-09-04 14:48 ` Patrick McHardy
2008-08-13 23:27 ` 4/7 [NETFILTER]: xt_length match, revision 1 Jan Engelhardt
2008-09-04 14:56 ` Patrick McHardy
2008-09-04 15:56 ` Jan Engelhardt
2008-09-04 15:58 ` Patrick McHardy
2008-08-13 23:42 ` 5/7 [NETFILTER]: Introduce NFPROTO_* constants Jan Engelhardt
2008-09-04 14:59 ` Patrick McHardy [this message]
2008-08-13 23:43 ` 6/7 [NETFILTER]: Use NFPROTO_* in extensions Jan Engelhardt
2008-09-04 15:05 ` Patrick McHardy
2008-09-04 16:01 ` Patrick McHardy
2008-08-13 23:44 ` 7/7 [NETFILTER]: Implement NFPROTO_UNSPEC as a wildcard for extensions Jan Engelhardt
2008-09-04 15:10 ` Patrick McHardy
2008-09-04 15:41 ` Jan Engelhardt
2008-09-04 14:34 ` 1/7 [NETFILTER]: Use unsigned types for hooknum and pf vars Patrick McHardy
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=48BFF7DA.9030808@trash.net \
--to=kaber@trash.net \
--cc=jengelh@medozas.de \
--cc=netfilter-devel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox