Nouveau Archive on lore.kernel.org
 help / color / mirror / Atom feed
 messages from 2026-06-22 03:55:18 to 2026-07-11 17:04:46 UTC [more...]

[PATCH 00/13] convert more vm_flags_t users to vma_flags_t
 2026-07-11 17:04 UTC  (62+ messages)
` [PATCH 01/13] mm: introduce vma_flags_can_grow() and vma_can_grow()
` [PATCH 02/13] mm/vma: update do_mmap() to use vma_flags_t
` [PATCH 03/13] mm: convert __get_unmapped_area() "
` [PATCH 04/13] mm: update generic_get_unmapped_area[_topdown]() "
` [PATCH 05/13] mm: prefer mm->def_vma_flags in mm logic
` [PATCH 06/13] mm/vma: convert vm_pgprot_modify() to use vma_flags_t and rename
` [PATCH 07/13] mm/vma: rename vma_get_page_prot to vma_flags_to_page_prot
` [PATCH 08/13] mm: introduce vma_get_page_prot() and use it
` [PATCH 09/13] mm/vma: update create_init_stack_vma() to use vma_flags_t
` [PATCH 10/13] mm/vma: convert miscellaneous uses of VMA flags in core mm
` [PATCH 11/13] mm/mlock: convert mlock code to use vma_flags_t
` [PATCH 12/13] mm/mprotect: convert mprotect "
` [PATCH 13/13] mm/mremap: convert mremap "

[PATCH v8 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
 2026-07-11  5:49 UTC  (23+ messages)
` [PATCH v8 1/8] mm/hmm: move page fault handling out of walk callbacks
` [PATCH v8 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
` [PATCH v8 3/8] selftests/mm: add HMM test for mmap lock-dropping faults
` [PATCH v8 4/8] mshv: Use hmm_range_fault_unlocked_timeout() for region faults
` [PATCH v8 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH v8 6/8] RDMA/umem: Use hmm_range_fault_unlocked_timeout() for ODP faults
` [PATCH v8 7/8] accel/amdxdna: Use hmm_range_fault_unlocked_timeout() for range population
` [PATCH v8 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults

[PATCH v7 0/8] mm/hmm: Add mmap lock-drop support for userfaultfd-backed mappings
 2026-07-10 18:07 UTC  (23+ messages)
` [PATCH v7 1/8] mm/hmm: move page fault handling out of walk callbacks
` [PATCH v7 2/8] mm/hmm: add hmm_range_fault_unlocked_timeout() for mmap lock-drop support
` [PATCH v7 3/8] selftests/mm: add HMM tests for mmap lock-dropping faults
` [PATCH v7 4/8] mshv: Use hmm_range_fault_unlocked_timeout() for region faults
` [PATCH v7 5/8] drm/nouveau: Use hmm_range_fault_unlocked_timeout() for SVM faults
` [PATCH v7 6/8] RDMA/umem: Use hmm_range_fault_unlocked_timeout() for ODP faults
` [PATCH v7 7/8] accel/amdxdna: Use hmm_range_fault_unlocked_timeout() for range population
` [PATCH v7 8/8] drm/gpusvm: Use hmm_range_fault_unlocked_timeout() for range faults

[PATCH] drm/nouveau/gsp: Preserve BAR2 flush mapping on kmap failure
 2026-07-09  6:23 UTC 

[PATCH 00/60] drm/plane: Convert all drivers to atomic_create_state and remove reset
 2026-07-09 11:51 UTC  (2+ messages)
` [PATCH 49/60] drm/nouveau: Convert to atomic_create_state

[PATCH v2 0/7] vga_switcheroo, drm: Push fbcon handling into DRM clients
 2026-07-09  9:16 UTC  (8+ messages)
` [PATCH v2 1/7] drm/edid: Include <linux/fb.h>
` [PATCH v2 2/7] drm/client: Add acquire_outputs callback; implement for fbdev emulation
` [PATCH v2 3/7] vga_switcheroo: Add pre_switch callback to client ops
` [PATCH v2 4/7] vga_switcheroo: Add post_switch "
` [PATCH v2 5/7] drm: Implement struct vga_switcheroo_client_ops.pre_switch
` [PATCH v2 6/7] drm: Implement vga_switcheroo_client_ops.post_switch
` [PATCH v2 7/7] vga-switcheroo: Remove unused interfaces

[PATCH v3 0/3] drm/nouveau/gsp/r570: Fix runtime PM
 2026-07-08 23:30 UTC  (11+ messages)
` [PATCH v3 1/3] Revert "nouveau/gsp: fix suspend/resume regression on r570 firmware"
` [PATCH v3 2/3] drm/nouveau/gsp/r570: Never enter Gcoff state
` [PATCH v3 3/3] drm/nouveau/gsp/r570: Add missing state flags to GSP resume arguments

XDC 2026: CfP deadline extended to July 15. Submit your talk, workshop or demo!
 2026-07-07 14:08 UTC 

[PATCH 00/10] vga_switcheroo, drm: Push fbcon handling into DRM clients
 2026-07-08 21:56 UTC  (12+ messages)
` [PATCH 01/10] drm/edid: Include <linux/fb.h>
` [PATCH 02/10] drm/client: Add acquire_outputs callback; implement for fbdev emulation
` [PATCH 03/10] vga_switcheroo: Add pre_switch callback to client ops
` [PATCH 04/10] vga_switcheroo: Add post_switch "
` [PATCH 05/10] drm/amdgpu: Implement struct vga_switcheroo_client_ops.pre_switch
` [PATCH 06/10] drm/i915: Implement vga_switcheroo_client_ops.pre_switch
` [PATCH 07/10] drm/nouveau: "
` [PATCH 08/10] drm/nouveau: Implement vga_switcheroo_client_ops.post_switch
` [PATCH 09/10] drm/radeon: Implement struct vga_switcheroo_client_ops.pre_switch
` [PATCH 10/10] vga-switcheroo: Remove unused interfaces

[PATCH] drm/nouveau: validate legacy BIT table bounds
 2026-07-06  9:38 UTC 

[PATCH] drm/nouveau: validate MXMS descriptor bounds
 2026-07-06  9:39 UTC 

[PATCH] nouveau/instmem: use iomapping interface for instmem handling (v3)
 2026-07-06  3:05 UTC 

[PATCH] nouveau/instmem: use iomapping interface for instmem handling (v2)
 2026-07-06  2:28 UTC 

[PATCH] drm/nouveau/therm: remove unreachable fan update branch
 2026-07-02 19:45 UTC 

[PATCH v4] drm: uapi: Add macro for chipset specific event ID region
 2026-07-01 18:51 UTC  (2+ messages)

[PATCH] nouveau/instmem: use iomapping interface for instmem handling
 2026-07-01 21:52 UTC  (2+ messages)

[PATCH v2 0/4] drm/nouveau/gsp/r570: Fix runtime PM
 2026-07-01 18:16 UTC  (10+ messages)
` [PATCH v2 1/4] Revert "nouveau/gsp: fix suspend/resume regression on r570 firmware"
` [PATCH v2 2/4] drm/nouveau/gsp/r570: Never enter Gcoff state
` [PATCH v2 3/4] drm/nouveau/gsp/r570: Set oldLevel correctly in GSP resume arguments
` [PATCH v2 4/4] drm/nouveau/gsp/r570: Add missing state flags to "

Reminder: Call for Proposals closing soon for XDC 2026!
 2026-06-30 20:28 UTC 

[PATCH v2] drm/ttm: add generic drvparam[] alias for ttm_place::fpfn/lpfn
 2026-06-30 12:47 UTC  (4+ messages)

[PATCH v5 0/5] nouveau/gsp: Clean up IS_ERR vs IS_ERR_OR_NULL usage
 2026-06-29  8:36 UTC 

[PATCH v2] drm/nouveau: fix GEM refcount leak in validate_init error paths
 2026-06-28 14:28 UTC 

[PATCH] fix: drm/nouveau: nvkm_ucgrp_new: nvkm_cgrp_new failure leaks ucgrp object and engine reference
 2026-06-28  4:03 UTC  (2+ messages)

[PATCH] fix: drm/nouveau: nvkm_chan_new_: multiple error paths return without releasing acquired references
 2026-06-28  3:56 UTC  (2+ messages)

[PATCH] fix: drm/nouveau: validate_init: break paths after drm_gem_object_lookup leak GEM reference
 2026-06-28  3:55 UTC  (2+ messages)

[PATCH 0/2] drm/nouveau: Fix runtime suspend on R570
 2026-06-26 12:32 UTC  (5+ messages)
` [PATCH 1/2] Revert "nouveau/gsp: fix suspend/resume regression on r570 firmware"
` [PATCH 2/2] drm/nouveau/gsp/r570: Never enter Gcoff state

[PATCH v21 0/4] Rust bindings for gem shmem
 2026-06-25 21:24 UTC  (4+ messages)
` [PATCH v21 4/4] rust: drm: gem: Introduce shmem::Object::sg_table()
` (subset) [PATCH v21 0/4] Rust bindings for gem shmem

A Fermi GPU Reclocking Nouveau Tester
 2026-06-25 16:05 UTC 

[PATCH v2] nouveau/firmware: fix memory leak on BL load failure
 2026-06-25 11:13 UTC  (2+ messages)

[PATCH] drm: Use named initializers for arrays of i2c_device_data
 2026-06-22 16:15 UTC  (4+ messages)

[PATCH] drm/nouveau: Simplify nouveau_cli_work
 2026-06-22 18:20 UTC  (9+ messages)
` [PATCH v3] "

Reminder: Call for Proposals open for XDC 2026
 2026-06-22 14:52 UTC 

[PATCH v5 0/5] nouveau/gsp: Clean up IS_ERR vs IS_ERR_OR_NULL usage
 2026-06-22  8:11 UTC  (6+ messages)
` [PATCH v5 1/5] nouveau/gsp/rpc: Document RPC function return value contracts
` [PATCH v5 2/5] nouveau/gsp/rpc: Cleanup incorrect IS_ERR_OR_NULL in rpc.c
` [PATCH v5 3/5] nouveau/gsp/rm/alloc: Cleanup IS_ERR_OR_NULL usage
` [PATCH v5 4/5] nouveau/gsp/rm/bar: "
` [PATCH v5 5/5] nouveau/gsp: Cleanup IS_ERR_OR_NULL in nvkm_gsp_rpc_rd()

[PATCH v4 0/5] nouveau/gsp: Clean up IS_ERR vs IS_ERR_OR_NULL usage
 2026-06-22  3:54 UTC  (3+ messages)
` [PATCH v4 2/5] nouveau/gsp/rpc: Cleanup incorrect IS_ERR_OR_NULL in rpc.c
` [PATCH v4 4/5] nouveau/gsp/rm/bar: Cleanup IS_ERR_OR_NULL usage


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox