Nouveau Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Alexandre Courbot <acourbot-DDmLM1+adcrQT0dZR+AlfA@public.gmane.org>
To: Ben Skeggs <bskeggs-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org>
Cc: nouveau-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW@public.gmane.org
Subject: Re: [PATCH v2 00/14] Secure Boot refactoring
Date: Thu, 27 Oct 2016 17:27:31 +0900	[thread overview]
Message-ID: <bba4722a-9b60-932a-e2ad-a5af203bbf2d@nvidia.com> (raw)
In-Reply-To: <20161027043708.22538-1-acourbot-DDmLM1+adcrQT0dZR+AlfA@public.gmane.org>

On 10/27/2016 01:36 PM, Alexandre Courbot wrote:
> This is a rework of the secure boot code that moves the building of the blob
> into its own set of source files (and own hooks), making the code more flexible
> and (hopefully) easier to understand as well.
> 
> This rework is needed to support more signed firmware for existing and new
> chips. Since the firmwares in question are not available yet I cannot send the
> code to manage then, but hopefully the gain in clarity will be enough to merge
> this series ahead of the rest.
> 
> Of the whole series, patch 8 is the most significant as it reorganizes the code
> into more source files. Chip support is separated from the ACR implementation,
> with ACR being numbered according to the (public) NVIDIA driver version it was
> build aainst. This means one can make any chip work with any ACR version just by
> instanciating the proper ACR and adds a lot of flexibility that will be required
> as more firmwares get released. At the moment, released firmwares cover driver
> versions 352 (for GM20B) and 361 (for GM200, GM204, GM206 and GP100). The r361
> implementation re-uses most of r352, and only implements its own BL descritors
> since the structure changed between the two versions.
> 
> Other patches are a mix of minor optimizations (1, 2, 3, 4, 9, 10, 12, 13),
> small fixes (5, 7, 11), and addition of abstractions to properly support various
> ACR versions (6, 14). Not all the abstractions are used at the moment
> (particularly those of patch 14), but hopefully they will be put to good use
> soon!
> 
> Changes since v1:
> - Use NVIDIA driver versions to differenciate the ACR structures instead of
>   arbitrary numbers
> - Add abstractions to firmware loading functions
> - Optimized set of abstractions
> - Removed some more code

Realized the naming of some structures/functions is rather off.
nvkm_acr_r352* and nvkm_acr_r361* should rather be named acr_r352* and
acr_361* to match the naming habits of Nouveau. I have fixed that in my
tree, waiting for more comments before sending v3...
_______________________________________________
Nouveau mailing list
Nouveau@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/nouveau

      parent reply	other threads:[~2016-10-27  8:27 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-27  4:36 [PATCH v2 00/14] Secure Boot refactoring Alexandre Courbot
     [not found] ` <20161027043708.22538-1-acourbot-DDmLM1+adcrQT0dZR+AlfA@public.gmane.org>
2016-10-27  4:36   ` [PATCH v2 01/14] core: constify nv*_printk macros Alexandre Courbot
2016-10-27  4:36   ` [PATCH v2 02/14] core: add falcon library Alexandre Courbot
2016-10-27  4:36   ` [PATCH v2 03/14] secboot: use falcon library's IMEM/DMEM loading functions Alexandre Courbot
2016-10-27  4:36   ` [PATCH v2 04/14] secboot: rename init() hook to oneinit() Alexandre Courbot
2016-10-27  4:36   ` [PATCH v2 05/14] secboot: remove fixup_hs_desc hook Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 06/14] secboot: add low-secure firmware hooks Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 07/14] secboot: generate HS BL descriptor in hook Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 08/14] secboot: reorganize into more files Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 09/14] secboot: add LS flags to LS func structure Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 10/14] secboot: split reset function Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 11/14] secboot: disable falcon interrupts before running Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 12/14] secboot: remove unneeded ls_ucode_img member Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 13/14] secboot: remove ls_ucode_mgr Alexandre Courbot
2016-10-27  4:37   ` [PATCH v2 14/14] secboot: abstract LS firmware loading functions Alexandre Courbot
2016-10-27  8:27   ` Alexandre Courbot [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=bba4722a-9b60-932a-e2ad-a5af203bbf2d@nvidia.com \
    --to=acourbot-ddmlm1+adcrqt0dzr+alfa@public.gmane.org \
    --cc=bskeggs-H+wXaHxf7aLQT0dZR+AlfA@public.gmane.org \
    --cc=nouveau-PD4FTy7X32lNgt0PjOBp9y5qC8QIuHrW@public.gmane.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox