Openembedded Core Discussions
 help / color / mirror / Atom feed
* [PATCH] kernel.bbclass: change oldnoconfig to olddefconfig
@ 2015-01-09 18:04 Bob Cochran
  2015-01-09 19:08 ` Bruce Ashfield
  0 siblings, 1 reply; 2+ messages in thread
From: Bob Cochran @ 2015-01-09 18:04 UTC (permalink / raw)
  To: openembedded-core

KERNEL_CONFIG_COMMAND is defined as passing oldnoconfig to
oe_runmake_call, but oldnoconfig is both an alias to olddefconfig and a
misleading name.  Therefore, change it to the meaningfully named
option: olddefconfig.

For further background, please see commit fb16d8912db5268f29706010ecafff74b971c58d  in
Linux kernel source tree:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=fb16d8912db5268f29706010ecafff74b971c58d

Signed-off-by: Bob Cochran <openembedded@mindchasers.com>
---
 meta/classes/kernel.bbclass |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/meta/classes/kernel.bbclass b/meta/classes/kernel.bbclass
index 88356b1..aebbc65 100644
--- a/meta/classes/kernel.bbclass
+++ b/meta/classes/kernel.bbclass
@@ -275,7 +275,7 @@ python sysroot_stage_all () {
     oe.path.copyhardlinktree(d.expand("${D}${KERNEL_SRC_PATH}"), d.expand("${SYSROOT_DESTDIR}${KERNEL_SRC_PATH}"))
 }
 
-KERNEL_CONFIG_COMMAND ?= "oe_runmake_call -C ${S} O=${B} oldnoconfig || yes '' | oe_runmake -C ${S} O=${B} oldconfig"
+KERNEL_CONFIG_COMMAND ?= "oe_runmake_call -C ${S} O=${B} olddefconfig || yes '' | oe_runmake -C ${S} O=${B} oldconfig"
 
 kernel_do_configure() {
 	# fixes extra + in /lib/modules/2.6.37+
-- 
1.7.9.5



^ permalink raw reply related	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2015-01-09 19:08 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2015-01-09 18:04 [PATCH] kernel.bbclass: change oldnoconfig to olddefconfig Bob Cochran
2015-01-09 19:08 ` Bruce Ashfield

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox