From: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
To: Khem Raj <raj.khem@gmail.com>,
"Robert P. J. Day" <rpjday@crashcourse.ca>
Cc: OE Core mailing list <openembedded-core@lists.openembedded.org>
Subject: Re: can "IMAGE_INSTALL ?= ..." not be written in a more obvious way?
Date: Tue, 13 Dec 2016 08:52:15 +0000 [thread overview]
Message-ID: <7aafe397c8214239a49d3cf09480d388@XBOX02.axis.com> (raw)
In-Reply-To: <CAMKF1sp_R_qapapbcZ8mu-b1BumWekvKjA-QXUDLOTSWgOoXQA@mail.gmail.com>
> -----Original Message-----
> From: openembedded-core-bounces@lists.openembedded.org
> [mailto:openembedded-core-bounces@lists.openembedded.org] On Behalf Of
> Khem Raj
> Sent: den 10 december 2016 22:16
> To: Robert P. J. Day
> Cc: OE Core mailing list
> Subject: Re: [OE-core] can "IMAGE_INSTALL ?= ..." not be written in a
> more obvious way?
>
> On Sat, Dec 10, 2016 at 3:40 AM, Robert P. J. Day
> <rpjday@crashcourse.ca> wrote:
> >
> > i've nattered about this before but not sure i ever got an answer --
> > here's the last bit of core-image.bbclass:
> >
> > CORE_IMAGE_BASE_INSTALL = '\
> > packagegroup-core-boot \
> > packagegroup-base-extended \
> > \
> > ${CORE_IMAGE_EXTRA_INSTALL} \
> > '
> >
> > CORE_IMAGE_EXTRA_INSTALL ?= ""
> >
> > IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
> >
> > the first time i saw that (long ago), it took me a few looks to figure
> > out what was happening. can this not be written in a more obvious way:
> >
> > CORE_IMAGE_BASE_INSTALL = '\
> > packagegroup-core-boot \
> > packagegroup-base-extended \
> > '
> >
> > CORE_IMAGE_EXTRA_INSTALL ?= ""
> >
> > IMAGE_INSTALL ?= " \
> > ${CORE_IMAGE_BASE_INSTALL} \
> > ${CORE_IMAGE_EXTRA_INSTALL} \
> > "
> >
> > is that not equivalent, or am i missing something? it's certainly
> > clearer as to what's happening if people are perusing the code.
>
> They are same AFAICT, dont feel strongly about readability but feel
> free to send a patch
Careful now. Changing these can affect image recipes outside of OE-core.
If one has an image recipe that inherits core-image and then defines
IMAGE_INSTALL = "${CORE_IMAGE_BASE_INSTALL} my-own-packages ..."
then changing CORE_IMAGE_BASE_INSTALL as per above would suddenly
cause that image to miss including packages that it previously did.
I recommend leaving it as is.
//Peter
next prev parent reply other threads:[~2016-12-13 8:52 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-12-10 11:40 can "IMAGE_INSTALL ?= ..." not be written in a more obvious way? Robert P. J. Day
2016-12-10 21:15 ` Khem Raj
2016-12-13 8:52 ` Peter Kjellerstedt [this message]
2016-12-13 16:29 ` Khem Raj
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7aafe397c8214239a49d3cf09480d388@XBOX02.axis.com \
--to=peter.kjellerstedt@axis.com \
--cc=openembedded-core@lists.openembedded.org \
--cc=raj.khem@gmail.com \
--cc=rpjday@crashcourse.ca \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox