From: Azael Avalos <coproscefalo@gmail.com>
To: Darren Hart <dvhart@infradead.org>,
platform-driver-x86@vger.kernel.org,
linux-kernel@vger.kernel.org
Cc: Azael Avalos <coproscefalo@gmail.com>
Subject: [PATCH 0/4] toshiba_acpi: Return codes cleanup
Date: Tue, 23 Sep 2014 18:24:24 -0600 [thread overview]
Message-ID: <1411518268-2773-1-git-send-email-coproscefalo@gmail.com> (raw)
Up for review.
This series of patches are a cleanup thee Toshiba
configuration interface return codes (unification),
as well as changing the returned type of the HCI/SCI
read/write functions from acpi_status to u32, since
the "status" was never checked on most of the functions.
I would like these to be queued for 3.18 if possible.
Azael Avalos (4):
toshiba_acpi: Rename hci_raw to tci_raw
toshiba_acpi: Unify return codes prefix to from HCI/SCI to TOS
toshiba_acpi: Change HCI/SCI functions return code type
toshiba_acpi: Adapt functions to the changes made to HCI/SCI
drivers/platform/x86/toshiba_acpi.c | 289 ++++++++++++++++++------------------
1 file changed, 142 insertions(+), 147 deletions(-)
--
2.0.0
next reply other threads:[~2014-09-24 0:24 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-09-24 0:24 Azael Avalos [this message]
2014-09-24 0:24 ` [PATCH 1/4] toshiba_acpi: Rename hci_raw to tci_raw Azael Avalos
2014-09-26 3:01 ` Darren Hart
2014-09-26 4:35 ` Azael Avalos
2014-09-29 21:52 ` Darren Hart
2014-09-24 0:24 ` [PATCH 2/4] toshiba_acpi: Unify return codes prefix to from HCI/SCI to TOS Azael Avalos
2014-09-24 0:24 ` [PATCH 3/4] toshiba_acpi: Change HCI/SCI functions return code type Azael Avalos
2014-09-26 3:11 ` Darren Hart
2014-09-26 4:52 ` Azael Avalos
2014-09-24 0:24 ` [PATCH 4/4] toshiba_acpi: Adapt functions to the changes made to HCI/SCI Azael Avalos
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1411518268-2773-1-git-send-email-coproscefalo@gmail.com \
--to=coproscefalo@gmail.com \
--cc=dvhart@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox