From: Darren Hart <dvhart@infradead.org>
To: Azael Avalos <coproscefalo@gmail.com>
Cc: platform-driver-x86@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/4] toshiba_acpi: Change HCI/SCI functions return code type
Date: Thu, 25 Sep 2014 20:11:51 -0700 [thread overview]
Message-ID: <20140926031151.GB40523@vmdeb7> (raw)
In-Reply-To: <1411518268-2773-4-git-send-email-coproscefalo@gmail.com>
On Tue, Sep 23, 2014 at 06:24:27PM -0600, Azael Avalos wrote:
> Currently the HCI/SCI read/write functions are returning
> the status of the ACPI call and also assigning the
> returned value of the HCI/SCI function.
>
> This patch changes such functions, returning the value
> of the HCI/SCI function instead of the ACPI call status.
>
> The next patch will change all the HCI/SCI functions
> to reflect the change made in this patch.
If you are changing what the functions return in this patch, you also need to
update the call sites at the same time (same patch).
>
> Signed-off-by: Azael Avalos <coproscefalo@gmail.com>
> ---
> drivers/platform/x86/toshiba_acpi.c | 51 ++++++++++++++++++++-----------------
> 1 file changed, 27 insertions(+), 24 deletions(-)
>
> diff --git a/drivers/platform/x86/toshiba_acpi.c b/drivers/platform/x86/toshiba_acpi.c
> index 5b16d11..43385f7 100644
> --- a/drivers/platform/x86/toshiba_acpi.c
> +++ b/drivers/platform/x86/toshiba_acpi.c
> @@ -316,47 +316,49 @@ static acpi_status tci_raw(struct toshiba_acpi_dev *dev,
> * may be useful (such as "not supported").
> */
The full text of the comment above is:
/* common hci tasks (get or set one or two value)
*
* In addition to the ACPI status, the HCI system returns a result which
* may be useful (such as "not supported").
*/
Is this no longer relevant?
I agree that the return and status approach seems suboptimal, but I'm not clear on the motivation for the change. Is there something besides cleanup you're attempting to work toward with this series?
--
Darren Hart
Intel Open Source Technology Center
next prev parent reply other threads:[~2014-09-26 3:11 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-09-24 0:24 [PATCH 0/4] toshiba_acpi: Return codes cleanup Azael Avalos
2014-09-24 0:24 ` [PATCH 1/4] toshiba_acpi: Rename hci_raw to tci_raw Azael Avalos
2014-09-26 3:01 ` Darren Hart
2014-09-26 4:35 ` Azael Avalos
2014-09-29 21:52 ` Darren Hart
2014-09-24 0:24 ` [PATCH 2/4] toshiba_acpi: Unify return codes prefix to from HCI/SCI to TOS Azael Avalos
2014-09-24 0:24 ` [PATCH 3/4] toshiba_acpi: Change HCI/SCI functions return code type Azael Avalos
2014-09-26 3:11 ` Darren Hart [this message]
2014-09-26 4:52 ` Azael Avalos
2014-09-24 0:24 ` [PATCH 4/4] toshiba_acpi: Adapt functions to the changes made to HCI/SCI Azael Avalos
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140926031151.GB40523@vmdeb7 \
--to=dvhart@infradead.org \
--cc=coproscefalo@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox