From: Vadim Pasternak <vadimp@nvidia.com>
To: <ilpo.jarvinen@linux.intel.com>, <hdegoede@redhat.com>
Cc: <michaelsh@nvidia.com>, <crajank@nvidia.com>,
<fradensky@nvidia.com>, <oleksandrs@nvidia.com>,
<platform-driver-x86@vger.kernel.org>,
"Vadim Pasternak" <vadimp@nvidia.com>
Subject: [PATCH v4 00/12] platform/mellanox: Add support for new systems, amendments, relocate mlx-platform module
Date: Thu, 23 Jan 2025 21:08:04 +0200 [thread overview]
Message-ID: <20250123190818.3834-1-vadimp@nvidia.com> (raw)
The patchset contains:
Patch #1: Relocation mlx-platform driver.
Change of MAINTANERS list after relocation of mlx-platform.
Patches #2; #6; #9: Add cosmetic changes - removing spaces, style.
Patch #3: Repurposing of one register.
Patches #4 - #5: Add new field.
Patches #6; #7; #9; #10 : Introduce systems: new SN428 smart switch
equipped with DPU for offloading, new 2U systems SN5610 and SN5640,
new compact system SN2200 OCP rack complained.
Patch #12 - Add documentation.
v3->v4:
Comments pointed out by Ilpo:
- Added inside pacthes.
v2->v3:
Comments pointed out by Ilpo:
- Added inside pacthes.
v0->v2:
Comments pointed out by Krzysztof:
- Merge changes of MAINTANERS to the 1-st patch.
- Change order between SoB and RB.
Vadim Pasternak (12):
mellanox: Relocate mlx-platform driver
platform: mellanox: mlx-platform: Cosmetic changes
platform: mellanox: mlx-platform: Change register name
platform_data/mlxreg: Add capability bit and mask fields
platform/mellanox: mlxreg-hotplug: Add support for new flavor of
capability registers
platform/mellanox: Rename field to improve code readability
platform/mellanox: mlxreg-dpu: Add initial support for Nvidia DPU
platform: mellanox: Introduce support of Nvidia smart switch
platform: mellanox: Cosmetic changes to improve code style
platform: mellanox: mlx-platform: Add support for new Nvidia system
platform: mellanox: nvsw-sn2200: Add support for new system flavour
Documentation/ABI: Add new attribute for mlxreg-io sysfs interfaces
.../ABI/stable/sysfs-driver-mlxreg-io | 96 +
MAINTAINERS | 7 +-
drivers/platform/mellanox/Kconfig | 25 +
drivers/platform/mellanox/Makefile | 2 +
.../platform/{x86 => mellanox}/mlx-platform.c | 3769 ++++++++++++-----
drivers/platform/mellanox/mlxreg-dpu.c | 619 +++
drivers/platform/mellanox/mlxreg-hotplug.c | 30 +-
drivers/platform/mellanox/nvsw-sn2201.c | 118 +-
drivers/platform/x86/Kconfig | 13 -
drivers/platform/x86/Makefile | 1 -
include/linux/platform_data/mlxreg.h | 12 +-
11 files changed, 3550 insertions(+), 1142 deletions(-)
rename drivers/platform/{x86 => mellanox}/mlx-platform.c (80%)
create mode 100644 drivers/platform/mellanox/mlxreg-dpu.c
--
2.44.0
next reply other threads:[~2025-01-23 19:09 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-23 19:08 Vadim Pasternak [this message]
2025-01-23 19:08 ` [PATCH v4 01/12] mellanox: Relocate mlx-platform driver Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 02/12] platform: mellanox: mlx-platform: Cosmetic changes Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 03/12] platform: mellanox: mlx-platform: Change register name Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 04/12] platform_data/mlxreg: Add capability bit and mask fields Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 05/12] platform/mellanox: mlxreg-hotplug: Add support for new flavor of capability registers Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 06/12] platform/mellanox: Rename field to improve code readability Vadim Pasternak
2025-01-24 8:13 ` Ilpo Järvinen
2025-01-24 12:52 ` Vadim Pasternak
2025-01-24 12:56 ` Ilpo Järvinen
2025-01-24 15:48 ` Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 07/12] platform/mellanox: mlxreg-dpu: Add initial support for Nvidia DPU Vadim Pasternak
2025-01-24 8:41 ` Ilpo Järvinen
2025-01-23 19:08 ` [PATCH v4 08/12] platform: mellanox: Introduce support of Nvidia smart switch Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 09/12] platform: mellanox: Cosmetic changes to improve code style Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 10/12] platform: mellanox: mlx-platform: Add support for new Nvidia system Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 11/12] platform: mellanox: nvsw-sn2200: Add support for new system flavour Vadim Pasternak
2025-01-23 19:08 ` [PATCH v4 12/12] Documentation/ABI: Add new attribute for mlxreg-io sysfs interfaces Vadim Pasternak
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250123190818.3834-1-vadimp@nvidia.com \
--to=vadimp@nvidia.com \
--cc=crajank@nvidia.com \
--cc=fradensky@nvidia.com \
--cc=hdegoede@redhat.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=michaelsh@nvidia.com \
--cc=oleksandrs@nvidia.com \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox