From: Shyam Sundar S K <Shyam-sundar.S-k@amd.com>
To: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: Hans de Goede <hdegoede@redhat.com>,
markgross@kernel.org, Sanket.Goswami@amd.com,
mario.limonciello@amd.com, platform-driver-x86@vger.kernel.org
Subject: Re: [PATCH 2/2] platform/x86/amd/pmc: Move structures to pmc header
Date: Mon, 9 Oct 2023 21:17:02 +0530 [thread overview]
Message-ID: <d958b8e8-0a09-4449-ab6e-7eaf2d34ecd3@amd.com> (raw)
In-Reply-To: <95a0ef77-ea2-a698-9ba7-3049195c7481@linux.intel.com>
On 10/9/2023 9:09 PM, Ilpo Järvinen wrote:
> On Mon, 9 Oct 2023, Shyam Sundar S K wrote:
>
>> As we have a separate header for amd_pmc driver, move the common strutures,
>> enums, and macros to the header file.
>>
>> Suggested-by: Sanket Goswami <Sanket.Goswami@amd.com>
>> Signed-off-by: Shyam Sundar S K <Shyam-sundar.S-k@amd.com>
>> ---
>
>> +#define RESPONSE_REGISTER_LOOP_MAX 20000
>
> This is borderline, I'd add prefix for this.
>
>> +#define DELAY_MIN_US 2000
>> +#define DELAY_MAX_US 3000
>> +#define FIFO_SIZE 4096
>
> These look way too generic names when they are now disconnected from the
> code using them, not that DELAY_* ever was a good name for anything :-).
>
>> +enum amd_pmc_def {
>> + MSG_TEST = 0x01,
>> + MSG_OS_HINT_PCO,
>> + MSG_OS_HINT_RN,
>> +};
>
> I suggest you consider adding a prefix for these too.
But these are there from long time, probably from the inception of
this driver :-)
This patch is just cleaning up of the code and move to header for
readability purpose.
You mean to say, make the prefix change while I move the macros to header?
Thanks,
Shyam
>
>
next prev parent reply other threads:[~2023-10-09 15:47 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-10-09 14:47 [PATCH 1/2] platform/x86/amd/pmc: Fix fetching DRAM size mechanism Shyam Sundar S K
2023-10-09 14:47 ` [PATCH 2/2] platform/x86/amd/pmc: Move structures to pmc header Shyam Sundar S K
2023-10-09 14:56 ` Mario Limonciello
2023-10-09 15:39 ` Ilpo Järvinen
2023-10-09 15:47 ` Shyam Sundar S K [this message]
2023-10-09 15:49 ` Ilpo Järvinen
2023-10-09 14:55 ` [PATCH 1/2] platform/x86/amd/pmc: Fix fetching DRAM size mechanism Mario Limonciello
2023-10-09 15:39 ` Shyam Sundar S K
2023-10-09 15:42 ` Mario Limonciello
2023-10-09 14:59 ` Ilpo Järvinen
2023-10-09 15:42 ` Shyam Sundar S K
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d958b8e8-0a09-4449-ab6e-7eaf2d34ecd3@amd.com \
--to=shyam-sundar.s-k@amd.com \
--cc=Sanket.Goswami@amd.com \
--cc=hdegoede@redhat.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=mario.limonciello@amd.com \
--cc=markgross@kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox