Storage Performance Development Kit (SPDK)
 help / color / mirror / Atom feed
From: Harris, James R <james.r.harris at intel.com>
To: spdk@lists.01.org
Subject: [SPDK] RPC Naming
Date: Tue, 07 May 2019 23:09:31 +0000	[thread overview]
Message-ID: <76F2E352-3DBA-4EB3-8E8D-DA326D781959@intel.com> (raw)

[-- Attachment #1: Type: text/plain, Size: 1490 bytes --]

There has been quite a bit of chatter recently about the SPDK RPCs – lack of meaningful error codes in a lot of the RPCs, and at least one RPC returning data in an array with different “types”.  Another sore point is the naming of the RPCs themselves.


  1.  construct v. create (the vast majority use “construct”)
  2.  destruct v. delete v. destroy (the vast majority use “delete”)
  3.  most contain their associated component name in the RPC names, but some of the oldest ones from iscsi do not
  4.  most do not follow a noun_verb(_object) naming convention
  5.  minor nits like “construct_nvme_bdev” – this really attaches an nvme controller, which then creates bdevs for each namespace (there could be many)

I’ve put out a patch series (https://review.gerrithub.io/c/spdk/spdk/+/453036) with suggested names for all of our existing RPCs – there are almost 150 of them now.  All of the old names would still be valid, but deprecated.  We could keep the old names around as aliases for as long as needed.

The patch series has an example of how the get_rpc_methods RPC would be converted to rpc_get_methods, and converts the previously deprecated get/set/clear_trace_flag RPCs to use this new framework.  Thanks to Ben Walker for his help on making some of the Python infrastructure for this simpler than I originally coded it.

If you have an interest in the SPDK RPC API, please take some time and review this patch set.

Thanks,

-Jim


             reply	other threads:[~2019-05-07 23:09 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-05-07 23:09 Harris, James R [this message]
  -- strict thread matches above, loose matches on Subject: below --
2019-05-09 14:03 [SPDK] RPC Naming Szwed, Maciej
2019-05-09 15:47 Harris, James R

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=76F2E352-3DBA-4EB3-8E8D-DA326D781959@intel.com \
    --to=spdk@lists.01.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox