U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [U-Boot] [PATCH 1/1] usb: rename board_usb_init_type to usb_init_type
@ 2013-10-22 21:39 Troy Kisky
  2013-10-24  1:21 ` Tom Rini
  0 siblings, 1 reply; 2+ messages in thread
From: Troy Kisky @ 2013-10-22 21:39 UTC (permalink / raw)
  To: u-boot

commit bba679144d25b91bcd7befff5a96728a30875f54
"usb: rename board_usb_init_type to usb_init_type" missed xhci-omap.c
So, fix that patch here, and fix a checkpatch warning.
WARNING: Avoid unnecessary line continuations

Signed-off-by: Troy Kisky <troy.kisky@boundarydevices.com>
---
 board/ti/omap5_uevm/evm.c    | 2 +-
 drivers/usb/host/xhci-omap.c | 4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/board/ti/omap5_uevm/evm.c b/board/ti/omap5_uevm/evm.c
index 9458104..bb3a699 100644
--- a/board/ti/omap5_uevm/evm.c
+++ b/board/ti/omap5_uevm/evm.c
@@ -221,7 +221,7 @@ void usb_hub_reset_devices(int port)
  *
  * @return 0
  */
-int board_usb_init(int index, enum board_usb_init_type init)
+int board_usb_init(int index, enum usb_init_type init)
 {
 	int ret;
 #ifdef CONFIG_PALMAS_USB_SS_PWR
diff --git a/drivers/usb/host/xhci-omap.c b/drivers/usb/host/xhci-omap.c
index f6099ac..e667810 100644
--- a/drivers/usb/host/xhci-omap.c
+++ b/drivers/usb/host/xhci-omap.c
@@ -27,11 +27,11 @@ DECLARE_GLOBAL_DATA_PTR;
 
 static struct omap_xhci omap;
 
-inline int __board_usb_init(int index, enum board_usb_init_type init)
+inline int __board_usb_init(int index, enum usb_init_type init)
 {
 	return 0;
 }
-int board_usb_init(int index, enum board_usb_init_type init) \
+int board_usb_init(int index, enum usb_init_type init)
 	__attribute__((weak, alias("__board_usb_init")));
 
 static void dwc3_set_mode(struct dwc3 *dwc3_reg, u32 mode)
-- 
1.8.1.2

^ permalink raw reply related	[flat|nested] 2+ messages in thread

* [U-Boot] [PATCH 1/1] usb: rename board_usb_init_type to usb_init_type
  2013-10-22 21:39 [U-Boot] [PATCH 1/1] usb: rename board_usb_init_type to usb_init_type Troy Kisky
@ 2013-10-24  1:21 ` Tom Rini
  0 siblings, 0 replies; 2+ messages in thread
From: Tom Rini @ 2013-10-24  1:21 UTC (permalink / raw)
  To: u-boot

On Tue, Oct 22, 2013 at 02:39:25PM -0700, Troy Kisky wrote:

> commit bba679144d25b91bcd7befff5a96728a30875f54
> "usb: rename board_usb_init_type to usb_init_type" missed xhci-omap.c
> So, fix that patch here, and fix a checkpatch warning.
> WARNING: Avoid unnecessary line continuations
> 
> Signed-off-by: Troy Kisky <troy.kisky@boundarydevices.com>

Applied to u-boot/master, thanks!

-- 
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.denx.de/pipermail/u-boot/attachments/20131023/deb05397/attachment.pgp>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2013-10-24  1:21 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2013-10-22 21:39 [U-Boot] [PATCH 1/1] usb: rename board_usb_init_type to usb_init_type Troy Kisky
2013-10-24  1:21 ` Tom Rini

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox