From: Tom Rini <trini@konsulko.com>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH 4/6] mmc: move CONFIG_SDHCI to Kconfig, renaming to CONFIG_MMC_SDHCI
Date: Mon, 5 Dec 2016 11:04:09 -0500 [thread overview]
Message-ID: <20161205160409.GN4248@bill-the-cat> (raw)
In-Reply-To: <1480857794-27145-5-git-send-email-yamada.masahiro@socionext.com>
On Sun, Dec 04, 2016 at 10:23:12PM +0900, Masahiro Yamada wrote:
> Move CONFIG_SDHCI to Kconfig and rename it to CONFIG_MMC_SDHCI.
> My motivation for the rename is, ultimately, to make all the MMC
> options prefixed with MMC_ and SDHCI options with MMC_SDHCI_,
> like Linux.
>
> This commit was created as follows:
>
> [1] Rename the config option with the following command:
> find . -name .git -prune -o ! -path ./scripts/config_whitelist.txt \
> -type f -print | xargs sed -i -e 's/CONFIG_SDHCI/CONFIG_MMC_SDHCI/g'
>
> [2] create the entry for MMC_SDHCI in drivers/mmc/Kconfig
>
> [3] run "tools/moveconfig MMC_SDHCI"
>
> [4] add "depends on MMC_SDHCI" to existing SDHCI driver entries
>
> Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
Reviewed-by: Tom Rini <trini@konsulko.com>
--
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.denx.de/pipermail/u-boot/attachments/20161205/30e01626/attachment.sig>
next prev parent reply other threads:[~2016-12-05 16:04 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-12-04 13:23 [U-Boot] [PATCH 0/6] mmc: move some config options to Kconfig Masahiro Yamada
2016-12-04 13:23 ` [U-Boot] [PATCH 1/6] Sync defconfig files by savedefconfig Masahiro Yamada
2016-12-04 13:23 ` [U-Boot] [PATCH 2/6] mmc: complete the unfinished move of CONFIG_MMC Masahiro Yamada
2016-12-05 16:02 ` Tom Rini
2016-12-06 6:25 ` Masahiro Yamada
2016-12-06 13:03 ` Tom Rini
2016-12-07 1:45 ` Masahiro Yamada
2016-12-04 13:23 ` [U-Boot] [PATCH 3/6] mmc: make MMC driver entries dependent on MMC Masahiro Yamada
2016-12-05 19:11 ` Tom Rini
2016-12-04 13:23 ` [U-Boot] [PATCH 4/6] mmc: move CONFIG_SDHCI to Kconfig, renaming to CONFIG_MMC_SDHCI Masahiro Yamada
2016-12-05 16:04 ` Tom Rini [this message]
2016-12-04 13:23 ` [U-Boot] [PATCH 5/6] mmc: move some SDHCI related options to Kconfig Masahiro Yamada
2016-12-05 19:10 ` Tom Rini
2016-12-07 9:04 ` Masahiro Yamada
2016-12-07 9:22 ` Jaehoon Chung
2016-12-07 12:52 ` Tom Rini
2016-12-04 13:23 ` [U-Boot] [PATCH 6/6] mmc: move MMC_SDHCI_IO_ACCESSORS " Masahiro Yamada
2016-12-05 19:11 ` Tom Rini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20161205160409.GN4248@bill-the-cat \
--to=trini@konsulko.com \
--cc=u-boot@lists.denx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox