U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [U-Boot] [PATCH v2 1/8] spl: Use a single underscore in the SPL_LOAD_IMAGE_METHOD() macro
@ 2016-11-30 22:30 Simon Glass
  2016-11-30 22:30 ` [U-Boot] [PATCH v2 2/8] spl: Add a name to the SPL load-image methods Simon Glass
                   ` (7 more replies)
  0 siblings, 8 replies; 16+ messages in thread
From: Simon Glass @ 2016-11-30 22:30 UTC (permalink / raw)
  To: u-boot

A double underscore is normally reserved for compiler predefines. Use a
single underscore instead.

Signed-off-by: Simon Glass <sjg@chromium.org>
---

Changes in v2: None

 include/spl.h | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/include/spl.h b/include/spl.h
index e080a82..11bdc2d 100644
--- a/include/spl.h
+++ b/include/spl.h
@@ -172,15 +172,15 @@ struct spl_image_loader {
 	ll_entry_declare(struct spl_image_loader, __name, spl_image_loader)
 
 /*
- * __priority is the priority of this method, 0 meaning it will be the top
+ * _priority is the priority of this method, 0 meaning it will be the top
  * choice for this device, 9 meaning it is the bottom choice.
- * __boot_device is the BOOT_DEVICE_... value
- * __method is the load_image function to call
+ * _boot_device is the BOOT_DEVICE_... value
+ * _method is the load_image function to call
  */
-#define SPL_LOAD_IMAGE_METHOD(__priority, __boot_device, __method) \
-	SPL_LOAD_IMAGE(__method ## __priority ## __boot_device) = { \
-		.boot_device = __boot_device, \
-		.load_image = __method, \
+#define SPL_LOAD_IMAGE_METHOD(_priority, _boot_device, _method) \
+	SPL_LOAD_IMAGE(_method ## _priority ## _boot_device) = { \
+		.boot_device = _boot_device, \
+		.load_image = _method, \
 	}
 
 /* SPL FAT image functions */
-- 
2.8.0.rc3.226.g39d4020

^ permalink raw reply related	[flat|nested] 16+ messages in thread

end of thread, other threads:[~2016-12-12 13:41 UTC | newest]

Thread overview: 16+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2016-11-30 22:30 [U-Boot] [PATCH v2 1/8] spl: Use a single underscore in the SPL_LOAD_IMAGE_METHOD() macro Simon Glass
2016-11-30 22:30 ` [U-Boot] [PATCH v2 2/8] spl: Add a name to the SPL load-image methods Simon Glass
2016-12-12 13:36   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 3/8] spl: Move the loading code into its own function Simon Glass
2016-12-12 13:37   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 4/8] spl: Pass the loader into spl_load_image() Simon Glass
2016-12-12 13:39   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 5/8] spl: Drop announce_boot_device() Simon Glass
2016-12-12 13:40   ` [U-Boot] [U-Boot,v2,5/8] " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 6/8] spl: sunxi: Drop spl_board_announce_boot_device() Simon Glass
2016-12-12 13:40   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 7/8] spl: uniphier: " Simon Glass
2016-12-12 13:41   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-11-30 22:30 ` [U-Boot] [PATCH v2 8/8] spl: sandbox: " Simon Glass
2016-12-12 13:41   ` [U-Boot] [U-Boot, v2, " Tom Rini
2016-12-12 13:36 ` [U-Boot] [U-Boot, v2, 1/8] spl: Use a single underscore in the SPL_LOAD_IMAGE_METHOD() macro Tom Rini

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox