U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Tom Rini <trini@konsulko.com>
To: u-boot@lists.denx.de
Subject: [PATCH 2/2] test: fix naming of test functions in the log test suite
Date: Fri, 8 May 2020 18:59:47 -0400	[thread overview]
Message-ID: <20200508225947.GA12564@bill-the-cat> (raw)
In-Reply-To: <20200506162608.96975-3-xypron.glpk@gmx.de>

On Wed, May 06, 2020 at 06:26:08PM +0200, Heinrich Schuchardt wrote:

> Both the nolog as well as the syslog tests were not found by Python
> function generate_ut_subtest() due to not following the nameing
> requirements imposed by the regular expression used to find linker
> generated list entries in file u-boot.sym.
> 
> Adjust the naming of test functions.
> 
> With the patch the following tests are executed successfully for
> sandbox_defconfig:
> 
> test/py/tests/test_ut.py::test_ut[ut_log_syslog_debug] PASSED
> test/py/tests/test_ut.py::test_ut[ut_log_syslog_err] PASSED
> test/py/tests/test_ut.py::test_ut[ut_log_syslog_info] PASSED
> test/py/tests/test_ut.py::test_ut[ut_log_syslog_nodebug] PASSED
> test/py/tests/test_ut.py::test_ut[ut_log_syslog_notice] PASSED
> test/py/tests/test_ut.py::test_ut[ut_log_syslog_warning] PASSED
> 
> The nolog tests are only executed if CONFIG_LOG=n and
> CONFIG_CONSOLE_RECORD=y.
> 
> Reported-by: Simon Glass <sjg@chromium.org>
> Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>

Applied to u-boot/master, thanks!

-- 
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 659 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20200508/b8a14b92/attachment.sig>

      reply	other threads:[~2020-05-08 22:59 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-06 16:26 [PATCH 0/2] test: fix naming of test functions in the log test suite Heinrich Schuchardt
2020-05-06 16:26 ` [PATCH 1/2] test: describe naming conventions for macro UNIT_TEST Heinrich Schuchardt
2020-05-06 23:28   ` Stephen Warren
2020-05-08  1:36     ` Simon Glass
2020-05-08 22:59   ` Tom Rini
2020-05-06 16:26 ` [PATCH 2/2] test: fix naming of test functions in the log test suite Heinrich Schuchardt
2020-05-08 22:59   ` Tom Rini [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200508225947.GA12564@bill-the-cat \
    --to=trini@konsulko.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox