U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/2] test: fix naming of test functions in the log test suite
@ 2020-05-06 16:26 Heinrich Schuchardt
  2020-05-06 16:26 ` [PATCH 1/2] test: describe naming conventions for macro UNIT_TEST Heinrich Schuchardt
  2020-05-06 16:26 ` [PATCH 2/2] test: fix naming of test functions in the log test suite Heinrich Schuchardt
  0 siblings, 2 replies; 7+ messages in thread
From: Heinrich Schuchardt @ 2020-05-06 16:26 UTC (permalink / raw)
  To: u-boot

Some Python subtests executed via the 'ut' console command were not
executed due to not following a required naming convention.

Add a description of the naming convention.
Fix the tests.

Heinrich Schuchardt (2):
  test: describe naming conventions for macro UNIT_TEST
  test: fix naming of test functions in the log test suite

 include/test/test.h      | 24 +++++++++++++++++++-
 test/log/nolog_test.c    | 24 ++++++++++----------
 test/log/syslog_test.c   | 48 ++++++++++++++++++++--------------------
 test/py/tests/test_ut.py | 17 +++++++++++++-
 4 files changed, 75 insertions(+), 38 deletions(-)

--
2.26.2

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2020-05-08 22:59 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2020-05-06 16:26 [PATCH 0/2] test: fix naming of test functions in the log test suite Heinrich Schuchardt
2020-05-06 16:26 ` [PATCH 1/2] test: describe naming conventions for macro UNIT_TEST Heinrich Schuchardt
2020-05-06 23:28   ` Stephen Warren
2020-05-08  1:36     ` Simon Glass
2020-05-08 22:59   ` Tom Rini
2020-05-06 16:26 ` [PATCH 2/2] test: fix naming of test functions in the log test suite Heinrich Schuchardt
2020-05-08 22:59   ` Tom Rini

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox