U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
* u-boot and mtdparts
@ 2021-07-15 18:13 Marek Behún
  2021-07-15 18:26 ` Simon Glass
  2021-07-15 20:50 ` Tom Rini
  0 siblings, 2 replies; 3+ messages in thread
From: Marek Behún @ 2021-07-15 18:13 UTC (permalink / raw)
  To: Tom Rini
  Cc: u-boot, Masami Hiramatsu, Jagan Teki, Patrice CHOTARD,
	Miquel Raynal, Pali Rohár, Simon Glass

Hello Tom and others,

many boards still use the obsolete mtdparts command.
What is the plan with this command? Do we still want to support it?

Recently as discovered by Masami, my patch
  mtd: spi-nor: allow  registering multiple MTDs when DM is enabled
caused that mtds may have different name than that defined in
CONFIG_MTDPARTS_DEFAULT.
Masami fixed his board by putting the partition definitions into
devicetree, but there are still many boards that may be broken.

The easy fix here is to make mtd_device_matches_name() in
drivers/mtd/mtdcore.c to support the old names. Most of them are in
format "type.id", for example "nor.1", "nand.1", but some are different.

The problem is that I do not know how exactly to match these names with
the devices. Does the number represent the bus, or chip select or
something else?

There are also multiple parsers of the mtdparts string (at least two,
one in cmd/mtdparts.c and the other in drivers/mtd/mtd_uboot.c).

IMO the proper solution would be to get rid of the mtdparts entirely,
move it to devicetree, and add code that generates the mtdparts string
for Linux' command line from devicetree.

What do you think?

Marek

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-07-15 20:50 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2021-07-15 18:13 u-boot and mtdparts Marek Behún
2021-07-15 18:26 ` Simon Glass
2021-07-15 20:50 ` Tom Rini

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox