From: Philip Oberfichtner <pro@denx.de>
To: u-boot@lists.denx.de
Cc: Philip Oberfichtner <pro@denx.de>,
Andre Przywara <andre.przywara@arm.com>,
Anshul Dalal <anshuld@ti.com>,
Dario Binacchi <dario.binacchi@amarulasolutions.com>,
Gary Bisson <bisson.gary@gmail.com>,
Greg Malysa <malysagreg@gmail.com>,
Heinrich Schuchardt <heinrich.schuchardt@canonical.com>,
Ilias Apalodimas <ilias.apalodimas@linaro.org>,
Jerome Forissier <jerome.forissier@linaro.org>,
Marek Vasut <marex@denx.de>,
Nathan Barrett-Morrison <nathan.morrison@timesys.com>,
Oliver Gaskell <Oliver.Gaskell@analog.com>,
Paul Barker <paul.barker.ct@bp.renesas.com>,
Paul Kocialkowski <contact@paulk.fr>, Peng Fan <peng.fan@nxp.com>,
Quentin Schulz <quentin.schulz@cherry.de>,
Simon Glass <sjg@chromium.org>, Tom Rini <trini@konsulko.com>,
Trevor Woerner <twoerner@gmail.com>, Ye Li <ye.li@nxp.com>
Subject: [RFC PATCH v1 0/3] Simplify image size checks
Date: Thu, 31 Jul 2025 13:40:41 +0200 [thread overview]
Message-ID: <20250731114044.264745-1-pro@denx.de> (raw)
This patch series intends to simplify the image size checks, which currently
exists in multiple flavours:
CONFIG_HAS_BOARD_SIZE_LIMIT
CONFIG_BOARD_SIZE_LIMIT
CONFIG_SPL_SIZE_LIMIT
CONFIG_SPL_SIZE_LIMIT_SUBTRACT_GD
CONFIG_SPL_SIZE_LIMIT_SUBTRACT_MALLOC
CONFIG_SPL_SIZE_LIMIT_PROVIDE_STACK
CONFIG_TPL_SIZE_LIMIT
CONFIG_VPL_SIZE_LIMIT
After this series, we would have
- Less code duplication in the toplevel Makefile (commit 1)
- Consistent logic for all the different CONFIGS (commit 2)
- All related options in one place (commit 3)
Please note that I have also posted commit 1 as part of the onion board support
series:
https://patchwork.ozlabs.org/project/uboot/patch/20250730123833.249923-2-pro@denx.de/
If this proposal finds some consent in the community, I think we might still
want to improve the Kconfig help texts. Also in commit 2 I just dropped the
"depends on !COMPILE_TEST" statement. Not sure how to translate that into the
new logic.
Philip Oberfichtner (3):
Image size checks: Simplify Makefile rules
Image size checks: Remove HAS_BOARD_SIZE_LIMIT
Image size checks: Move all configs in one place
Kconfig | 67 ++++++++++++++++---
Makefile | 44 +++---------
cmd/Kconfig | 2 +-
common/spl/Kconfig | 38 -----------
common/spl/Kconfig.tpl | 7 --
common/spl/Kconfig.vpl | 7 --
configs/bk4r1_defconfig | 1 -
configs/chromebook_link_defconfig | 1 -
configs/colibri_vf_defconfig | 1 -
configs/ea-lpc3250devkitv2_defconfig | 1 -
.../gardena-smart-gateway-mt7688_defconfig | 1 -
configs/guruplug_defconfig | 1 -
configs/imx28_btt3_defconfig | 1 -
configs/imx28_xea_defconfig | 1 -
configs/legoev3_defconfig | 1 -
configs/linkit-smart-7688_defconfig | 1 -
configs/lschlv2_defconfig | 1 -
configs/lsxhl_defconfig | 1 -
configs/lxr2_defconfig | 1 -
configs/mx51evk_defconfig | 1 -
configs/mx53loco_defconfig | 1 -
configs/mx6sabresd_defconfig | 1 -
configs/mx7ulp_com_defconfig | 1 -
configs/openrd_base_defconfig | 1 -
configs/openrd_client_defconfig | 1 -
configs/openrd_ultimate_defconfig | 1 -
configs/pcm052_defconfig | 1 -
configs/pico-dwarf-imx6ul_defconfig | 1 -
configs/pico-dwarf-imx7d_defconfig | 1 -
configs/pico-hobbit-imx6ul_defconfig | 1 -
configs/pico-hobbit-imx7d_defconfig | 1 -
configs/pico-imx6_defconfig | 1 -
configs/pico-imx6ul_defconfig | 1 -
configs/pico-imx7d_bl33_defconfig | 1 -
configs/pico-imx7d_defconfig | 1 -
configs/pico-nymph-imx7d_defconfig | 1 -
configs/pico-pi-imx6ul_defconfig | 1 -
configs/pico-pi-imx7d_defconfig | 1 -
configs/sheevaplug_defconfig | 1 -
configs/stm32mp15_dhsom.config | 1 -
configs/tbs2910_defconfig | 1 -
configs/turris_1x_nor_defconfig | 1 -
configs/turris_1x_sdcard_defconfig | 1 -
configs/turris_omnia_defconfig | 1 -
configs/udoo_neo_defconfig | 1 -
configs/vf610twr_defconfig | 1 -
configs/vf610twr_nand_defconfig | 1 -
configs/warp7_bl33_defconfig | 1 -
configs/warp7_defconfig | 1 -
lib/efi_loader/Kconfig | 6 +-
tools/spl_size_limit.c | 2 +-
51 files changed, 74 insertions(+), 142 deletions(-)
--
2.39.5
next reply other threads:[~2025-07-31 11:41 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-31 11:40 Philip Oberfichtner [this message]
2025-07-31 11:40 ` [RFC PATCH v1 1/3] Image size checks: Simplify Makefile rules Philip Oberfichtner
2025-07-31 11:40 ` [RFC PATCH v1 2/3] Image size checks: Remove HAS_BOARD_SIZE_LIMIT Philip Oberfichtner
2025-07-31 12:09 ` Heinrich Schuchardt
2025-07-31 11:40 ` [RFC PATCH v1 3/3] Image size checks: Move all configs in one place Philip Oberfichtner
2025-07-31 12:14 ` Heinrich Schuchardt
2025-08-07 10:28 ` Philip Oberfichtner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250731114044.264745-1-pro@denx.de \
--to=pro@denx.de \
--cc=Oliver.Gaskell@analog.com \
--cc=andre.przywara@arm.com \
--cc=anshuld@ti.com \
--cc=bisson.gary@gmail.com \
--cc=contact@paulk.fr \
--cc=dario.binacchi@amarulasolutions.com \
--cc=heinrich.schuchardt@canonical.com \
--cc=ilias.apalodimas@linaro.org \
--cc=jerome.forissier@linaro.org \
--cc=malysagreg@gmail.com \
--cc=marex@denx.de \
--cc=nathan.morrison@timesys.com \
--cc=paul.barker.ct@bp.renesas.com \
--cc=peng.fan@nxp.com \
--cc=quentin.schulz@cherry.de \
--cc=sjg@chromium.org \
--cc=trini@konsulko.com \
--cc=twoerner@gmail.com \
--cc=u-boot@lists.denx.de \
--cc=ye.li@nxp.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox