From: Tom Rini <trini@konsulko.com>
To: Raymond Mao <raymondmaoca@gmail.com>
Cc: u-boot@lists.denx.de
Subject: Re: [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF
Date: Tue, 7 Jul 2026 19:12:45 -0600 [thread overview]
Message-ID: <20260708011245.GO749385@bill-the-cat> (raw)
In-Reply-To: <CAMDkj5z3tTVxZeusOsNwjmfUr3qCAthBeRUQqgBpifZS4LDy7w@mail.gmail.com>
[-- Attachment #1: Type: text/plain, Size: 1008 bytes --]
On Tue, Jul 07, 2026 at 08:04:22PM -0400, Raymond Mao wrote:
> Hi Tom,
>
> On Tue, Jul 7, 2026 at 6:48 PM Tom Rini <trini@konsulko.com> wrote:
> >
> > Now that we have made bloblist have distinct "find" and "create"
> > functions, the global data tag "GD_FLG_BLOBLIST_READY" doesn't quite
> > make sense anymore. Rename it to GD_FLG_BLOBLIST_HANDOFF.
> >
> > Suggested-by: Raymond Mao <raymondmaoca@gmail.com>
> > Signed-off-by: Tom Rini <trini@konsulko.com>
> > ---
> > common/bloblist.c | 8 ++++----
> > include/asm-generic/global_data.h | 4 ++--
> > include/bloblist.h | 2 +-
> > 3 files changed, 7 insertions(+), 7 deletions(-)
> >
>
> Sounds good to me.
> Reviewed-by: Raymond Mao <raymondmaoca@gmail.com>
>
> BTW, do we need another flag for the locally allocated/static-assigned bloblist?
Probably not? But it's been a while since I put a lot thought into this
area. I had this sitting around and noticed I hadn't sent it.
--
Tom
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
next prev parent reply other threads:[~2026-07-08 1:12 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-07 22:48 [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF Tom Rini
2026-07-08 0:04 ` Raymond Mao
2026-07-08 1:12 ` Tom Rini [this message]
2026-07-18 0:07 ` Tom Rini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260708011245.GO749385@bill-the-cat \
--to=trini@konsulko.com \
--cc=raymondmaoca@gmail.com \
--cc=u-boot@lists.denx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox