* [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF
@ 2026-07-07 22:48 Tom Rini
2026-07-08 0:04 ` Raymond Mao
2026-07-18 0:07 ` Tom Rini
0 siblings, 2 replies; 4+ messages in thread
From: Tom Rini @ 2026-07-07 22:48 UTC (permalink / raw)
To: u-boot; +Cc: Raymond Mao
Now that we have made bloblist have distinct "find" and "create"
functions, the global data tag "GD_FLG_BLOBLIST_READY" doesn't quite
make sense anymore. Rename it to GD_FLG_BLOBLIST_HANDOFF.
Suggested-by: Raymond Mao <raymondmaoca@gmail.com>
Signed-off-by: Tom Rini <trini@konsulko.com>
---
common/bloblist.c | 8 ++++----
include/asm-generic/global_data.h | 4 ++--
include/bloblist.h | 2 +-
3 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/common/bloblist.c b/common/bloblist.c
index 51ae9cc50a5f..846c8047f746 100644
--- a/common/bloblist.c
+++ b/common/bloblist.c
@@ -448,7 +448,7 @@ int bloblist_new(ulong addr, uint size, uint flags, uint align_log2)
hdr->align_log2 = align_log2 ? align_log2 : BLOBLIST_BLOB_ALIGN_LOG2;
hdr->chksum = 0;
gd->bloblist = hdr;
- gd->flags |= GD_FLG_BLOBLIST_READY;
+ gd->flags |= GD_FLG_BLOBLIST_HANDOFF;
return 0;
}
@@ -476,7 +476,7 @@ int bloblist_check(ulong addr, uint size)
return log_msg_ret("Bad checksum", -EIO);
}
gd->bloblist = hdr;
- gd->flags |= GD_FLG_BLOBLIST_READY;
+ gd->flags |= GD_FLG_BLOBLIST_HANDOFF;
return 0;
}
@@ -627,7 +627,7 @@ int bloblist_init(void)
int ret;
ulong addr = 0, size = CONFIG_BLOBLIST_SIZE;
- if (gd->flags & GD_FLG_BLOBLIST_READY) {
+ if (gd->flags & GD_FLG_BLOBLIST_HANDOFF) {
log_debug("Found existing bloblist size %x at %p\n",
gd->bloblist->total_size, gd->bloblist);
return 0;
@@ -689,7 +689,7 @@ int bloblist_check_reg_conv(ulong rfdt, ulong rzero, ulong rsig, ulong xlist)
if (rfdt != (ulong)bloblist_find(BLOBLISTT_CONTROL_FDT, 0)) {
/* Remove this bloblist from gd */
gd->bloblist = NULL;
- gd->flags &= ~GD_FLG_BLOBLIST_READY;
+ gd->flags &= ~GD_FLG_BLOBLIST_HANDOFF;
return -EIO;
}
diff --git a/include/asm-generic/global_data.h b/include/asm-generic/global_data.h
index ad7ebb1bbc95..fd116b0cebf2 100644
--- a/include/asm-generic/global_data.h
+++ b/include/asm-generic/global_data.h
@@ -697,9 +697,9 @@ enum gd_flags {
*/
GD_FLG_DM_DEAD = 0x400000,
/**
- * @GD_FLG_BLOBLIST_READY: bloblist is ready for use
+ * @GD_FLG_BLOBLIST_HANDOFF: bloblist has been found.
*/
- GD_FLG_BLOBLIST_READY = 0x800000,
+ GD_FLG_BLOBLIST_HANDOFF = 0x800000,
/**
* @GD_FLG_HUSH_OLD_PARSER: Use hush old parser.
*/
diff --git a/include/bloblist.h b/include/bloblist.h
index 4c5787729654..fcd290eeb165 100644
--- a/include/bloblist.h
+++ b/include/bloblist.h
@@ -516,7 +516,7 @@ bool bloblist_exists(void);
* If CONFIG_BLOBLIST_PASSAGE_MANDATORY is selected, bloblist in the incoming
* standard passage is mandatorily required.
*
- * Sets GD_FLG_BLOBLIST_READY in global_data flags on success
+ * Sets GD_FLG_BLOBLIST_HANDOFF in global_data flags on success
*
* Return: 0 if OK, -ve on error
*/
--
2.43.0
^ permalink raw reply related [flat|nested] 4+ messages in thread
* Re: [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF
2026-07-07 22:48 [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF Tom Rini
@ 2026-07-08 0:04 ` Raymond Mao
2026-07-08 1:12 ` Tom Rini
2026-07-18 0:07 ` Tom Rini
1 sibling, 1 reply; 4+ messages in thread
From: Raymond Mao @ 2026-07-08 0:04 UTC (permalink / raw)
To: Tom Rini; +Cc: u-boot
Hi Tom,
On Tue, Jul 7, 2026 at 6:48 PM Tom Rini <trini@konsulko.com> wrote:
>
> Now that we have made bloblist have distinct "find" and "create"
> functions, the global data tag "GD_FLG_BLOBLIST_READY" doesn't quite
> make sense anymore. Rename it to GD_FLG_BLOBLIST_HANDOFF.
>
> Suggested-by: Raymond Mao <raymondmaoca@gmail.com>
> Signed-off-by: Tom Rini <trini@konsulko.com>
> ---
> common/bloblist.c | 8 ++++----
> include/asm-generic/global_data.h | 4 ++--
> include/bloblist.h | 2 +-
> 3 files changed, 7 insertions(+), 7 deletions(-)
>
Sounds good to me.
Reviewed-by: Raymond Mao <raymondmaoca@gmail.com>
BTW, do we need another flag for the locally allocated/static-assigned bloblist?
Regards,
Raymond
> diff --git a/common/bloblist.c b/common/bloblist.c
> index 51ae9cc50a5f..846c8047f746 100644
> --- a/common/bloblist.c
> +++ b/common/bloblist.c
> @@ -448,7 +448,7 @@ int bloblist_new(ulong addr, uint size, uint flags, uint align_log2)
> hdr->align_log2 = align_log2 ? align_log2 : BLOBLIST_BLOB_ALIGN_LOG2;
> hdr->chksum = 0;
> gd->bloblist = hdr;
> - gd->flags |= GD_FLG_BLOBLIST_READY;
> + gd->flags |= GD_FLG_BLOBLIST_HANDOFF;
>
> return 0;
> }
> @@ -476,7 +476,7 @@ int bloblist_check(ulong addr, uint size)
> return log_msg_ret("Bad checksum", -EIO);
> }
> gd->bloblist = hdr;
> - gd->flags |= GD_FLG_BLOBLIST_READY;
> + gd->flags |= GD_FLG_BLOBLIST_HANDOFF;
>
> return 0;
> }
> @@ -627,7 +627,7 @@ int bloblist_init(void)
> int ret;
> ulong addr = 0, size = CONFIG_BLOBLIST_SIZE;
>
> - if (gd->flags & GD_FLG_BLOBLIST_READY) {
> + if (gd->flags & GD_FLG_BLOBLIST_HANDOFF) {
> log_debug("Found existing bloblist size %x at %p\n",
> gd->bloblist->total_size, gd->bloblist);
> return 0;
> @@ -689,7 +689,7 @@ int bloblist_check_reg_conv(ulong rfdt, ulong rzero, ulong rsig, ulong xlist)
> if (rfdt != (ulong)bloblist_find(BLOBLISTT_CONTROL_FDT, 0)) {
> /* Remove this bloblist from gd */
> gd->bloblist = NULL;
> - gd->flags &= ~GD_FLG_BLOBLIST_READY;
> + gd->flags &= ~GD_FLG_BLOBLIST_HANDOFF;
> return -EIO;
> }
>
> diff --git a/include/asm-generic/global_data.h b/include/asm-generic/global_data.h
> index ad7ebb1bbc95..fd116b0cebf2 100644
> --- a/include/asm-generic/global_data.h
> +++ b/include/asm-generic/global_data.h
> @@ -697,9 +697,9 @@ enum gd_flags {
> */
> GD_FLG_DM_DEAD = 0x400000,
> /**
> - * @GD_FLG_BLOBLIST_READY: bloblist is ready for use
> + * @GD_FLG_BLOBLIST_HANDOFF: bloblist has been found.
> */
> - GD_FLG_BLOBLIST_READY = 0x800000,
> + GD_FLG_BLOBLIST_HANDOFF = 0x800000,
> /**
> * @GD_FLG_HUSH_OLD_PARSER: Use hush old parser.
> */
> diff --git a/include/bloblist.h b/include/bloblist.h
> index 4c5787729654..fcd290eeb165 100644
> --- a/include/bloblist.h
> +++ b/include/bloblist.h
> @@ -516,7 +516,7 @@ bool bloblist_exists(void);
> * If CONFIG_BLOBLIST_PASSAGE_MANDATORY is selected, bloblist in the incoming
> * standard passage is mandatorily required.
> *
> - * Sets GD_FLG_BLOBLIST_READY in global_data flags on success
> + * Sets GD_FLG_BLOBLIST_HANDOFF in global_data flags on success
> *
> * Return: 0 if OK, -ve on error
> */
> --
> 2.43.0
>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF
2026-07-08 0:04 ` Raymond Mao
@ 2026-07-08 1:12 ` Tom Rini
0 siblings, 0 replies; 4+ messages in thread
From: Tom Rini @ 2026-07-08 1:12 UTC (permalink / raw)
To: Raymond Mao; +Cc: u-boot
[-- Attachment #1: Type: text/plain, Size: 1008 bytes --]
On Tue, Jul 07, 2026 at 08:04:22PM -0400, Raymond Mao wrote:
> Hi Tom,
>
> On Tue, Jul 7, 2026 at 6:48 PM Tom Rini <trini@konsulko.com> wrote:
> >
> > Now that we have made bloblist have distinct "find" and "create"
> > functions, the global data tag "GD_FLG_BLOBLIST_READY" doesn't quite
> > make sense anymore. Rename it to GD_FLG_BLOBLIST_HANDOFF.
> >
> > Suggested-by: Raymond Mao <raymondmaoca@gmail.com>
> > Signed-off-by: Tom Rini <trini@konsulko.com>
> > ---
> > common/bloblist.c | 8 ++++----
> > include/asm-generic/global_data.h | 4 ++--
> > include/bloblist.h | 2 +-
> > 3 files changed, 7 insertions(+), 7 deletions(-)
> >
>
> Sounds good to me.
> Reviewed-by: Raymond Mao <raymondmaoca@gmail.com>
>
> BTW, do we need another flag for the locally allocated/static-assigned bloblist?
Probably not? But it's been a while since I put a lot thought into this
area. I had this sitting around and noticed I hadn't sent it.
--
Tom
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF
2026-07-07 22:48 [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF Tom Rini
2026-07-08 0:04 ` Raymond Mao
@ 2026-07-18 0:07 ` Tom Rini
1 sibling, 0 replies; 4+ messages in thread
From: Tom Rini @ 2026-07-18 0:07 UTC (permalink / raw)
To: u-boot, Tom Rini; +Cc: Raymond Mao
On Tue, 07 Jul 2026 16:48:42 -0600, Tom Rini wrote:
> Now that we have made bloblist have distinct "find" and "create"
> functions, the global data tag "GD_FLG_BLOBLIST_READY" doesn't quite
> make sense anymore. Rename it to GD_FLG_BLOBLIST_HANDOFF.
>
>
Applied to u-boot/main, thanks!
[1/1] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF
commit: a1a944f25c10dfa2ae3b344acbbeac39dc929bb8
--
Tom
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2026-07-18 0:08 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-07 22:48 [PATCH] bloblist: Rename GD_FLG_BLOBLIST_READY to GD_FLG_BLOBLIST_HANDOFF Tom Rini
2026-07-08 0:04 ` Raymond Mao
2026-07-08 1:12 ` Tom Rini
2026-07-18 0:07 ` Tom Rini
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox