U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Heinrich Schuchardt <heinrich.schuchardt@canonical.com>
To: Simon Glass <sjg@chromium.org>
Cc: Ilias Apalodimas <ilias.apalodimas@linaro.org>,
	Masahisa Kojima <masahisa.kojima@linaro.org>,
	u-boot@lists.denx.de
Subject: Re: [PATCH 1/1] test: avoid function name 'setup'
Date: Sun, 16 Jul 2023 15:37:56 +0200	[thread overview]
Message-ID: <58a4201b-0f97-c94a-6aaf-e3dffbfc4852@canonical.com> (raw)
In-Reply-To: <CAPnjgZ2W-fM-pEhFF6keShxyws17ZsKDyuhpvdQ-kTDwQdDN_Q@mail.gmail.com>



On 7/16/23 01:40, Simon Glass wrote:
> Hi Heinrich,
> 
> On Sat, 15 Jul 2023 at 03:05, Heinrich Schuchardt
> <heinrich.schuchardt@canonical.com> wrote:
>>
>> pytest 7.3.2 treats the function name 'setup' as a fixture [1].
>>
>> This leads to errors like:
>>
>>      TypeError: setup() missing 2 required positional arguments:
>>      'disk_img' and 'osindications'
>>
>> Rename setup() to capsule_setup().
>>
>> [1] How to run tests written for nose
>>      https://docs.pytest.org/en/7.3.x/how-to/nose.html
>>
>> Fixes: 482ef90aeb4c ("test: efi_capsule: refactor efi_capsule test")
>> Signed-off-by: Heinrich Schuchardt <heinrich.schuchardt@canonical.com>
>> ---
>>   test/py/tests/test_efi_capsule/capsule_common.py     |  2 +-
>>   .../test_efi_capsule/test_capsule_firmware_fit.py    | 10 +++++-----
>>   .../test_efi_capsule/test_capsule_firmware_raw.py    | 12 ++++++------
>>   .../test_capsule_firmware_signed_fit.py              | 12 ++++++------
>>   .../test_capsule_firmware_signed_raw.py              | 12 ++++++------
>>   5 files changed, 24 insertions(+), 24 deletions(-)
> 
> Reviewed-by: Simon Glass <sjg@chromium.org>
> 
> Would it make sense to reduce the code duplication a little?

Thank you for reviewing.

Fixed 482ef90aeb4c ("test: efi_capsule: refactor efi_capsule test")
started the de-duplication effort.

Best regards

Heinrich

  reply	other threads:[~2023-07-16 13:37 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-07-15  9:05 [PATCH 1/1] test: avoid function name 'setup' Heinrich Schuchardt
2023-07-15 23:40 ` Simon Glass
2023-07-16 13:37   ` Heinrich Schuchardt [this message]
2023-07-24 13:58     ` Ilias Apalodimas
2023-07-25 21:13 ` Tom Rini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=58a4201b-0f97-c94a-6aaf-e3dffbfc4852@canonical.com \
    --to=heinrich.schuchardt@canonical.com \
    --cc=ilias.apalodimas@linaro.org \
    --cc=masahisa.kojima@linaro.org \
    --cc=sjg@chromium.org \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox